aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-09-25 05:43:43 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-09-25 05:43:43 +0800
commite9f804c754d0ca85869c142c41e7933ab812b690 (patch)
tree9c988ed00636962eef6641552649de0ddfbb0552 /ports-mgmt
parent944e83fabc27315c2404cbdebb0f6d42a6324022 (diff)
downloadfreebsd-ports-gnome-e9f804c754d0ca85869c142c41e7933ab812b690.tar.gz
freebsd-ports-gnome-e9f804c754d0ca85869c142c41e7933ab812b690.tar.zst
freebsd-ports-gnome-e9f804c754d0ca85869c142c41e7933ab812b690.zip
- Fix staging of meta ports that have no files, such as
mail/squirrelmail-plugins Discussed with: bapt With hat: portmgr
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg/Makefile2
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__pkg_create.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 4b9ce8739c06..208a18137ed0 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pkg
DISTVERSION= 1.1.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= ports-mgmt
MASTER_SITES= http://files.etoilebsd.net/pkg/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/ \
diff --git a/ports-mgmt/pkg/files/patch-libpkg__pkg_create.c b/ports-mgmt/pkg/files/patch-libpkg__pkg_create.c
new file mode 100644
index 000000000000..4e7ddc1cbc91
--- /dev/null
+++ b/ports-mgmt/pkg/files/patch-libpkg__pkg_create.c
@@ -0,0 +1,11 @@
+--- ./libpkg/pkg_create.c.orig 2013-09-24 16:27:05.716245523 -0500
++++ ./libpkg/pkg_create.c 2013-09-24 16:27:17.642245427 -0500
+@@ -323,7 +323,7 @@
+ goto cleanup;
+ }
+
+- if (pkg_files(pkg, &file) != EPKG_OK &&
++ if (0 && pkg_files(pkg, &file) != EPKG_OK &&
+ pkg_dirs(pkg, &dir) != EPKG_OK) {
+ /* Now traverse the file directories, adding to the archive */
+ packing_append_tree(pkg_archive, md_dir, NULL);