aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2013-10-12 19:45:43 +0800
committercrees <crees@FreeBSD.org>2013-10-12 19:45:43 +0800
commitf0b57c7043ddfa5888e13dc6f44f5376c5cd6964 (patch)
tree4f2bef6541e28ec9f5a5cb55f5ecb0362666fe79 /ports-mgmt
parent18aa03b0b57fa2e5688df1abcdc68c788e1c5e5a (diff)
downloadfreebsd-ports-gnome-f0b57c7043ddfa5888e13dc6f44f5376c5cd6964.tar.gz
freebsd-ports-gnome-f0b57c7043ddfa5888e13dc6f44f5376c5cd6964.tar.zst
freebsd-ports-gnome-f0b57c7043ddfa5888e13dc6f44f5376c5cd6964.zip
Fix serious bug-- SRCBASE should be set for some iterations. Disable it
selectively rather than always. This stops the incorrect "building for: " value. Reported by: redports, danfe
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/tinderbox/Makefile2
-rw-r--r--ports-mgmt/tinderbox/files/patch-chroot45
2 files changed, 46 insertions, 1 deletions
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index f4362a73eca9..e6c50bd72d45 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tinderbox
PORTVERSION= 4.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ports-mgmt
MASTER_SITES= http://tinderbox.marcuscom.com/ \
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
diff --git a/ports-mgmt/tinderbox/files/patch-chroot b/ports-mgmt/tinderbox/files/patch-chroot
index b052be7f5f21..063aa3f621f5 100644
--- a/ports-mgmt/tinderbox/files/patch-chroot
+++ b/ports-mgmt/tinderbox/files/patch-chroot
@@ -363,3 +363,48 @@ diff -u -r1.176 tc_command.sh
}
addPortToBuild () {
+? .fslckout
+? .fslckout-mjFA3F63973
+Index: lib/tc_command.sh
+===================================================================
+RCS file: /space/cvs/marcuscom-cvs/portstools/tinderbox/lib/tc_command.sh,v
+retrieving revision 1.177
+diff -u -r1.177 tc_command.sh
+--- lib/tc_command.sh 8 Oct 2013 16:06:48 -0000 1.177
++++ lib/tc_command.sh 12 Oct 2013 11:27:28 -0000
+@@ -1973,6 +1973,8 @@
+ # Need to do this in a subshell so as to only hide the host
+ # environment during makefile creation
+ (
++ # Everything is done in chroot, so SRCBASE is relative to /
++ export SRCBASE=/usr/src
+ export PORTBUILD_ARGS="$(echo ${pbargs})"
+ buildenvNoHost ${build}
+ buildenv ${jail} ${portstree} ${build}
+@@ -2102,6 +2104,8 @@
+ if [ -n "${SRCBASE}" ]; then
+ save_SRCBASE=${SRCBASE}
+ fi
++ # Everything is done in chroot, so SRCBASE is relative to /
++ export SRCBASE=/usr/src
+
+ buildenv ${jail} ${portsTree} ${build}
+ buildenvNoHost ${build}
+Index: lib/tinderlib.sh
+===================================================================
+RCS file: /space/cvs/marcuscom-cvs/portstools/tinderbox/lib/tinderlib.sh,v
+retrieving revision 1.85
+diff -u -r1.85 tinderlib.sh
+--- lib/tinderlib.sh 7 Oct 2013 16:36:54 -0000 1.85
++++ lib/tinderlib.sh 12 Oct 2013 11:27:29 -0000
+@@ -506,7 +506,9 @@
+ save_IFS=${IFS}
+ IFS='
+ '
+- # Do not set SRCBASE here-- we use chroots nowadays so /usr/src is there
++ # Allow SRCBASE to be overridden
++ eval "export SRCBASE=${SRCBASE:-`realpath $(tinderLoc jail ${jail})/src`}" \
++ >/dev/null 2>&1
+
+ # Set ARCH (needed for cross-building)
+ export ARCH=$(${tc} getJailArch -j ${jail})