aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2014-10-29 06:55:13 +0800
committerohauer <ohauer@FreeBSD.org>2014-10-29 06:55:13 +0800
commitf85805361b9e05b064a1c574af4ca826a39699e0 (patch)
tree721e17601dba0914c368bd4c7c333bda1f23fc47 /ports-mgmt
parenta6b6b3fced53639013dc77485224676b99b978bb (diff)
downloadfreebsd-ports-gnome-f85805361b9e05b064a1c574af4ca826a39699e0.tar.gz
freebsd-ports-gnome-f85805361b9e05b064a1c574af4ca826a39699e0.tar.zst
freebsd-ports-gnome-f85805361b9e05b064a1c574af4ca826a39699e0.zip
- new port pkgcompare
This program provides for an alternate pkg upgrade procedure. Usage: pkg-compare [options] new_path old_path This program reads local.sqlite in new_path and compares list of installed packages in local.sqlite in old_path. If a package is found in old_path which is not in new_path then the name of the port is printed, one per line. Command line switches: -p prefix uninstalled packages with 'pkg install -Rf' -m show manually installed packages only, no deps WWW: https://github.com/waitman/pkg-compare PR: 186484 Submitted by: waitman@waitman.net
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/Makefile1
-rw-r--r--ports-mgmt/pkgcompare/Makefile46
-rw-r--r--ports-mgmt/pkgcompare/distinfo2
-rw-r--r--ports-mgmt/pkgcompare/files/pkg-message.in14
-rw-r--r--ports-mgmt/pkgcompare/pkg-descr6
5 files changed, 69 insertions, 0 deletions
diff --git a/ports-mgmt/Makefile b/ports-mgmt/Makefile
index a59447f9072a..a68f696a7f26 100644
--- a/ports-mgmt/Makefile
+++ b/ports-mgmt/Makefile
@@ -30,6 +30,7 @@
SUBDIR += pchecker
SUBDIR += pib
SUBDIR += pkg
+ SUBDIR += pkgcompare
SUBDIR += pkg-devel
SUBDIR += pkg-orphan
SUBDIR += pkg-plist
diff --git a/ports-mgmt/pkgcompare/Makefile b/ports-mgmt/pkgcompare/Makefile
new file mode 100644
index 000000000000..4ab591e95ae3
--- /dev/null
+++ b/ports-mgmt/pkgcompare/Makefile
@@ -0,0 +1,46 @@
+# Created by: "Waitman Gobble" <uzimac@da3m0n8t3r.com>
+# $FreeBSD$
+
+PORTNAME= pkgcompare
+PORTVERSION= 1.1
+CATEGORIES= ports-mgmt
+MASTER_SITES= GH
+DISTNAME= ${GH_ACCOUNT}-${GH_PROJECT}-${PORTVERSION}-0-g${GH_COMMIT}
+
+MAINTAINER= waitman@waitman.net
+COMMENT= Alternate to pkg upgrade
+
+LICENSE= PKG-COMPARE
+LICENSE_NAME= PKG-COMPARE BSD LICENSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= ${_LICENSE_PERMS_DEFAULT}
+
+LIB_DEPENDS= libpkg.so:${PORTSDIR}/ports-mgmt/pkg \
+ libsqlite3.so:${PORTSDIR}/databases/sqlite3
+
+USE_GITHUB= yes
+GH_ACCOUNT= waitman
+GH_PROJECT= pkg-compare
+GH_TAGNAME= 418295d
+GH_COMMIT= ${GH_TAGNAME}
+
+WRKSRC= ${WRKDIR}/waitman-pkg-compare-${GH_TAGNAME}
+
+BINARY= pkg-compare
+
+PORTDOCS= *
+PLIST_FILES= man/man8/pkg-compare.8.gz \
+ sbin/pkg-compare
+SUB_FILES= pkg-message
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${BINARY} ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/pkg-compare.8 \
+ ${STAGEDIR}${MAN8PREFIX}/man/man8
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${LICENSE_FILE} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/pkgcompare/distinfo b/ports-mgmt/pkgcompare/distinfo
new file mode 100644
index 000000000000..93a0f2268c3f
--- /dev/null
+++ b/ports-mgmt/pkgcompare/distinfo
@@ -0,0 +1,2 @@
+SHA256 (waitman-pkg-compare-1.1-0-g418295d.tar.gz) = edd3a18cb31728b9ab130c9a246add5b7c7cf3d9ecfb6a7298a31bcdc9a36d44
+SIZE (waitman-pkg-compare-1.1-0-g418295d.tar.gz) = 4159
diff --git a/ports-mgmt/pkgcompare/files/pkg-message.in b/ports-mgmt/pkgcompare/files/pkg-message.in
new file mode 100644
index 000000000000..cc9fde9adae1
--- /dev/null
+++ b/ports-mgmt/pkgcompare/files/pkg-message.in
@@ -0,0 +1,14 @@
+************************************************************************
+
+NOTICE
+
+man page is installed in %%LOCALBASE%%/man/man8, if you do not yet
+have the configuration in /etc/manpath.config, add
+
+OPTIONAL_MANPATH %%LOCALBASE%%/man
+
+to view all man pages which are installed in /usr/local/man/manX/
+
+
+************************************************************************
+
diff --git a/ports-mgmt/pkgcompare/pkg-descr b/ports-mgmt/pkgcompare/pkg-descr
new file mode 100644
index 000000000000..75686c8003fe
--- /dev/null
+++ b/ports-mgmt/pkgcompare/pkg-descr
@@ -0,0 +1,6 @@
+This program provides for an alternate pkg upgrade procedure.
+
+Move /usr/local to /usr/old-local and /var/db/pkg to /var/db/old-pkg,
+then use pkg-compare to generate a list of packages to install.
+
+WWW: https://github.com/waitman/pkg-compare