aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2014-04-22 22:44:04 +0800
committerbdrewery <bdrewery@FreeBSD.org>2014-04-22 22:44:04 +0800
commitfe46e686a2c271a5bd373c1e79bd5e2c99d85358 (patch)
tree408802a0613b481b6fc5d1d2034f94f83f31ae21 /ports-mgmt
parentcd5f6739681b9360593655f798ffd9f398e0ab5d (diff)
downloadfreebsd-ports-gnome-fe46e686a2c271a5bd373c1e79bd5e2c99d85358.tar.gz
freebsd-ports-gnome-fe46e686a2c271a5bd373c1e79bd5e2c99d85358.tar.zst
freebsd-ports-gnome-fe46e686a2c271a5bd373c1e79bd5e2c99d85358.zip
- Update to checkin 32a2683eca
Changes: - Queue is now priotitized by the dependency-chain length and not by number of direct dependencies. - Add PRIORITY_BOOST in poudriere.conf which takes PKGNAME globs to boost up to the top of the queue. Example: PRIORITY_BOOST="apache-openoffice* pypy* mysql-workbench*" - bulk/testport: Add -k to keep going on test failures. The failures are stll considered failures but do not skip further builds depending on that port. - bulk -at: This now defaults to -k - Leftovers and Orphan checking now uses the scripts in ports so we can update them frequently without a poudriere release and allow Tinderbox to use the same checks. [1] - This fixes many false-positives with orphans - Now @dirrm are not shown if they are already in the plist - Hook-up stage-qa into the tests and remove our redundant checks. - testport -i: Fix common double-install error - Fix leftover mtree not showing all results when a directory is modified. I.e., changed user and group, only one of which was showing. - bulk -a: Don't consider missing origins as fatal. - Rework distfile handling to be more atomic - Fix many race conditions with cleanup after port build, especially with skipping ports. - Optimize port cleanup after builds - Speedup compute_deps - Fix crashed build detection (commonly shows as "unknown stuck queue bug") - status: Fix regression causing it to not work with multiple builds at once [1] It's possible we may change the format of the scripts in ports once Tinderbox integrates with them. If this happens you will need to update poudriere-devel.
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/poudriere-devel/Makefile8
-rw-r--r--ports-mgmt/poudriere-devel/distinfo4
-rw-r--r--ports-mgmt/poudriere-devel/files/patch-Makefile.am21
-rw-r--r--ports-mgmt/poudriere-devel/files/patch-Makefile.in120
-rw-r--r--ports-mgmt/poudriere-devel/files/patch-src__poudriered__poudriered.c13
-rw-r--r--ports-mgmt/poudriere-devel/pkg-plist14
6 files changed, 13 insertions, 167 deletions
diff --git a/ports-mgmt/poudriere-devel/Makefile b/ports-mgmt/poudriere-devel/Makefile
index 7658ba465799..b0da9343caf4 100644
--- a/ports-mgmt/poudriere-devel/Makefile
+++ b/ports-mgmt/poudriere-devel/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= poudriere
-PORTVERSION= 3.0.99.20140320
-PORTREVISION= 1
+PORTVERSION= 3.0.99.20140419
CATEGORIES= ports-mgmt
MASTER_SITES= http://fossil.etoilebsd.net/poudriere/tarball/ \
LOCAL/bdrewery/${PORTNAME}/
@@ -16,9 +15,8 @@ LICENSE= BSD2CLAUSE
CONFLICTS_INSTALL= poudriere-[0-9]*
-FSL_CHKIN= 0966e62bc4
+FSL_CHKIN= 32a2683eca
-USES= uidfix
GNU_CONFIGURE= yes
ETCDIR= ${PREFIX}/etc/poudriere.d
@@ -28,10 +26,8 @@ OPTIONS_SUB= yes
.include <bsd.port.options.mk>
post-install:
-.if ${PORT_OPTIONS:MZSH}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions/
${INSTALL_DATA} ${WRKSRC}/completions/zsh/_poudriere \
${STAGEDIR}${PREFIX}/share/zsh/site-functions/
-.endif
.include <bsd.port.mk>
diff --git a/ports-mgmt/poudriere-devel/distinfo b/ports-mgmt/poudriere-devel/distinfo
index 51e9a9f7b601..e5e594879b28 100644
--- a/ports-mgmt/poudriere-devel/distinfo
+++ b/ports-mgmt/poudriere-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (poudriere-3.0.99.20140320.tar.gz?uuid=0966e62bc4) = 8f63df4003b8a09ef6f8fe0b2e14050bc2e742fb0d745080ce1a194d155cc268
-SIZE (poudriere-3.0.99.20140320.tar.gz?uuid=0966e62bc4) = 2364140
+SHA256 (poudriere-3.0.99.20140419.tar.gz?uuid=32a2683eca) = e8c1f877d4269afe4eed72cdc26eade50267bd96446002e5f145ba6a323d2471
+SIZE (poudriere-3.0.99.20140419.tar.gz?uuid=32a2683eca) = 2381322
diff --git a/ports-mgmt/poudriere-devel/files/patch-Makefile.am b/ports-mgmt/poudriere-devel/files/patch-Makefile.am
deleted file mode 100644
index b19756a934cc..000000000000
--- a/ports-mgmt/poudriere-devel/files/patch-Makefile.am
+++ /dev/null
@@ -1,21 +0,0 @@
---- ./Makefile.am.orig 2014-03-23 10:59:46.490421007 -0500
-+++ ./Makefile.am 2014-03-23 11:00:25.195417823 -0500
-@@ -12,6 +12,7 @@
- dtimagesdir= $(datatablesdir)/images
- dtjsdir= $(datatablesdir)/js
- rcdir= $(sysconfdir)/rc.d
-+hookdir= $(sysconfdir)/poudriere.d/hooks
-
- dist_bin_SCRIPTS= src/bin/poudriere
-
-@@ -20,6 +21,10 @@
- sysconf_DATA= src/etc/poudriere.conf.sample \
- src/etc/poudriered.conf.sample
-
-+hook_DATA= src/etc/poudriere.d/hooks/bulk.sh.sample \
-+ src/etc/poudriere.d/hooks/pkgbuild.sh.sample
-+
-+
- dist_pkgdata_DATA= src/share/poudriere/bulk.sh \
- src/share/poudriere/clean.sh \
- src/share/poudriere/common.sh \
diff --git a/ports-mgmt/poudriere-devel/files/patch-Makefile.in b/ports-mgmt/poudriere-devel/files/patch-Makefile.in
deleted file mode 100644
index a6f13e85fc1f..000000000000
--- a/ports-mgmt/poudriere-devel/files/patch-Makefile.in
+++ /dev/null
@@ -1,120 +0,0 @@
---- ./Makefile.in.orig 2014-03-23 10:59:51.978420717 -0500
-+++ ./Makefile.in 2014-03-23 11:00:31.953420721 -0500
-@@ -125,7 +125,8 @@
- "$(DESTDIR)$(btimgdir)" "$(DESTDIR)$(btjsdir)" \
- "$(DESTDIR)$(dtcssdir)" "$(DESTDIR)$(dtimagesdir)" \
- "$(DESTDIR)$(dtjsdir)" "$(DESTDIR)$(htmldir)" \
-- "$(DESTDIR)$(pkgdatadir)" "$(DESTDIR)$(sysconfdir)"
-+ "$(DESTDIR)$(pkgdatadir)" "$(DESTDIR)$(hookdir)" \
-+ "$(DESTDIR)$(sysconfdir)"
- PROGRAMS = $(pkglibexec_PROGRAMS) $(sbin_PROGRAMS)
- am_cpdup_OBJECTS = src/libexec/poudriere/cpdup/cpdup-cpdup.$(OBJEXT) \
- src/libexec/poudriere/cpdup/cpdup-hcproto.$(OBJEXT) \
-@@ -238,7 +239,7 @@
- DATA = $(dist_assets_DATA) $(dist_awk_DATA) $(dist_btcss_DATA) \
- $(dist_btimg_DATA) $(dist_btjs_DATA) $(dist_dtcss_DATA) \
- $(dist_dtimages_DATA) $(dist_dtjs_DATA) $(dist_html_DATA) \
-- $(dist_pkgdata_DATA) $(sysconf_DATA)
-+ $(dist_pkgdata_DATA) $(hook_DATA) $(sysconf_DATA)
- am__tagged_files = $(HEADERS) $(SOURCES) $(TAGS_FILES) $(LISP)
- # Read a list of newline-separated strings from the standard input,
- # and print each of them once, without duplicates. Input order is
-@@ -374,11 +375,15 @@
- dtimagesdir = $(datatablesdir)/images
- dtjsdir = $(datatablesdir)/js
- rcdir = $(sysconfdir)/rc.d
-+hookdir = $(sysconfdir)/poudriere.d/hooks
- dist_bin_SCRIPTS = src/bin/poudriere
- dist_man_MANS = src/bin/poudriere.8
- sysconf_DATA = src/etc/poudriere.conf.sample \
- src/etc/poudriered.conf.sample
-
-+hook_DATA = src/etc/poudriere.d/hooks/bulk.sh.sample \
-+ src/etc/poudriere.d/hooks/pkgbuild.sh.sample
-+
- dist_pkgdata_DATA = src/share/poudriere/bulk.sh \
- src/share/poudriere/clean.sh \
- src/share/poudriere/common.sh \
-@@ -1263,6 +1268,27 @@
- @list='$(dist_pkgdata_DATA)'; test -n "$(pkgdatadir)" || list=; \
- files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
- dir='$(DESTDIR)$(pkgdatadir)'; $(am__uninstall_files_from_dir)
-+install-hookDATA: $(hook_DATA)
-+ @$(NORMAL_INSTALL)
-+ @list='$(hook_DATA)'; test -n "$(hookdir)" || list=; \
-+ if test -n "$$list"; then \
-+ echo " $(MKDIR_P) '$(DESTDIR)$(hookdir)'"; \
-+ $(MKDIR_P) "$(DESTDIR)$(hookdir)" || exit 1; \
-+ fi; \
-+ for p in $$list; do \
-+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
-+ echo "$$d$$p"; \
-+ done | $(am__base_list) | \
-+ while read files; do \
-+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(hookdir)'"; \
-+ $(INSTALL_DATA) $$files "$(DESTDIR)$(hookdir)" || exit $$?; \
-+ done
-+
-+uninstall-hookDATA:
-+ @$(NORMAL_UNINSTALL)
-+ @list='$(hook_DATA)'; test -n "$(hookdir)" || list=; \
-+ files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
-+ dir='$(DESTDIR)$(hookdir)'; $(am__uninstall_files_from_dir)
- install-sysconfDATA: $(sysconf_DATA)
- @$(NORMAL_INSTALL)
- @list='$(sysconf_DATA)'; test -n "$(sysconfdir)" || list=; \
-@@ -1509,7 +1535,7 @@
- check: check-am
- all-am: Makefile $(LIBRARIES) $(PROGRAMS) $(SCRIPTS) $(MANS) $(DATA)
- installdirs:
-- for dir in "$(DESTDIR)$(pkglibexecdir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(rcdir)" "$(DESTDIR)$(man8dir)" "$(DESTDIR)$(assetsdir)" "$(DESTDIR)$(awkdir)" "$(DESTDIR)$(btcssdir)" "$(DESTDIR)$(btimgdir)" "$(DESTDIR)$(btjsdir)" "$(DESTDIR)$(dtcssdir)" "$(DESTDIR)$(dtimagesdir)" "$(DESTDIR)$(dtjsdir)" "$(DESTDIR)$(htmldir)" "$(DESTDIR)$(pkgdatadir)" "$(DESTDIR)$(sysconfdir)"; do \
-+ for dir in "$(DESTDIR)$(pkglibexecdir)" "$(DESTDIR)$(sbindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(rcdir)" "$(DESTDIR)$(man8dir)" "$(DESTDIR)$(assetsdir)" "$(DESTDIR)$(awkdir)" "$(DESTDIR)$(btcssdir)" "$(DESTDIR)$(btimgdir)" "$(DESTDIR)$(btjsdir)" "$(DESTDIR)$(dtcssdir)" "$(DESTDIR)$(dtimagesdir)" "$(DESTDIR)$(dtjsdir)" "$(DESTDIR)$(htmldir)" "$(DESTDIR)$(pkgdatadir)" "$(DESTDIR)$(hookdir)" "$(DESTDIR)$(sysconfdir)"; do \
- test -z "$$dir" || $(MKDIR_P) "$$dir"; \
- done
- install: install-am
-@@ -1588,7 +1614,7 @@
- install-dist_btjsDATA install-dist_dtcssDATA \
- install-dist_dtimagesDATA install-dist_dtjsDATA \
- install-dist_htmlDATA install-dist_pkgdataDATA \
-- install-dist_rcSCRIPTS install-man
-+ install-dist_rcSCRIPTS install-hookDATA install-man
-
- install-dvi: install-dvi-am
-
-@@ -1642,7 +1668,7 @@
- uninstall-dist_dtcssDATA uninstall-dist_dtimagesDATA \
- uninstall-dist_dtjsDATA uninstall-dist_htmlDATA \
- uninstall-dist_pkgdataDATA uninstall-dist_rcSCRIPTS \
-- uninstall-man uninstall-pkglibexecPROGRAMS \
-+ uninstall-hookDATA uninstall-man uninstall-pkglibexecPROGRAMS \
- uninstall-sbinPROGRAMS uninstall-sysconfDATA
-
- uninstall-man: uninstall-man8
-@@ -1664,10 +1690,10 @@
- install-dist_dtimagesDATA install-dist_dtjsDATA \
- install-dist_htmlDATA install-dist_pkgdataDATA \
- install-dist_rcSCRIPTS install-dvi install-dvi-am install-exec \
-- install-exec-am install-html install-html-am install-info \
-- install-info-am install-man install-man8 install-pdf \
-- install-pdf-am install-pkglibexecPROGRAMS install-ps \
-- install-ps-am install-sbinPROGRAMS install-strip \
-+ install-exec-am install-hookDATA install-html install-html-am \
-+ install-info install-info-am install-man install-man8 \
-+ install-pdf install-pdf-am install-pkglibexecPROGRAMS \
-+ install-ps install-ps-am install-sbinPROGRAMS install-strip \
- install-sysconfDATA installcheck installcheck-am installdirs \
- maintainer-clean maintainer-clean-generic mostlyclean \
- mostlyclean-compile mostlyclean-generic pdf pdf-am ps ps-am \
-@@ -1677,9 +1703,9 @@
- uninstall-dist_btjsDATA uninstall-dist_dtcssDATA \
- uninstall-dist_dtimagesDATA uninstall-dist_dtjsDATA \
- uninstall-dist_htmlDATA uninstall-dist_pkgdataDATA \
-- uninstall-dist_rcSCRIPTS uninstall-man uninstall-man8 \
-- uninstall-pkglibexecPROGRAMS uninstall-sbinPROGRAMS \
-- uninstall-sysconfDATA
-+ uninstall-dist_rcSCRIPTS uninstall-hookDATA uninstall-man \
-+ uninstall-man8 uninstall-pkglibexecPROGRAMS \
-+ uninstall-sbinPROGRAMS uninstall-sysconfDATA
-
-
- .PHONY: gen-make-wiki
diff --git a/ports-mgmt/poudriere-devel/files/patch-src__poudriered__poudriered.c b/ports-mgmt/poudriere-devel/files/patch-src__poudriered__poudriered.c
deleted file mode 100644
index 5ab96a8212db..000000000000
--- a/ports-mgmt/poudriere-devel/files/patch-src__poudriered__poudriered.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./src/poudriered/poudriered.c.orig 2014-03-23 11:01:01.147420893 -0500
-+++ ./src/poudriered/poudriered.c 2014-03-23 11:01:25.271419416 -0500
-@@ -669,8 +669,8 @@
- dateformat == NULL)
- continue;
-
-- if (strftime_l(datestr, BUFSIZ, ucl_object_tostring(dateformat),
-- now, NULL) <= 0)
-+ if (strftime(datestr, BUFSIZ, ucl_object_tostring(dateformat),
-+ now) <= 0)
- continue;
-
- if (!strcmp(datestr, ucl_object_tostring(when))) {
diff --git a/ports-mgmt/poudriere-devel/pkg-plist b/ports-mgmt/poudriere-devel/pkg-plist
index ba5845f7c1cd..844a1e92b86f 100644
--- a/ports-mgmt/poudriere-devel/pkg-plist
+++ b/ports-mgmt/poudriere-devel/pkg-plist
@@ -7,20 +7,24 @@ etc/rc.d/poudriered
libexec/poudriere/cpdup
libexec/poudriere/dirempty
libexec/poudriere/dirwatch
-libexec/poudriere/make_index
libexec/poudriere/nc
libexec/poudriere/rename
+libexec/poudriere/tsort
sbin/poudriered
man/man8/poudriere.8.gz
%%DATADIR%%/awk/dependency_loop.awk
%%DATADIR%%/awk/humanize.awk
%%DATADIR%%/awk/json.awk
%%DATADIR%%/awk/siginfo_buildtime.awk
+%%DATADIR%%/awk/processonelog2.awk
+%%DATADIR%%/include/common.sh.dragonfly
+%%DATADIR%%/include/common.sh.freebsd
+%%DATADIR%%/include/fs.sh
+%%DATADIR%%/include/hash.sh
+%%DATADIR%%/include/parallel.sh
%%DATADIR%%/bulk.sh
%%DATADIR%%/clean.sh
%%DATADIR%%/common.sh
-%%DATADIR%%/common.sh.dragonfly
-%%DATADIR%%/common.sh.freebsd
%%DATADIR%%/daemon.sh
%%DATADIR%%/distclean.sh
%%DATADIR%%/html/assets/bootstrap/css/bootstrap-responsive.min.css
@@ -51,13 +55,13 @@ man/man8/poudriere.8.gz
%%DATADIR%%/pkgclean.sh
%%DATADIR%%/ports.sh
%%DATADIR%%/processonelog.sh
-%%DATADIR%%/processonelog2.sh
%%DATADIR%%/queue.sh
%%DATADIR%%/status.sh
%%DATADIR%%/testport.sh
%%ZSH%%share/zsh/site-functions/_poudriere
%%ZSH%%@dirrmtry share/zsh/site-functions
%%ZSH%%@dirrmtry share/zsh/
+@dirrm %%DATADIR%%/awk
@dirrm %%DATADIR%%/html/assets/dataTables/js
@dirrm %%DATADIR%%/html/assets/dataTables/images
@dirrm %%DATADIR%%/html/assets/dataTables/css
@@ -68,7 +72,7 @@ man/man8/poudriere.8.gz
@dirrm %%DATADIR%%/html/assets/bootstrap
@dirrm %%DATADIR%%/html/assets
@dirrm %%DATADIR%%/html
-@dirrm %%DATADIR%%/awk
+@dirrm %%DATADIR%%/include
@dirrm %%DATADIR%%
@dirrm libexec/poudriere
@dirrmtry %%ETCDIR%%