aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-30 02:41:15 +0800
committeradamw <adamw@FreeBSD.org>2014-07-30 02:41:15 +0800
commit38fe74289962f7bde8f57d9a999e61b74241ad6b (patch)
treec756810defa7862a81134a13cec391bfef55e24e /ports-mgmt
parentf9ace8477d074484a12cc946b59a8aab04d0810f (diff)
downloadfreebsd-ports-gnome-38fe74289962f7bde8f57d9a999e61b74241ad6b.tar.gz
freebsd-ports-gnome-38fe74289962f7bde8f57d9a999e61b74241ad6b.tar.zst
freebsd-ports-gnome-38fe74289962f7bde8f57d9a999e61b74241ad6b.zip
Convert a bunch of USE_BZIP2 to USES=tar:bzip2
Approved by: portmgr (not really, but touches unstaged ports)
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/bxpkg/Makefile3
-rw-r--r--ports-mgmt/kpackagekit/Makefile3
-rw-r--r--ports-mgmt/kports-qt4/Makefile3
-rw-r--r--ports-mgmt/p5-FreeBSD-Ports/Makefile3
-rw-r--r--ports-mgmt/portrac/Makefile3
5 files changed, 5 insertions, 10 deletions
diff --git a/ports-mgmt/bxpkg/Makefile b/ports-mgmt/bxpkg/Makefile
index 44654ff3314f..87e11bbca592 100644
--- a/ports-mgmt/bxpkg/Makefile
+++ b/ports-mgmt/bxpkg/Makefile
@@ -11,12 +11,11 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK+ based tool to manage binary packages on BSD systems
-USES= pkgconfig
+USES= pkgconfig tar:bzip2
USE_XORG= x11
USE_GNOME= gtk20
PLIST_FILES= bin/bxpkg
-USE_BZIP2= YES
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
diff --git a/ports-mgmt/kpackagekit/Makefile b/ports-mgmt/kpackagekit/Makefile
index 909c002e6acc..39d6a4d9cfab 100644
--- a/ports-mgmt/kpackagekit/Makefile
+++ b/ports-mgmt/kpackagekit/Makefile
@@ -15,10 +15,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpackagekit-qt.so:${PORTSDIR}/ports-mgmt/packagekit-qt4
-USE_BZIP2= yes
USE_KDE4= automoc4 kdehier kdelibs kdeprefix
USE_QT4= moc_build qmake_build rcc_build uic_build
-USES= cmake gettext pkgconfig
+USES= cmake gettext pkgconfig tar:bzip2
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
diff --git a/ports-mgmt/kports-qt4/Makefile b/ports-mgmt/kports-qt4/Makefile
index 98021101b5c2..e87a122a7fdd 100644
--- a/ports-mgmt/kports-qt4/Makefile
+++ b/ports-mgmt/kports-qt4/Makefile
@@ -15,8 +15,7 @@ RUN_DEPENDS= portaudit:${PORTSDIR}/ports-mgmt/portaudit \
CONFLICTS= kports-0.[0-7]*
-USE_BZIP2= yes
-USES= qmake
+USES= qmake tar:bzip2
USE_QT4= corelib gui network moc_build uic_build rcc_build
OPTIONS_DEFINE= DEBUG OXYGEN KDEBASE
diff --git a/ports-mgmt/p5-FreeBSD-Ports/Makefile b/ports-mgmt/p5-FreeBSD-Ports/Makefile
index 04bef7bd10f8..d4ea6abf7a05 100644
--- a/ports-mgmt/p5-FreeBSD-Ports/Makefile
+++ b/ports-mgmt/p5-FreeBSD-Ports/Makefile
@@ -11,9 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl modules for parsing FreeBSD's Ports INDEX file
-USE_BZIP2= yes
-USES= perl5
+USES= perl5 tar:bzip2
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/ports-mgmt/portrac/Makefile b/ports-mgmt/portrac/Makefile
index fbf55c14683d..e61b2909d292 100644
--- a/ports-mgmt/portrac/Makefile
+++ b/ports-mgmt/portrac/Makefile
@@ -20,8 +20,7 @@ PLIST_FILES= bin/portrac \
PLIST_DIRS= share/portrac
-USES= qmake
-USE_BZIP2= yes
+USES= qmake tar:bzip2
USE_QT4= gui moc_build
do-install: