aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-08-16 13:51:17 +0800
committermiwi <miwi@FreeBSD.org>2006-08-16 13:51:17 +0800
commit507a69380f53efe2b814361dc547578d356b5996 (patch)
tree92242edc444750089e9844a0b6eea4377892a327 /ports-mgmt
parenta11b02c6c546265ce375cd72778b5fd82b94d814 (diff)
downloadfreebsd-ports-gnome-507a69380f53efe2b814361dc547578d356b5996.tar.gz
freebsd-ports-gnome-507a69380f53efe2b814361dc547578d356b5996.tar.zst
freebsd-ports-gnome-507a69380f53efe2b814361dc547578d356b5996.zip
- Respect DESTDIR
PR: ports/102011 Submitted by: Matthew Seaman <m.seaman(at)infracaninophile.co.uk> Approved by: krion (mentor)
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/p5-FreeBSD-Portindex/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/ports-mgmt/p5-FreeBSD-Portindex/Makefile b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
index c106aa6b7a3e..8c87cd042cab 100644
--- a/ports-mgmt/p5-FreeBSD-Portindex/Makefile
+++ b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_BZIP2= yes
PERL_CONFIGURE= yes
-CACHE_DIR?= /var/db/portindex
+CACHE_DIR?= ${DESTDIR}/var/db/portindex
CACHE_OWNER?= root
CACHE_GROUP?= operator
CACHE_MODE?= 0775
@@ -45,8 +45,8 @@ post-install: install-conf install-cache
install-conf:
cd ${WRKSRC} ; \
- ${INSTALL_DATA} ${CFG_FILE}.sample ${PREFIX}/etc/${CFG_FILE}.sample
- cd ${PREFIX}/etc ; \
+ ${INSTALL_DATA} ${CFG_FILE}.sample ${TARGETDIR}/etc/${CFG_FILE}.sample
+ cd ${TARGETDIR}/etc ; \
if ${TEST} ! -f ${CFG_FILE} ; then \
${CP} -p ${CFG_FILE}.sample ${CFG_FILE} ; \
fi