aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2009-03-28 18:54:23 +0800
committeritetcu <itetcu@FreeBSD.org>2009-03-28 18:54:23 +0800
commit56d3af8f119fdf8f2ab0653f3155946a8c883197 (patch)
tree948aaf25c2ea0ba8df851db70cad92b719580c45 /ports-mgmt
parent5270ebb7d149ae0975df8696b741eabcc25171d6 (diff)
downloadfreebsd-ports-gnome-56d3af8f119fdf8f2ab0653f3155946a8c883197.tar.gz
freebsd-ports-gnome-56d3af8f119fdf8f2ab0653f3155946a8c883197.tar.zst
freebsd-ports-gnome-56d3af8f119fdf8f2ab0653f3155946a8c883197.zip
Pull two fixes from CVS:
- Properly check the result of getDbInfo to make sure we don't try to configure the database when we don't have access. - Correct a typo which broken copyBuild for packages. Bump PORTREVISION.
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile2
-rw-r--r--ports-mgmt/tinderbox-devel/files/patch-lib__tc_command.pl22
-rw-r--r--ports-mgmt/tinderbox-devel/files/patch-lib__tc_command.sh24
3 files changed, 47 insertions, 1 deletions
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 5b3e3791e7d2..a7cb3ab80bdc 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -6,7 +6,7 @@
PORTNAME= tinderbox
PORTVERSION= 3.2
-PORTREVISION= 1 # 2009-03-25
+PORTREVISION= 2 # 2009-03-27
CATEGORIES= ports-mgmt
MASTER_SITES= http://tinderbox.marcuscom.com/ \
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
diff --git a/ports-mgmt/tinderbox-devel/files/patch-lib__tc_command.pl b/ports-mgmt/tinderbox-devel/files/patch-lib__tc_command.pl
new file mode 100644
index 000000000000..edf7235b4dab
--- /dev/null
+++ b/ports-mgmt/tinderbox-devel/files/patch-lib__tc_command.pl
@@ -0,0 +1,22 @@
+Index: portstools/tinderbox/lib/tc_command.pl
+diff -u portstools/tinderbox/lib/tc_command.pl:1.150.2.12 portstools/tinderbox/lib/tc_command.pl:1.150.2.13
+--- ./lib/tc_command.pl:1.150.2.12 Wed Feb 11 03:50:34 2009
++++ ./lib/tc_command.pl Fri Mar 27 00:16:27 2009
+@@ -24,7 +24,7 @@
+ # OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ # SUCH DAMAGE.
+ #
+-# $MCom: portstools/tinderbox/lib/tc_command.pl,v 1.150.2.12 2009/02/11 08:50:34 beat Exp $
++# $MCom: portstools/tinderbox/lib/tc_command.pl,v 1.150.2.13 2009/03/27 04:16:27 marcus Exp $
+ #
+
+ my $pb;
+@@ -3090,7 +3090,7 @@
+ }
+
+ $rc =
+- $ds->updatePortLastBuiltStatus($port, $dest,
++ $ds->updatePortLastStatus($port, $dest,
+ $ds->getPortLastBuiltStatus($port, $src));
+ if (!$rc) {
+ warn
diff --git a/ports-mgmt/tinderbox-devel/files/patch-lib__tc_command.sh b/ports-mgmt/tinderbox-devel/files/patch-lib__tc_command.sh
new file mode 100644
index 000000000000..3eeba7921a0f
--- /dev/null
+++ b/ports-mgmt/tinderbox-devel/files/patch-lib__tc_command.sh
@@ -0,0 +1,24 @@
+Index: portstools/tinderbox/lib/tc_command.sh
+diff -u portstools/tinderbox/lib/tc_command.sh:1.101.2.14 portstools/tinderbox/lib/tc_command.sh:1.101.2.15
+--- ./lib/tc_command.sh:1.101.2.14 Sun Feb 15 12:22:28 2009
++++ ./lib/tc_command.sh Fri Mar 27 23:52:57 2009
+@@ -24,7 +24,7 @@
+ # OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ # SUCH DAMAGE.
+ #
+-# $MCom: portstools/tinderbox/lib/tc_command.sh,v 1.101.2.14 2009/02/15 17:22:28 marcus Exp $
++# $MCom: portstools/tinderbox/lib/tc_command.sh,v 1.101.2.15 2009/03/28 03:52:57 marcus Exp $
+ #
+
+ export _defaultUpdateHost="cvsup12.FreeBSD.org"
+@@ -247,8 +247,9 @@
+ do_load=0
+ db_driver=$(getDbDriver)
+ dbinfo=$(getDbInfo ${db_driver})
++ db_res=$?
+ genschema=$(tinderLoc scripts sql/genschema)
+- if [ $? = 0 ]; then
++ if [ ${db_res} = 0 ]; then
+ db_admin_host_name=${dbinfo%:*}
+ db_admin_host=${db_admin_host_name%:*}
+ db_name=${db_admin_host_name##*:}