aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2014-02-12 06:50:26 +0800
committermandree <mandree@FreeBSD.org>2014-02-12 06:50:26 +0800
commit7d81f6f00d80b9d9a00a73e2e3f3e89d5a7c00e8 (patch)
tree069942b9fdd9fbeda3a81e3135add03741f7ea83 /ports-mgmt
parent677f4618a6de0cd4a8f28602d3ec7c1514bd1945 (diff)
downloadfreebsd-ports-gnome-7d81f6f00d80b9d9a00a73e2e3f3e89d5a7c00e8.tar.gz
freebsd-ports-gnome-7d81f6f00d80b9d9a00a73e2e3f3e89d5a7c00e8.tar.zst
freebsd-ports-gnome-7d81f6f00d80b9d9a00a73e2e3f3e89d5a7c00e8.zip
0.4.1 2014-02-11
- do not require files given on command line are regular files, but accept any non-directory (for instance, symlinks). Workaround for previous versions: use --no-find if you intend to look up non-regular files.
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkgs_which/Makefile2
-rw-r--r--ports-mgmt/pkgs_which/files/pkgs_which9
2 files changed, 9 insertions, 2 deletions
diff --git a/ports-mgmt/pkgs_which/Makefile b/ports-mgmt/pkgs_which/Makefile
index be41c7707f73..9937fbefa1bb 100644
--- a/ports-mgmt/pkgs_which/Makefile
+++ b/ports-mgmt/pkgs_which/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pkgs_which
-PORTVERSION= 0.4.0
+PORTVERSION= 0.4.1
CATEGORIES= ports-mgmt perl5
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/pkgs_which/files/pkgs_which b/ports-mgmt/pkgs_which/files/pkgs_which
index c5ae20b8a9b8..a9789e5825ad 100644
--- a/ports-mgmt/pkgs_which/files/pkgs_which
+++ b/ports-mgmt/pkgs_which/files/pkgs_which
@@ -298,7 +298,7 @@ exit $rc;
sub wanted {
my ($dev,$ino,$mode,$nlink,$uid,$gid);
- if ((($dev,$ino,$mode,$nlink,$uid,$gid) = lstat($_)) && -f _)
+ if ((($dev,$ino,$mode,$nlink,$uid,$gid) = lstat($_)) && ! -d _)
{
# only record clean names
if ($_ =~ $UNTAINT and $1) {
@@ -406,6 +406,13 @@ L<pkg_info>(8), L<portmaster>(8), L<portupgrade>(8), L<pkg_which>(8)
=head1 HISTORY
+0.4.1 2014-02-11
+ - do not require files given on command line are regular files,
+ but accept any non-directory (for instance, symlinks).
+
+ Workaround for previous versions: use --no-find if you intend to
+ look up non-regular files.
+
0.4.0 2013-11-28
- support pkgNG. Known issue is that pkg which returns bogus exit
codes, spamming your screen. pkgs_which works nonetheless.