aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2009-06-04 08:08:29 +0800
committerlinimon <linimon@FreeBSD.org>2009-06-04 08:08:29 +0800
commit812c87a1bf8dc3b6dce5f973cec4f2d0d7eee62a (patch)
treea058d67c1164d8ffa0ab8f7ca9021031ac0b5a8e /ports-mgmt
parentfcbaec9a50c92fb9b2f28cfa7b7f0d75bb665476 (diff)
downloadfreebsd-ports-gnome-812c87a1bf8dc3b6dce5f973cec4f2d0d7eee62a.tar.gz
freebsd-ports-gnome-812c87a1bf8dc3b6dce5f973cec4f2d0d7eee62a.tar.zst
freebsd-ports-gnome-812c87a1bf8dc3b6dce5f973cec4f2d0d7eee62a.zip
Catch up with master 1.620.
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portmk/Mk/bsd.port.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/ports-mgmt/portmk/Mk/bsd.port.mk b/ports-mgmt/portmk/Mk/bsd.port.mk
index 0cf7a1415505..84792f7e8f6c 100644
--- a/ports-mgmt/portmk/Mk/bsd.port.mk
+++ b/ports-mgmt/portmk/Mk/bsd.port.mk
@@ -307,6 +307,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# the regular expression.
# USE_GCC - If set, this port requires this version of gcc, either in
# the system or installed from a port.
+# USE_CSTD - Override the default C language standard (gnu89, gnu99)
# USE_GMAKE - If set, this port uses gmake.
# GMAKE - Set to path of GNU make if not in $PATH.
# Default: gmake
@@ -2408,16 +2409,17 @@ CFLAGS+= -fno-strict-aliasing
.endif
.endif
+.if defined(USE_CSTD)
+CFLAGS:= ${CFLAGS:N-std=*} -std=${USE_CSTD}
+.endif
+
# Multiple make jobs support
.if defined(DISABLE_MAKE_JOBS) || defined(MAKE_JOBS_UNSAFE)
_MAKE_JOBS= #
.else
.if defined(MAKE_JOBS_SAFE) || defined(FORCE_MAKE_JOBS)
-.if defined(MAKE_JOBS_NUMBER)
+MAKE_JOBS_NUMBER?= `${SYSCTL} -n kern.smp.cpus`
_MAKE_JOBS= -j${MAKE_JOBS_NUMBER}
-.else
-_MAKE_JOBS= -j`${SYSCTL} -n kern.smp.cpus`
-.endif
.if defined(FORCE_MAKE_JOBS)
BUILD_FAIL_MESSAGE+= "You have chosen to use multiple make jobs (parallelization) for all ports. This port was not tested for this setting. Please remove FORCE_MAKE_JOBS and retry the build before reporting the failure to the maintainer."
.endif