aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-01-07 01:59:31 +0800
committerpav <pav@FreeBSD.org>2009-01-07 01:59:31 +0800
commit8ef21a396d8627cdfced24744c2bacb7cb0c9453 (patch)
tree06fbb407306ac7e1b7b00946df69737e787c8891 /ports-mgmt
parente32973556a174646ad93cdf1b43963a9fc18eb55 (diff)
downloadfreebsd-ports-gnome-8ef21a396d8627cdfced24744c2bacb7cb0c9453.tar.gz
freebsd-ports-gnome-8ef21a396d8627cdfced24744c2bacb7cb0c9453.tar.zst
freebsd-ports-gnome-8ef21a396d8627cdfced24744c2bacb7cb0c9453.zip
- Remove conditional checks for FreeBSD 5.x and older
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/jailaudit/Makefile8
-rw-r--r--ports-mgmt/pkg_install/Makefile10
-rw-r--r--ports-mgmt/pkg_trackinst/Makefile8
-rw-r--r--ports-mgmt/pkgfe/Makefile8
4 files changed, 5 insertions, 29 deletions
diff --git a/ports-mgmt/jailaudit/Makefile b/ports-mgmt/jailaudit/Makefile
index 1081a43d61c4..e123f5aba28c 100644
--- a/ports-mgmt/jailaudit/Makefile
+++ b/ports-mgmt/jailaudit/Makefile
@@ -25,10 +25,4 @@ PLIST_SUB+= PERIODICDIR="${PERIODICDIR:S,^${PREFIX}/,,}" \
REPORTDIR="${REPORTDIR:S,^${PREFIX}/,,}" \
TMPDIR="${TMPDIR:S,^${PREFIX}/,,}"
-.include <bsd.port.pre.mk>
-
-.if ( ${OSVERSION} < 501000 )
-IGNORE= needs the jls utility which was added in FreeBSD 5.1
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ports-mgmt/pkg_install/Makefile b/ports-mgmt/pkg_install/Makefile
index 0da84c100a51..1ade816e3252 100644
--- a/ports-mgmt/pkg_install/Makefile
+++ b/ports-mgmt/pkg_install/Makefile
@@ -16,21 +16,15 @@ MAINTAINER= portmgr@FreeBSD.org
COMMENT= FreeBSD -STABLE version of the package tools
MANCOMPRESSED= yes
-
MAN1= pkg_add.1 pkg_create.1 pkg_delete.1 \
pkg_info.1 pkg_updating.1 pkg_version.1
+MAKE_ARGS= -DNO_OBJ -DNO_CRYPT -DNO_OPENSSL
+
OPTIONS= WRAPPER "Use ports version instead of base if more recent" on
.include <bsd.port.pre.mk>
-# Arbitrary OSVERSION but support for 5.x will go away soon anyway...
-.if ${OSVERSION} < 600000
-MAKE_ARGS= -DNOOBJ -DNOCRYPT -DNO_OPENSSL
-.else
-MAKE_ARGS= -DNO_OBJ -DNO_CRYPT -DNO_OPENSSL
-.endif
-
pre-configure:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%MANPREFIX%%,${MANPREFIX},g' \
diff --git a/ports-mgmt/pkg_trackinst/Makefile b/ports-mgmt/pkg_trackinst/Makefile
index d93855212296..e2c9a87ae0ba 100644
--- a/ports-mgmt/pkg_trackinst/Makefile
+++ b/ports-mgmt/pkg_trackinst/Makefile
@@ -16,14 +16,8 @@ USE_PYTHON= 2.3+
INSTALLS_EGGINFO= yes
MAKE_ENV= PYTHON_CMD=${PYTHON_CMD}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 501105
-IGNORE= requires dynamically-linked base programs
-.endif
-
post-patch:
${REINPLACE_CMD} 's,/usr/local,${PREFIX},g' \
${WRKSRC}/PkgTrackInst/cmd_support.py
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ports-mgmt/pkgfe/Makefile b/ports-mgmt/pkgfe/Makefile
index 3667217cff76..d00bfd7e9d61 100644
--- a/ports-mgmt/pkgfe/Makefile
+++ b/ports-mgmt/pkgfe/Makefile
@@ -21,12 +21,6 @@ RUN_DEPENDS= portupgrade:${PORTSDIR}/ports-mgmt/portupgrade \
MAN8= pkgfe.8
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600033 && ( ${OSVERSION} < 504103 || ${OSVERSION} > 600000 )
-RUN_DEPENDS+= portsnap:${PORTSDIR}/ports-mgmt/portsnap
-.endif
-
NO_BUILD= yes
do-install:
@@ -40,4 +34,4 @@ post-install:
${CP} -p ${PREFIX}/etc/pkgfe.conf.sample ${PREFIX}/etc/pkgfe.conf ; \
fi
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>