aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2000-10-09 19:45:46 +0800
committerdes <des@FreeBSD.org>2000-10-09 19:45:46 +0800
commit9ecf5c3066f24b12f084be1ed3521c0af8e404e1 (patch)
treef3339b23a1235763f905c006c43f6460820cf224 /ports-mgmt
parentf493372ba423ef79e4cc1ecba4cbf7382d6a3e30 (diff)
downloadfreebsd-ports-gnome-9ecf5c3066f24b12f084be1ed3521c0af8e404e1.tar.gz
freebsd-ports-gnome-9ecf5c3066f24b12f084be1ed3521c0af8e404e1.tar.zst
freebsd-ports-gnome-9ecf5c3066f24b12f084be1ed3521c0af8e404e1.zip
Look for pkg-descr rather than pkg/DESCR.
Always use the -d option when invoking CVS, to work around breakage in CVS (said breakage has reportedly been fixed in 1.11, but I haven't verified this) Bump version number.
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/porteasy/Makefile2
-rw-r--r--ports-mgmt/porteasy/src/porteasy.pl12
2 files changed, 7 insertions, 7 deletions
diff --git a/ports-mgmt/porteasy/Makefile b/ports-mgmt/porteasy/Makefile
index 14ba69544491..640577dc2672 100644
--- a/ports-mgmt/porteasy/Makefile
+++ b/ports-mgmt/porteasy/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= porteasy
-PORTVERSION= 1.6
+PORTVERSION= 1.7
CATEGORIES= misc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/porteasy/src/porteasy.pl b/ports-mgmt/porteasy/src/porteasy.pl
index f44afce3349d..eb83b9d631d3 100644
--- a/ports-mgmt/porteasy/src/porteasy.pl
+++ b/ports-mgmt/porteasy/src/porteasy.pl
@@ -34,7 +34,7 @@ use Data::Dumper;
use Fcntl;
use Getopt::Long;
-my $VERSION = "1.6";
+my $VERSION = "1.7";
# Constants
sub ANONCVS_ROOT { ":pserver:anoncvs\@anoncvs.FreeBSD.org:/home/ncvs" }
@@ -146,7 +146,7 @@ sub cvs($;@) {
my @args; # Arguments to CVS
- push(@args, "-f", "-z3", "-R",
+ push(@args, "-f", "-z3", "-R", "-d$cvsroot",
$verbose ? "-q" : "-Q", $cmd, "-A");
if ($cmd eq "checkout") {
push(@args, "-P");
@@ -354,7 +354,7 @@ sub show_port_info($) {
local *FILE; # File handle
my $info; # Port info
- sysopen(FILE, "$portsdir/$ports{$port}/pkg/DESCR", O_RDONLY)
+ sysopen(FILE, "$portsdir/$ports{$port}/pkg-descr", O_RDONLY)
or err(1, "can't read description for $port");
$info = join("| ", <FILE>);
close(FILE);
@@ -552,10 +552,10 @@ MAIN:{
if ($anoncvs) {
$cvsroot = &ANONCVS_ROOT;
}
- if ($cvsroot) {
- $ENV{'CVSROOT'} = $cvsroot;
+ if (!$cvsroot) {
+ $cvsroot = $ENV{'CVSROOT'};
}
- if (!$ENV{'CVSROOT'}) {
+ if (!$cvsroot) {
errx(1, "No CVS root, please use the -r option or set \$CVSROOT");
}