aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2008-04-12 06:56:39 +0800
committerlinimon <linimon@FreeBSD.org>2008-04-12 06:56:39 +0800
commita3de6bb9ffdedf97f7e4fdae22e34a07f32a38f3 (patch)
treeaf8b71c33a681cf47b1ee9df6c8084ed1f2df443 /ports-mgmt
parentf0047990dff509e85be625b37262b4288aad7d52 (diff)
downloadfreebsd-ports-gnome-a3de6bb9ffdedf97f7e4fdae22e34a07f32a38f3.tar.gz
freebsd-ports-gnome-a3de6bb9ffdedf97f7e4fdae22e34a07f32a38f3.tar.zst
freebsd-ports-gnome-a3de6bb9ffdedf97f7e4fdae22e34a07f32a38f3.zip
Remove local changes that crept in.
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portmk/Mk/bsd.port.mk11
1 files changed, 5 insertions, 6 deletions
diff --git a/ports-mgmt/portmk/Mk/bsd.port.mk b/ports-mgmt/portmk/Mk/bsd.port.mk
index d0b4798bd899..34275d635b46 100644
--- a/ports-mgmt/portmk/Mk/bsd.port.mk
+++ b/ports-mgmt/portmk/Mk/bsd.port.mk
@@ -1404,7 +1404,6 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
# XXX to remain undefined until all ports that require Perl are fixed
# to set one of the conditionals that force the inclusion of bsd.perl.mk
-_PERL_REFACTORING_COMPLETE= BEING_TESTED
.if !defined(_PERL_REFACTORING_COMPLETE)
PERL_VERSION?= 5.8.8
@@ -1474,13 +1473,13 @@ PERL= ${LOCALBASE}/bin/perl
.endif
.endif
-.if defined(WANT_PERL) || defined(USE_PERL5) || defined(USE_PERL5_BUILD) || defined(USE_PERL5_RUN) || defined(PERL_CONFIGURE) || defined(PERL_MODBUILD)
+#.if defined(USE_PERL5) || defined(USE_PERL5_BUILD) || defined(USE_PERL5_RUN) || defined(PERL_CONFIGURE) || defined(PERL_MODBUILD)
.if exists(${DEVELPORTSDIR}/Mk/bsd.perl.mk)
.include "${DEVELPORTSDIR}/Mk/bsd.perl.mk"
.else
.include "${PORTSDIR}/Mk/bsd.perl.mk"
.endif
-.endif
+#.endif
.if defined(USE_PHP)
.if exists(${DEVELPORTSDIR}/Mk/bsd.php.mk)
@@ -2155,13 +2154,13 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
.endif
.endif
-.if defined(WANT_PERL) || defined(USE_PERL5) || defined(USE_PERL5_BUILD) || defined(USE_PERL5_RUN) || defined(PERL_CONFIGURE) || defined(PERL_MODBUILD)
+#.if defined(USE_PERL5) || defined(USE_PERL5_BUILD) || defined(USE_PERL5_RUN) || defined(PERL_CONFIGURE) || defined(PERL_MODBUILD)
.if exists(${DEVELPORTSDIR}/Mk/bsd.perl.mk)
.include "${DEVELPORTSDIR}/Mk/bsd.perl.mk"
.else
.include "${PORTSDIR}/Mk/bsd.perl.mk"
.endif
-.endif
+#.endif
.if defined(USE_PHP)
.if exists(${DEVELPORTSDIR}/Mk/bsd.php.mk)
@@ -2469,7 +2468,7 @@ INSTALL_MACROS= BSD_INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
MAKE_ENV+= ${INSTALL_MACROS}
SCRIPTS_ENV+= ${INSTALL_MACROS}
-# Macro for copying entire directory tree with correct permissions
+# Macro for coping entire directory tree with correct permissions
.if ${UID} == 0
COPYTREE_BIN= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
2>&1) && \