aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-03-18 01:12:47 +0800
committerbapt <bapt@FreeBSD.org>2014-03-18 01:12:47 +0800
commitca7104a2a0d53adba373ee8985bd3e111a418dcc (patch)
tree6587f7574f791c83f84122ff4f5be47829c9dcaf /ports-mgmt
parentc7c581ac4887ec5db9358f40c1d2f1107534ba31 (diff)
downloadfreebsd-ports-gnome-ca7104a2a0d53adba373ee8985bd3e111a418dcc.tar.gz
freebsd-ports-gnome-ca7104a2a0d53adba373ee8985bd3e111a418dcc.tar.zst
freebsd-ports-gnome-ca7104a2a0d53adba373ee8985bd3e111a418dcc.zip
Update to 1.3.0.a1:
- New solver that can support external solvers using the CUDF format and the internal SAT solver - pkg-ssh(8) is now sandboxed with capsicum if it is available - pkg-ssh(8) now uses poll(2) - Remove StringList usage to improve portability - Rework the build system to use autotools to help portability - Now fetching is done to a temporary location and cleaned up if it fails - Remove PACKAGESITE - pkg-audit: remove support for portaudit compact database (only VulnXML will be used) - Improved UI experience based on jmmv write up (http://julipedia.meroh.net/search/label/cli-design) - Hide the average speed from the progress bar (confusing for users) - Reworking the database locking mechanism into a finer grain and more clever system - Dynamic conflict handling if a conflict on files is detected at the sanity check level, try to solve the problem again with the new conflict information - Fix %t (timestamp) modifier in pkg_printf(3) - Full output now has a new field "date installed" - New pkg -o A=B to overwrite configuration from command line without the need of defining environment variables - pkg-install now can handle local files - pkg-add is now an alias on pkg-install - Simplify API by using more and more libucl objects (hidden behind an opaque 'pkg_object') Special thanks to Vsevolod Stakhov (vsevolod@)
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg-devel/Makefile24
-rw-r--r--ports-mgmt/pkg-devel/distinfo4
-rw-r--r--ports-mgmt/pkg-devel/files/extra-patch-pkg_pkg.84
-rw-r--r--ports-mgmt/pkg-devel/pkg-plist4
4 files changed, 16 insertions, 20 deletions
diff --git a/ports-mgmt/pkg-devel/Makefile b/ports-mgmt/pkg-devel/Makefile
index 49b512659715..70c7bd3a3176 100644
--- a/ports-mgmt/pkg-devel/Makefile
+++ b/ports-mgmt/pkg-devel/Makefile
@@ -1,11 +1,12 @@
# $FreeBSD$
PORTNAME= pkg
-DISTVERSION= 1.2.7
+DISTVERSION= 1.3.0.a1
CATEGORIES= ports-mgmt
MASTER_SITES= \
- http://files.etoilebsd.net/${PORTNAME}/ \
+ http://files.etoilebsd.net/pkg/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/ \
+ http://miwibox.org/distfiles/${PORTNAME}/ \
LOCAL/portmgr
PKGNAMESUFFIX= -devel
@@ -14,16 +15,12 @@ COMMENT= Package manager
LICENSE= BSD2CLAUSE
-USES= tar:xz uidfix
-
# Disable CCACHE support because of the chicken/egg problem pkg should always
# With no dependency at all
NO_CCACHE= yes
USE_LDCONFIG= yes
-MAKE_ARGS+= PKG_PORTSDIR=${PORTSDIR}
-
-MAKE_ENV+= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null \
- PORTREVISION=${PORTREVISION}
+USES= tar:xz
+GNU_CONFIGURE= yes
# Use a submake as 'deinstall install' needs to reevaluate PKG_CMD
# so that pkg-static is used from the wrkdir
@@ -88,15 +85,14 @@ LATEST_LINK= pkg-devel
PKG_DEPENDS=
.undef INSTALLS_DEPENDS
.if !exists(${LOCALBASE}/sbin/pkg)
-PKG_BIN= ${WRKSRC}/pkg/pkg-static
+PKG_BIN= ${WRKSRC}/src/pkg-static
.endif
.endif
-PERIODIC_DAILY= 400.status-pkg 411.pkg-backup 490.status-pkg-changes
-PERIODIC_SECURITY= 410.pkg-audit 460.pkg-checksum
-PERIODIC_ALL= ${PERIODIC_DAILY} ${PERIODIC_SECURITY}
-
post-install:
- @${INSTALL_DATA} ${WRKSRC}/pkg/pkg.conf.sample ${STAGEDIR}${PREFIX}/etc
+ @${RM} -f ${STAGEDIR}${PREFIX}/lib/*.la
+ @${MV} ${STAGEDIR}${PREFIX}/lib/libpkg_static.a \
+ ${STAGEDIR}${PREFIX}/lib/libpkg.a
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpkg.so.2
.include <bsd.port.post.mk>
diff --git a/ports-mgmt/pkg-devel/distinfo b/ports-mgmt/pkg-devel/distinfo
index aca1a06a3523..2788e663f65e 100644
--- a/ports-mgmt/pkg-devel/distinfo
+++ b/ports-mgmt/pkg-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pkg-1.2.7.tar.xz) = 450f51a4c6e3d05fac9b0e408e5dfe252ac87abe72481a5b4711f077178ba4c1
-SIZE (pkg-1.2.7.tar.xz) = 1822868
+SHA256 (pkg-1.3.0.a1.tar.xz) = 41c59160877e7133789542b07c3a38130b5315c30753c997731a9db591908ad0
+SIZE (pkg-1.3.0.a1.tar.xz) = 1622316
diff --git a/ports-mgmt/pkg-devel/files/extra-patch-pkg_pkg.8 b/ports-mgmt/pkg-devel/files/extra-patch-pkg_pkg.8
index a6f077b2449b..e5f32f7a4c05 100644
--- a/ports-mgmt/pkg-devel/files/extra-patch-pkg_pkg.8
+++ b/ports-mgmt/pkg-devel/files/extra-patch-pkg_pkg.8
@@ -1,5 +1,5 @@
---- pkg/pkg.8.orig 2013-11-27 18:14:50.000000000 +0000
-+++ pkg/pkg.8
+--- src/pkg.8.orig 2013-11-27 18:14:50.000000000 +0000
++++ src/pkg.8
@@ -30,7 +30,7 @@
.Op Fl d
.Op Fl l
diff --git a/ports-mgmt/pkg-devel/pkg-plist b/ports-mgmt/pkg-devel/pkg-plist
index 4d16760e754f..e496d9eea7c7 100644
--- a/ports-mgmt/pkg-devel/pkg-plist
+++ b/ports-mgmt/pkg-devel/pkg-plist
@@ -8,7 +8,7 @@ etc/pkg.conf.sample
include/pkg.h
lib/libpkg.a
lib/libpkg.so
-lib/libpkg.so.1
+lib/libpkg.so.2
libdata/pkgconfig/pkg.pc
man/man3/pkg_printf.3.gz
man/man3/pkg_repos.3.gz
@@ -50,7 +50,7 @@ man/man8/pkg.8.gz
sbin/pkg
sbin/pkg-static
sbin/pkg2ng
-share/zsh/site-functions/_pkg
+share/zsh/site-functions/_pkg.zsh
@dirrmtry etc/bash_completion.d
@dirrmtry etc/periodic/daily
@dirrmtry etc/periodic/security