aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorbrd <brd@FreeBSD.org>2018-09-11 06:28:59 +0800
committerbrd <brd@FreeBSD.org>2018-09-11 06:28:59 +0800
commite6c98f4eaa7777ef51daa4da00fd8e44bdf6f65a (patch)
treec5fb064db43700d2883206ce4d195627e4e126bd /ports-mgmt
parentaf814543787084c5e4fb13704667b5805ae4d087 (diff)
downloadfreebsd-ports-gnome-e6c98f4eaa7777ef51daa4da00fd8e44bdf6f65a.tar.gz
freebsd-ports-gnome-e6c98f4eaa7777ef51daa4da00fd8e44bdf6f65a.tar.zst
freebsd-ports-gnome-e6c98f4eaa7777ef51daa4da00fd8e44bdf6f65a.zip
Apply a patch from git that fixes make packages with hardlinks and config files.
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg/Makefile2
-rw-r--r--ports-mgmt/pkg/files/patch-60666a116
2 files changed, 17 insertions, 1 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 36ac998733da..48d03465f988 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pkg
DISTVERSION= 1.10.5
-PORTREVISION= 2
+PORTREVISION= 3
_PKG_VERSION= ${DISTVERSION}
CATEGORIES= ports-mgmt
MASTER_SITES= \
diff --git a/ports-mgmt/pkg/files/patch-60666a1 b/ports-mgmt/pkg/files/patch-60666a1
new file mode 100644
index 000000000000..73527ddd2403
--- /dev/null
+++ b/ports-mgmt/pkg/files/patch-60666a1
@@ -0,0 +1,16 @@
+--- libpkg/pkg_ports.c
++++ libpkg/pkg_ports.c
+@@ -353,13 +353,6 @@ meta_file(struct plist *p, char *line, struct file_attr *a, bool is_config)
+ pkg_addconfig_file(p->pkg, path, content);
+ free(content);
+ }
+- } else {
+- if (is_config) {
+- pkg_emit_error("Plist error, @config %s: not a regular "
+- "file", line);
+- free(buf);
+- return (EPKG_FATAL);
+- }
+ }
+
+ if (S_ISDIR(st.st_mode) &&