aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-22 20:40:32 +0800
committerbapt <bapt@FreeBSD.org>2013-03-22 20:40:32 +0800
commit2626a10f9b6d17c2b9eb1b328b4c26680ad38e0d (patch)
tree2eef8dc8057844b13440984edd0115f961a53036 /ports-mgmt
parenta88ef9ad052139f2fabce8ddfcba3cf5aa6f838e (diff)
downloadfreebsd-ports-gnome-2626a10f9b6d17c2b9eb1b328b4c26680ad38e0d.tar.gz
freebsd-ports-gnome-2626a10f9b6d17c2b9eb1b328b4c26680ad38e0d.tar.zst
freebsd-ports-gnome-2626a10f9b6d17c2b9eb1b328b4c26680ad38e0d.zip
Convert to new options framework ports in p* catories
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/kports-qt4/Makefile23
-rw-r--r--ports-mgmt/kports/Makefile28
-rw-r--r--ports-mgmt/portscout/Makefile19
3 files changed, 31 insertions, 39 deletions
diff --git a/ports-mgmt/kports-qt4/Makefile b/ports-mgmt/kports-qt4/Makefile
index b7514fb5873b..df1af6f7214f 100644
--- a/ports-mgmt/kports-qt4/Makefile
+++ b/ports-mgmt/kports-qt4/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: kports
-# Date created: Thu Jan 12 12:47:58 UTC 2006
-# Whom: Hannes Hauswedell <hannes.hauswedell@gmail.com>
-#
+# Created by: Hannes Hauswedell <hannes.hauswedell@gmail.com>
# $FreeBSD$
-#
PORTNAME= kports
PORTVERSION= 0.8.2
@@ -29,24 +25,25 @@ HAS_CONFIGURE= yes
LATEST_LINK= kports-qt4
-OPTIONS= DEBUG "Add Debugging Symbols" off \
- OXYGEN "Pull in Oxygen icons (recommended)" on \
- KDEBASE "Pull in kdebase-runtime for kdesu" on
+OPTIONS_DEFINE= DEBUG OXYGEN KDEBASE
+OPTIONS_DEFAULT= OXYGEN KDEBASE
+OXYGEN_DESC= Pull in Oxygen icons (recommended)
+KDEBASE_DESC= Pull in kdebase-runtime for kdesu
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_OXYGEN)
+.if ${PORT_OPTIONS:MOXYGEN}
USE_KDE4= oxygen
.endif
-.if !defined(WITHOUT_KDEBASE)
+.if ${PORT_OPTIONS:MKDEBASE}
USE_KDE4= runtime
.endif
post-patch:
${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/data/kports.desktop
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
pre-configure:
@(${ECHO_CMD} "CONFIG += debug" >> ${WRKSRC}/src/src.pro)
@(${ECHO_CMD} "CONFIG -= release warn_off" >> ${WRKSRC}/src/src.pro)
@@ -59,11 +56,11 @@ do-configure:
${QMAKE} -unix ${QMAKE_ARGS} kports.pro
post-install:
-.if defined(WITHOUT_OXYGEN)
+.if ! ${PORT_OPTIONS:MOXYGEN}
@${CAT} pkg-message.nooxygen
.endif
-.if defined(WITHOUT_KDEBASE)
+.if ! ${PORT_OPTIONS:MKDEBASE}
@${CAT} pkg-message.nokdebase
.endif
diff --git a/ports-mgmt/kports/Makefile b/ports-mgmt/kports/Makefile
index d72bc66f1d8c..2b13460368b2 100644
--- a/ports-mgmt/kports/Makefile
+++ b/ports-mgmt/kports/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: kports
-# Date created: Thu Jan 12 12:47:58 UTC 2006
-# Whom: Hannes Hauswedell <hannes.hauswedell@gmail.com>
-#
+# Created by: Hannes Hauswedell <hannes.hauswedell@gmail.com>
# $FreeBSD$
-#
PORTNAME= kports
PORTVERSION= 0.6.1
@@ -23,30 +19,32 @@ CONFLICTS= kports-0.[89]*
RUN_DEPENDS+= portupgrade:${PORTSDIR}/ports-mgmt/portupgrade
RUN_DEPENDS+= kdehier>=0:${PORTSDIR}/misc/kdehier
-OPTIONS= PORTAUDIT "Require Portaudit" on \
- KDESU "With KDE3 kdesu" on \
- KDESU4 "With KDE4 kdesu" off \
- GKSU "With gksu" off
+OPTIONS_DEFINE= PORTAUDIT KDESU KDESU4 GKSU
+OPTIONS_DEFAULT= PORTAUDIT KDESU
+PORTAUDIT_DESC= Require Portaudit
+KDESU_DESC= With KDE3 kdesu
+KDESU4_DESC= With KDE4 kdesu
+GKSU_DESC= With gksu
.include <bsd.port.options.mk>
-.if defined(WITHOUT_KDESU) && defined(WITHOUT_KDESU4) && defined(WITHOUT_GKSU)
+.if ! ${PORT_OPTIONS:MKDESU} && ! ${PORT_OPTIONS:MKDESU4} && ! ${PORT_OPTIONS:MGKSU}
PKGMESSAGE= ${FILESDIR}/pkg-message.nosu
.endif
-.if !defined(WITHOUT_PORTAUDIT)
+.if ${PORT_OPTIONS:MPORTAUDIT}
RUN_DEPENDS+= portaudit:${PORTSDIR}/ports-mgmt/portaudit
.endif
-.if defined(WITH_KDESU)
+.if ${PORT_OPTIONS:MKDESU}
RUN_DEPENDS+= ${LOCALBASE}/bin/kdesu:${PORTSDIR}/x11/kdebase3
.endif
-.if defined(WITH_KDESU4)
+.if ${PORT_OPTIONS:MKDESU4}
USE_KDE4+= runtime
.endif
-.if defined(WITH_GKSU)
+.if ${PORT_OPTIONS:MGKSU}
RUN_DEPENDS+= ${LOCALBASE}/bin/gksu:${PORTSDIR}/sysutils/gksu
.endif
@@ -54,7 +52,7 @@ post-patch:
${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/src/kports.desktop
post-install:
-.if defined(WITHOUT_KDESU) && defined(WITHOUT_KDESU4) && defined(WITHOUT_GKSU)
+.if ! ${PORT_OPTIONS:MKDESU} && ! ${PORT_OPTIONS:MKDESU4} && ! ${PORT_OPTIONS:MGKSU}
@${CAT} ${PKGMESSAGE}
.endif
diff --git a/ports-mgmt/portscout/Makefile b/ports-mgmt/portscout/Makefile
index 37a16e20852b..ccc4381ae7c6 100644
--- a/ports-mgmt/portscout/Makefile
+++ b/ports-mgmt/portscout/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: portscout
-# Date created: 2006-05-15
-# Whom: Shaun Amott <shaun@inerd.com>
-#
+# Created by: Shaun Amott <shaun@inerd.com>
# $FreeBSD$
-#
PORTNAME= portscout
PORTVERSION= 0.8.1
@@ -15,7 +11,8 @@ MASTER_SITES= http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/ \
MAINTAINER= shaun@FreeBSD.org
COMMENT= A tool to scan for new versions of FreeBSD ports
-OPTIONS= SQLITE3 "Use SQLite backend instead of PostgreSQL" off
+OPTIONS_DEFINE= SQLITE3 DOCS
+SQLITE3_DESC= Use SQLite backend instead of PostgreSQL
NO_BUILD= yes
USE_PERL5= yes
@@ -34,7 +31,7 @@ RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
.include <bsd.port.options.mk>
-.if defined(WITH_SQLITE3)
+.if ${PORT_OPTIONS:MSQLITE3}
USE_SQLITE= 3
RUN_DEPENDS+= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
.elif !defined(WITHOUT_PGSQL)
@@ -43,7 +40,7 @@ RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
.endif
pre-everything::
-.if defined(WITH_SQLITE3)
+.if ${PORT_OPTIONS:MSQLITE3}
@${ECHO_MSG} "+-------------------------------------------------------------+"
@${ECHO_MSG} "| Warning! although SQLite is supported, portscout will only |"
@${ECHO_MSG} "| operate in non-forking mode with this database backend. It |"
@@ -52,7 +49,7 @@ pre-everything::
.endif
post-patch:
-.if defined(WITH_SQLITE3)
+.if ${PORT_OPTIONS:MSQLITE3}
@${REINPLACE_CMD} 's/^\([^#]*DBI:Pg.*\)$$/#\1/g' ${WRKSRC}/portscout.conf
@${REINPLACE_CMD} 's/^#\(.*DBI:SQLite.*\)$$/\1/g' ${WRKSRC}/portscout.conf
.endif
@@ -93,7 +90,7 @@ post-install:
@if [ ! -f ${PREFIX}/etc/portscout.conf ]; then \
${CP} -p ${PREFIX}/etc/portscout.conf.sample ${PREFIX}/etc/portscout.conf; \
fi
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
. for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
@@ -103,7 +100,7 @@ post-install:
test:
${PERL} ${WRKSRC}/t/00-use.t
${PERL} ${WRKSRC}/t/01-vercompare.t
-.if defined(WITH_SQLITE3)
+.if ${PORT_OPTIONS:MSQLITE3}
${PERL} ${WRKSRC}/t/10-sqlite.t
#.else
# ${PERL} ${WRKSRC}/10-postgresql.t