aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-02-20 16:50:04 +0800
committerlinimon <linimon@FreeBSD.org>2007-02-20 16:50:04 +0800
commit2c8257789295756e48d5832720dc17e65c8c342f (patch)
tree7a41ddccb1bd10bdc9b7596770d12b05564c657d /ports-mgmt
parente5a3ab2491f78e08ba536701fa6cb3c084174b05 (diff)
downloadfreebsd-ports-gnome-2c8257789295756e48d5832720dc17e65c8c342f.tar.gz
freebsd-ports-gnome-2c8257789295756e48d5832720dc17e65c8c342f.tar.zst
freebsd-ports-gnome-2c8257789295756e48d5832720dc17e65c8c342f.zip
Catch up with ports/Mk 1.552.
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portmk/Mk/bsd.port.mk19
1 files changed, 10 insertions, 9 deletions
diff --git a/ports-mgmt/portmk/Mk/bsd.port.mk b/ports-mgmt/portmk/Mk/bsd.port.mk
index b9ccfbd72dae..9f2c4a16c3dd 100644
--- a/ports-mgmt/portmk/Mk/bsd.port.mk
+++ b/ports-mgmt/portmk/Mk/bsd.port.mk
@@ -439,13 +439,14 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_WX - If set, this port uses the WxWidgets library and related
# components. See bsd.wx.mk for more details.
##
-# USE_KDEBASE_VER
-# - Set to 3 to use the KDE windowing system.
+# USE_KDEBASE_VER - Set to 3 to use the KDE windowing system.
# Implies inclusion of bsd.kde.mk.
-# USE_KDELIBS_VER
-# - Set to 3 to use the KDE libraries.
+#
+# USE_KDELIBS_VER - Set to 3 to use the KDE libraries.
# Implies inclusion of bsd.kde.mk.
-# USE_QT_VER - Set to 3 to use the QT libraries.
+#
+# USE_QT_VER - Set to 3 or 4 to use the respective version
+# of the QT libraries.
# Implies inclusion of bsd.kde.mk.
##
# USE_LINUX - Set to yes to say the port needs the default linux base port.
@@ -1718,7 +1719,7 @@ CFLAGS:= ${CFLAGS:C/${_CPUCFLAGS}//}
STRIP= #none
STRIP_CMD= #none
DEBUG_FLAGS?= -g
-CFLAGS:= ${CFLAGS:N-O*:N-f*} ${DEBUG_FLAGS}
+CFLAGS:= ${CFLAGS:N-O*:N-fno-strict*} ${DEBUG_FLAGS}
.endif
.if defined(NOPORTDOCS)
@@ -2424,9 +2425,9 @@ PORTDIRNAME?= ${_PORTDIRNAME}
PKGORIGIN?= ${PKGCATEGORY}/${PORTDIRNAME}
-.if (${OSVERSION} < 491101 && ${PKGORIGIN} != "sysutils/pkg_install") || exists(${LOCALBASE}/sbin/pkg_info)
-.if ${OSVERSION} < 491101 && ${PKGORIGIN} != "sysutils/pkg_install"
-EXTRACT_DEPENDS+= ${LOCALBASE}/sbin/pkg_info:${PORTSDIR}/sysutils/pkg_install
+.if ((${OSVERSION} < 504105 || (${OSVERSION} >= 600000 && ${OSVERSION} < 600103) || (${OSVERSION} >= 700000 && ${OSVERSION} < 700012)) && ${PKGORIGIN} != "ports-mgmt/pkg_install") || exists(${LOCALBASE}/sbin/pkg_info)
+.if (${OSVERSION} < 504105 || (${OSVERSION} >= 600000 && ${OSVERSION} < 600103) || (${OSVERSION} >= 700000 && ${OSVERSION} < 700012)) && ${PKGORIGIN} != "ports-mgmt/pkg_install"
+EXTRACT_DEPENDS+= ${LOCALBASE}/sbin/pkg_info:${PORTSDIR}/ports-mgmt/pkg_install
.endif
.if !defined(DESTDIR)
PKG_CMD?= ${LOCALBASE_REL}/sbin/pkg_create