aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-05-02 02:51:46 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-05-02 02:51:46 +0800
commit6ce45290f0a65d5d4acee8bf7f42dbf6df0e399e (patch)
treedcee14f24555384f2ad6951e7ce8927acb0c98cd /ports-mgmt
parent547a1ba776dad48e224bb6d94bbcf936716962c7 (diff)
downloadfreebsd-ports-gnome-6ce45290f0a65d5d4acee8bf7f42dbf6df0e399e.tar.gz
freebsd-ports-gnome-6ce45290f0a65d5d4acee8bf7f42dbf6df0e399e.tar.zst
freebsd-ports-gnome-6ce45290f0a65d5d4acee8bf7f42dbf6df0e399e.zip
- Update to 1.0.12
*** Binary Package Builders: It is recommended to rebuild all packages and then run 'pkg check -Ba' and 'pkg upgrade' on your client servers once. This will allow the new shlib tracking to reinstall packages that have changed shlib requirements. This step is optional. Changes: * Always track provided SHLIBS now when packages are created * Automatically reinstall packages when their needed shlibs or dependencies change. This removes the need to run 'pkg install -Rf' in many, but not all, cases. * New DB lock strategy when stored on a network filesystem * pkg version: Show ? when package is missing on remote * pkg check -s: Return non-zero exit status if a mismatch is found * pkg audit: Implement -q * Add more periodic scripts * Add bash completion script * pkg audit: Performance optimizations * Build fixes * Add some forward-compatibility support for upcoming 1.1 Thank you to all contributors, listed in the upstream commits: https://github.com/pkgng/pkgng/commits/1.0.12 With hat: portmgr
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg/Makefile21
-rw-r--r--ports-mgmt/pkg/distinfo4
-rw-r--r--ports-mgmt/pkg/files/patch-Wmissing-variable-declarations56
-rw-r--r--ports-mgmt/pkg/pkg-plist5
4 files changed, 24 insertions, 62 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 04e1e4c0874c..87f2655dce94 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= pkg
-DISTVERSION= 1.0.11
+DISTVERSION= 1.0.12
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/portmgr \
http://files.etoilebsd.net/pkg/ \
@@ -106,17 +106,30 @@ PKG_BIN= ${WRKSRC}/pkg-static/pkg-static
IGNORE= not supported on 7.x or early 8.0
.endif
+PERIODIC_DAILY= 400.status-pkg 411.pkg-backup 490.status-pkg-changes
+PERIODIC_SECURITY= 410.pkg-audit 460.pkg-checksum
+PERIDIC_ALL= ${PERIODIC_DAILY} ${PERIODIC_SECURITY}
+
post-install:
- @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/scripts/periodic/410.pkg-audit
+.for periodic in ${PERIDIC_ALL}
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/scripts/periodic/${periodic}
+.endfor
@${MKDIR} ${PREFIX}/etc/periodic/security
@${MKDIR} ${PREFIX}/etc/periodic/daily
- @${INSTALL_SCRIPT} ${WRKSRC}/scripts/periodic/410.pkg-audit ${PREFIX}/etc/periodic/security
- @${INSTALL_SCRIPT} ${WRKSRC}/scripts/periodic/411.pkg-backup ${PREFIX}/etc/periodic/daily
+.for periodic in ${PERIODIC_DAILY}
+ @${INSTALL_SCRIPT} ${WRKSRC}/scripts/periodic/${periodic} ${PREFIX}/etc/periodic/daily
+.endfor
+.for periodic in ${PERIODIC_SECURITY}
+ @${INSTALL_SCRIPT} ${WRKSRC}/scripts/periodic/${periodic} ${PREFIX}/etc/periodic/security
+.endfor
+ @${INSTALL_SCRIPT} ${WRKSRC}/ports/pkg2ng ${PREFIX}/sbin
@${INSTALL_SCRIPT} ${WRKSRC}/ports/pkg2ng ${PREFIX}/sbin
@${INSTALL_DATA} ${WRKSRC}/pkg/pkg.conf.sample ${PREFIX}/etc
@${INSTALL_DATA} ${WRKSRC}/libpkg/pkg.pc ${PREFIX}/libdata/pkgconfig/
@${MKDIR} ${PREFIX}/share/zsh/site-functions
@${INSTALL_DATA} ${WRKSRC}/scripts/zsh/_pkg ${PREFIX}/share/zsh/site-functions/
+ @${MKDIR} ${PREFIX}/etc/bash_completion.d
+ @${INSTALL_DATA} ${WRKSRC}/scripts/bash/_pkg.bash ${PREFIX}/etc/bash_completion.d/
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/ports-mgmt/pkg/distinfo b/ports-mgmt/pkg/distinfo
index 996416f7d6dd..1b07a435f41e 100644
--- a/ports-mgmt/pkg/distinfo
+++ b/ports-mgmt/pkg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pkg-1.0.11.tar.xz) = 8297c8d9a4644471b501822e88d54448bd6fad83d0d1057b6dac2720885c172a
-SIZE (pkg-1.0.11.tar.xz) = 1451320
+SHA256 (pkg-1.0.12.tar.xz) = 04b5fe89c9f106b5499056825066df284e5f1bd3bcdf3b46228164c9be3a96b2
+SIZE (pkg-1.0.12.tar.xz) = 1456292
diff --git a/ports-mgmt/pkg/files/patch-Wmissing-variable-declarations b/ports-mgmt/pkg/files/patch-Wmissing-variable-declarations
deleted file mode 100644
index 446906203c8c..000000000000
--- a/ports-mgmt/pkg/files/patch-Wmissing-variable-declarations
+++ /dev/null
@@ -1,56 +0,0 @@
---- libpkg/pkg_elf.c
-+++ libpkg/pkg_elf.c
-@@ -468,7 +468,7 @@
- }
-
- static const char *
--elf_corres_to_string(struct _elf_corres* m, int e)
-+elf_corres_to_string(const struct _elf_corres* m, int e)
- {
- int i = 0;
-
---- libpkg/private/elf_tables.h
-+++ libpkg/private/elf_tables.h
-@@ -30,7 +30,7 @@
- const char *string;
- };
-
--struct _elf_corres mach_corres[] = {
-+static const struct _elf_corres mach_corres[] = {
- { EM_386, "x86" },
- { EM_X86_64, "x86" },
- { EM_ARM, "arm" },
-@@ -42,19 +42,19 @@
- { -1, NULL },
- };
-
--struct _elf_corres wordsize_corres[] = {
-+static const struct _elf_corres wordsize_corres[] = {
- { ELFCLASS32, "32" },
- { ELFCLASS64, "64" },
- { -1, NULL},
- };
-
--struct _elf_corres endian_corres[] = {
-+static const struct _elf_corres endian_corres[] = {
- { ELFDATA2MSB, "eb" },
- { ELFDATA2LSB, "el" },
- { -1, NULL}
- };
-
--struct _elf_corres os_corres[] = {
-+static const struct _elf_corres os_corres[] = {
- { ELFOSABI_FREEBSD, "freebsd" },
- { -1, NULL }
- };
---- pkg/main.c
-+++ pkg/main.c
-@@ -90,7 +90,7 @@
- { "which", "Displays which package installed a specific file", exec_which, usage_which},
- };
-
--const unsigned int cmd_len = (sizeof(cmd)/sizeof(cmd[0]));
-+static const unsigned int cmd_len = sizeof(cmd) / sizeof(cmd[0]);
-
- static void
- usage(void)
diff --git a/ports-mgmt/pkg/pkg-plist b/ports-mgmt/pkg/pkg-plist
index 1b84b6a92b1e..37561e13976e 100644
--- a/ports-mgmt/pkg/pkg-plist
+++ b/ports-mgmt/pkg/pkg-plist
@@ -6,10 +6,15 @@ include/pkg.h
lib/libpkg.so.0
lib/libpkg.so
lib/libpkg.a
+etc/periodic/daily/400.status-pkg
etc/periodic/daily/411.pkg-backup
+etc/periodic/daily/490.status-pkg-changes
etc/periodic/security/410.pkg-audit
+etc/periodic/security/460.pkg-checksum
libdata/pkgconfig/pkg.pc
share/zsh/site-functions/_pkg
+etc/bash_completion.d/_pkg.bash
+@dirrmtry etc/bash_completion.d
@dirrmtry etc/periodic/daily
@dirrmtry etc/periodic/security
@dirrmtry etc/periodic