aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2005-10-19 15:47:48 +0800
committerdaichi <daichi@FreeBSD.org>2005-10-19 15:47:48 +0800
commitf38fffd4fcde8eb3ef04a07432e246b770ab909b (patch)
tree23f4fd25ee38f7f903a4b5c30ce6a36b1c2d6d2f /ports-mgmt
parent4f7e55fc3fc288fd6387ad95a6175f70941b0a5f (diff)
downloadfreebsd-ports-gnome-f38fffd4fcde8eb3ef04a07432e246b770ab909b.tar.gz
freebsd-ports-gnome-f38fffd4fcde8eb3ef04a07432e246b770ab909b.tar.zst
freebsd-ports-gnome-f38fffd4fcde8eb3ef04a07432e246b770ab909b.zip
fix: ports/54424 problem
- fix PKG_ALTDEP does not work problem PR: ports/54424 Submitted by: koma2@lovepeers.org (maintainer) Approved by: bharat@menalto.com
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile2
-rw-r--r--ports-mgmt/portupgrade-devel/files/patch-bin-pkgdb13
-rw-r--r--ports-mgmt/portupgrade-devel/files/patch-etc-pkgtools.conf16
-rw-r--r--ports-mgmt/portupgrade/Makefile2
-rw-r--r--ports-mgmt/portupgrade/files/patch-bin-pkgdb13
-rw-r--r--ports-mgmt/portupgrade/files/patch-etc-pkgtools.conf16
6 files changed, 60 insertions, 2 deletions
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index d872013ac335..4a4469e2dabe 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 20041226
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/ \
${MASTER_SITE_LOCAL}
diff --git a/ports-mgmt/portupgrade-devel/files/patch-bin-pkgdb b/ports-mgmt/portupgrade-devel/files/patch-bin-pkgdb
new file mode 100644
index 000000000000..94bd4843b037
--- /dev/null
+++ b/ports-mgmt/portupgrade-devel/files/patch-bin-pkgdb
@@ -0,0 +1,13 @@
+Index: bin/pkgdb
+===================================================================
+--- bin/pkgdb (revision 38)
++++ bin/pkgdb (working copy)
+@@ -615,7 +615,7 @@
+ next
+ end
+
+- if $pkgdb.match?(pat, dep)
++ if File.fnmatch?(pat, dep)
+ case alt
+ when :delete, :skip
+ return [alt]
diff --git a/ports-mgmt/portupgrade-devel/files/patch-etc-pkgtools.conf b/ports-mgmt/portupgrade-devel/files/patch-etc-pkgtools.conf
new file mode 100644
index 000000000000..84ec52278a32
--- /dev/null
+++ b/ports-mgmt/portupgrade-devel/files/patch-etc-pkgtools.conf
@@ -0,0 +1,16 @@
+Index: etc/pkgtools.conf
+===================================================================
+--- etc/pkgtools.conf (revision 39)
++++ etc/pkgtools.conf (revision 40)
+@@ -252,8 +252,10 @@
+ # be used as B values, instead of pkgname glob patterns. <:delete>
+ # means to delete the dependency and <:skip> to skip it.
+ #
+- # cf. pkg_glob(1)
++ # This replacement is done when "pkgdb -F" is executed.
+ #
++ # cf. pkg_glob(1), pkgdb(1)
++ #
+ # e.g.:
+ # ALT_PKGDEP = {
+ # # If you use apache13-modssl instead of apache13
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index d872013ac335..4a4469e2dabe 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 20041226
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/ \
${MASTER_SITE_LOCAL}
diff --git a/ports-mgmt/portupgrade/files/patch-bin-pkgdb b/ports-mgmt/portupgrade/files/patch-bin-pkgdb
new file mode 100644
index 000000000000..94bd4843b037
--- /dev/null
+++ b/ports-mgmt/portupgrade/files/patch-bin-pkgdb
@@ -0,0 +1,13 @@
+Index: bin/pkgdb
+===================================================================
+--- bin/pkgdb (revision 38)
++++ bin/pkgdb (working copy)
+@@ -615,7 +615,7 @@
+ next
+ end
+
+- if $pkgdb.match?(pat, dep)
++ if File.fnmatch?(pat, dep)
+ case alt
+ when :delete, :skip
+ return [alt]
diff --git a/ports-mgmt/portupgrade/files/patch-etc-pkgtools.conf b/ports-mgmt/portupgrade/files/patch-etc-pkgtools.conf
new file mode 100644
index 000000000000..84ec52278a32
--- /dev/null
+++ b/ports-mgmt/portupgrade/files/patch-etc-pkgtools.conf
@@ -0,0 +1,16 @@
+Index: etc/pkgtools.conf
+===================================================================
+--- etc/pkgtools.conf (revision 39)
++++ etc/pkgtools.conf (revision 40)
+@@ -252,8 +252,10 @@
+ # be used as B values, instead of pkgname glob patterns. <:delete>
+ # means to delete the dependency and <:skip> to skip it.
+ #
+- # cf. pkg_glob(1)
++ # This replacement is done when "pkgdb -F" is executed.
+ #
++ # cf. pkg_glob(1), pkgdb(1)
++ #
+ # e.g.:
+ # ALT_PKGDEP = {
+ # # If you use apache13-modssl instead of apache13