aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2015-12-28 21:20:14 +0800
committermiwi <miwi@FreeBSD.org>2015-12-28 21:20:14 +0800
commit24d2806852c0d8aa72f64c3bda79ddd49cc9d300 (patch)
tree95608fce7bc80ef3de083d42f0338bc74a7bdf2c /ports-mgmt
parent1ba03a592341f8dac7009cd86616a568336f58c5 (diff)
downloadfreebsd-ports-gnome-24d2806852c0d8aa72f64c3bda79ddd49cc9d300.tar.gz
freebsd-ports-gnome-24d2806852c0d8aa72f64c3bda79ddd49cc9d300.tar.zst
freebsd-ports-gnome-24d2806852c0d8aa72f64c3bda79ddd49cc9d300.zip
pytoport provides a way to quickly generate the barebones of a Python package
by simply providing the name of the module to the command. It accesses the PyPI JSON API and does its best to generate a fully functional Makefile and distinfo where sources are found. WWW: https://github.com/freebsd/pytoport PR: 205636 Submitted by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/Makefile1
-rw-r--r--ports-mgmt/py-pytoport/Makefile25
-rw-r--r--ports-mgmt/py-pytoport/distinfo2
-rw-r--r--ports-mgmt/py-pytoport/pkg-descr6
4 files changed, 34 insertions, 0 deletions
diff --git a/ports-mgmt/Makefile b/ports-mgmt/Makefile
index 47cf7afa1632..1c0aa62bc102 100644
--- a/ports-mgmt/Makefile
+++ b/ports-mgmt/Makefile
@@ -61,6 +61,7 @@
SUBDIR += poudriere
SUBDIR += poudriere-devel
SUBDIR += psearch
+ SUBDIR += py-pytoport
SUBDIR += symports
SUBDIR += tinderbox
SUBDIR += tinderbox-devel
diff --git a/ports-mgmt/py-pytoport/Makefile b/ports-mgmt/py-pytoport/Makefile
new file mode 100644
index 000000000000..3ecd35845425
--- /dev/null
+++ b/ports-mgmt/py-pytoport/Makefile
@@ -0,0 +1,25 @@
+# Created by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
+# $FreeBSD$
+
+PORTNAME= pytoport
+PORTVERSION= 0.2.0
+DISTVERSIONPREFIX= v
+CATEGORIES= ports-mgmt python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= brendan+freebsd@bbqsrc.net
+COMMENT= Generate FreeBSD ports from Python modules on PyPI
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-licensee>0:${PORTSDIR}/devel/rubygem-licensee
+
+USE_GITHUB= yes
+GH_ACCOUNT= freebsd
+GH_PROJECT= pytoport
+
+USES= python:3.2+
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/py-pytoport/distinfo b/ports-mgmt/py-pytoport/distinfo
new file mode 100644
index 000000000000..9a642dee9f1c
--- /dev/null
+++ b/ports-mgmt/py-pytoport/distinfo
@@ -0,0 +1,2 @@
+SHA256 (freebsd-pytoport-v0.2.0_GH0.tar.gz) = 44cfb9674596fa676b00cf319493608f2c755311baf48aebfb25065482bf46af
+SIZE (freebsd-pytoport-v0.2.0_GH0.tar.gz) = 4594
diff --git a/ports-mgmt/py-pytoport/pkg-descr b/ports-mgmt/py-pytoport/pkg-descr
new file mode 100644
index 000000000000..db629d46d973
--- /dev/null
+++ b/ports-mgmt/py-pytoport/pkg-descr
@@ -0,0 +1,6 @@
+pytoport provides a way to quickly generate the barebones of a Python package
+by simply providing the name of the module to the command. It accesses the
+PyPI JSON API and does its best to generate a fully functional Makefile and
+distinfo where sources are found.
+
+WWW: https://github.com/freebsd/pytoport