aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-10-15 05:02:49 +0800
committeritetcu <itetcu@FreeBSD.org>2006-10-15 05:02:49 +0800
commitb84a1b6d85ae20db6c8923d4eb4641c810173f79 (patch)
treea75f5bf32bcaf39017aaf2dda02cb8b9f799c107 /ports-mgmt
parentc430490e0092f8fc45a2b097d72349c09ccf4096 (diff)
downloadfreebsd-ports-gnome-b84a1b6d85ae20db6c8923d4eb4641c810173f79.tar.gz
freebsd-ports-gnome-b84a1b6d85ae20db6c8923d4eb4641c810173f79.tar.zst
freebsd-ports-gnome-b84a1b6d85ae20db6c8923d4eb4641c810173f79.zip
- it doesn't work with MySQL below 4.1.x because it uses sub-selects
- also fix broken INDEX if Mysql 3.23.x is installed [1] Submitted by: vd [1] Approved by: portmgr (marcus)
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile5
-rw-r--r--ports-mgmt/tinderbox/Makefile5
2 files changed, 6 insertions, 4 deletions
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index a8996126c1c7..15254fc78d3a 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -6,7 +6,7 @@
PORTNAME= tinderbox
PORTVERSION= 2.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= http://tinderbox.marcuscom.com/
@@ -45,7 +45,8 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-P
.if !defined(WITHOUT_MYSQL)
USE_PHP+= mysql
USE_MYSQL= yes
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}
+IGNORE_WITH_MYSQL= 323 40
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER:S/323//}
.endif
.if ! (${OSVERSION} > 700014 || ( ${OSVERSION} >= 601101 && ${OSVERSION} < 700000 ))
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index a8996126c1c7..15254fc78d3a 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -6,7 +6,7 @@
PORTNAME= tinderbox
PORTVERSION= 2.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= http://tinderbox.marcuscom.com/
@@ -45,7 +45,8 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-P
.if !defined(WITHOUT_MYSQL)
USE_PHP+= mysql
USE_MYSQL= yes
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}
+IGNORE_WITH_MYSQL= 323 40
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER:S/323//}
.endif
.if ! (${OSVERSION} > 700014 || ( ${OSVERSION} >= 601101 && ${OSVERSION} < 700000 ))