aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2013-08-12 21:05:07 +0800
committerale <ale@FreeBSD.org>2013-08-12 21:05:07 +0800
commit46f4a169835a9586e2104c5bbb4a7c1d9c0f46d1 (patch)
tree033dd88e9a726a44dac9766922467836e9b2ffa7 /ports-mgmt
parent2b0cb9468edf33425776b304e8a3ead6e2be3fdc (diff)
downloadfreebsd-ports-gnome-46f4a169835a9586e2104c5bbb4a7c1d9c0f46d1.tar.gz
freebsd-ports-gnome-46f4a169835a9586e2104c5bbb4a7c1d9c0f46d1.tar.zst
freebsd-ports-gnome-46f4a169835a9586e2104c5bbb4a7c1d9c0f46d1.zip
Add dash (-) and plus (+) symbols to allowed characters in variable names:
Dash symbols are required when using OptionsNG and $UNIQUENAME_SET/UNSET. e.g. apache22-event-mpm_SET=... Plus symbols can be used to extend existing variables. e.g. OPTIONS_SET+=... PR: ports/172355, ports/181119 Submitted by: Manuel <manuel-freebsd@mausz.at>, Gea-Suan Lin <gslin@gslin.org>
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portconf/Makefile2
-rw-r--r--ports-mgmt/portconf/files/portconf.sh.in2
2 files changed, 2 insertions, 2 deletions
diff --git a/ports-mgmt/portconf/Makefile b/ports-mgmt/portconf/Makefile
index ae4f353849e6..73545bb40277 100644
--- a/ports-mgmt/portconf/Makefile
+++ b/ports-mgmt/portconf/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portconf
-PORTVERSION= 1.5
+PORTVERSION= 1.6
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portconf/files/portconf.sh.in b/ports-mgmt/portconf/files/portconf.sh.in
index 5a3ac83df3f9..bce47ff5c650 100644
--- a/ports-mgmt/portconf/files/portconf.sh.in
+++ b/ports-mgmt/portconf/files/portconf.sh.in
@@ -36,7 +36,7 @@ _pwd=`pwd`
sed '/^#/d;/^[[:space:]]*$/d' "${_conf}" | while read _line; do
for _port in ${_line%%:*}; do
if [ "${_pwd%%${_port}}" != "${_pwd}" ]; then
- echo ${_line#*:} | sed -E 's/([A-Za-z0-9_]+)(=([^|]+))?/\1=\3/g;s/!([A-Za-z0-9_]+)=([^|]+)?/.undef \1/g;s/ *\| */|/g;s/ /%/g'
+ echo ${_line#*:} | sed -E 's/([A-Za-z0-9_\-]+\+?)(=([^|]+))?/\1=\3/g;s/!([A-Za-z0-9_]+)=([^|]+)?/.undef \1/g;s/ *\| */|/g;s/ /%/g'
fi
done
done