aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authoreik <eik@FreeBSD.org>2004-06-18 16:07:29 +0800
committereik <eik@FreeBSD.org>2004-06-18 16:07:29 +0800
commitdde670cb055b99c60d69d8061b50705a86ee8c76 (patch)
tree30ba33efa4496226ae8e65e49335793b0f857911 /ports-mgmt
parentf18d20fd27fd1b2544885aef0c6ea90676948187 (diff)
downloadfreebsd-ports-gnome-dde670cb055b99c60d69d8061b50705a86ee8c76.tar.gz
freebsd-ports-gnome-dde670cb055b99c60d69d8061b50705a86ee8c76.tar.zst
freebsd-ports-gnome-dde670cb055b99c60d69d8061b50705a86ee8c76.zip
Fetch the database from http://www.FreeBSD.org/ports/ first.
Thanks to: kuriyama
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portaudit/Makefile2
-rw-r--r--ports-mgmt/portaudit/files/portaudit.conf9
-rw-r--r--ports-mgmt/portaudit/files/portaudit.functions4
-rw-r--r--ports-mgmt/portaudit/pkg-install2
4 files changed, 11 insertions, 6 deletions
diff --git a/ports-mgmt/portaudit/Makefile b/ports-mgmt/portaudit/Makefile
index 6cd41e3658d6..d62f20727494 100644
--- a/ports-mgmt/portaudit/Makefile
+++ b/ports-mgmt/portaudit/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= portaudit
-PORTVERSION= 0.3.1
+PORTVERSION= 0.3.2
CATEGORIES= security
DISTFILES=
diff --git a/ports-mgmt/portaudit/files/portaudit.conf b/ports-mgmt/portaudit/files/portaudit.conf
index 5b2f5363cbcf..2e73ffcd9830 100644
--- a/ports-mgmt/portaudit/files/portaudit.conf
+++ b/ports-mgmt/portaudit/files/portaudit.conf
@@ -17,8 +17,9 @@
#FETCH_AFTER_ARGS=
-# specify a local mirror here
-#MASTER_SITES="http://my.mirror.sample/path/portaudit/"
+# specify a local mirror that generates databases with portaudit-db here
+#MASTER_SITE_OVERRIDE="http://my.mirror.sample/path/portaudit/"
+# use the following to disable the override
+#MASTER_SITE_OVERRIDE=" "
-# uncomment to prefer the UK mirror, jp, se, tw and uk are available
-#MASTER_SORT_REGEX="\.uk[.\/]"
+# uncomment to prefer the UK mirror, at, cz, dk, jp, ro, se, tw and uk are available
diff --git a/ports-mgmt/portaudit/files/portaudit.functions b/ports-mgmt/portaudit/files/portaudit.functions
index 9475bfeaf805..be3599913979 100644
--- a/ports-mgmt/portaudit/files/portaudit.functions
+++ b/ports-mgmt/portaudit/files/portaudit.functions
@@ -41,6 +41,7 @@ portaudit_confs()
FETCH_BEFORE_ARGS=${FETCH_BEFORE_ARGS:-"-p"}
FETCH_AFTER_ARGS=${FETCH_AFTER_ARGS:-}
+ MASTER_SITE_OVERRIDE=${MASTER_SITE_OVERRIDE:-"http://www.FreeBSD.org/ports/"}
MASTER_SITES=${MASTER_SITES:-"
ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/%SUBDIR%/
ftp://ftp.se.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/%SUBDIR%/
@@ -196,6 +197,9 @@ audit_cwd()
fetch_locations()
{
# site sort order is not overly smart
+ if [ -n "${MASTER_SITE_OVERRIDE}" ]; then
+ echo "${MASTER_SITE_OVERRIDE}"
+ fi
echo ${MASTER_SITES} | /usr/bin/tr -s ' \t' '\n' | /usr/bin/awk "
BEGIN { IGNORECASE=1; srand() }
/^$/ { next }
diff --git a/ports-mgmt/portaudit/pkg-install b/ports-mgmt/portaudit/pkg-install
index 485fe2c991cb..158f0e25ee15 100644
--- a/ports-mgmt/portaudit/pkg-install
+++ b/ports-mgmt/portaudit/pkg-install
@@ -9,7 +9,7 @@ POST-INSTALL)
echo
echo "===> To check your installed ports for known vulnerabilities now do:"
echo
- echo " %%PREFIX%%/bin/portaudit -F -a"
+ echo " %%PREFIX%%/bin/portaudit -Fda"
echo
fi
;;