aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-12-06 01:13:03 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-12-06 01:13:03 +0800
commit7fd34309b54770b17b10f2ec0deb9467e614006f (patch)
treead1aae398d83db34b7c8f1373cd22699f0c90487 /ports-mgmt
parent4ced8c4e0cd1cc4df54df01b7699b23f46a29ab8 (diff)
downloadfreebsd-ports-gnome-7fd34309b54770b17b10f2ec0deb9467e614006f.tar.gz
freebsd-ports-gnome-7fd34309b54770b17b10f2ec0deb9467e614006f.tar.zst
freebsd-ports-gnome-7fd34309b54770b17b10f2ec0deb9467e614006f.zip
- Resurrect ports-mgmt/pkg-plist, update to 1.4
Make a pkg-plist for a FreeBSD port. Try to be as "automatic" as possible. That's all it does ;-) Basic usage =========== 1. Build your port to the staging directory: `make stage`. 2. Run this from your port's directory (or set `-p`). Alternatively, you can install your ports to a "fake" prefix, this is the "old" from before staging support, but it has the added advantage that you've tested whether your port works when installing to a different prefix. 1. Build & install your port with a different `PREFIX`: `make install PREFIX=/var/tmp/ptest`. 2. Run this from your port's directory with `-x` set to `PREFIX`. WWW: http://code.arp242.net/pkg-plist PR: 195576 Submitted by: lightside@gmx.com Approved by: martin@arp242.net (maintainer)
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/Makefile1
-rw-r--r--ports-mgmt/pkg-plist/Makefile28
-rw-r--r--ports-mgmt/pkg-plist/distinfo2
-rw-r--r--ports-mgmt/pkg-plist/pkg-descr18
4 files changed, 49 insertions, 0 deletions
diff --git a/ports-mgmt/Makefile b/ports-mgmt/Makefile
index 006b0bdec49d..5c15efd8bddd 100644
--- a/ports-mgmt/Makefile
+++ b/ports-mgmt/Makefile
@@ -32,6 +32,7 @@
SUBDIR += pkg
SUBDIR += pkg-devel
SUBDIR += pkg-orphan
+ SUBDIR += pkg-plist
SUBDIR += pkg-rmleaf
SUBDIR += pkg_cleanup
SUBDIR += pkg_cutleaves
diff --git a/ports-mgmt/pkg-plist/Makefile b/ports-mgmt/pkg-plist/Makefile
new file mode 100644
index 000000000000..a9a4f5f6f655
--- /dev/null
+++ b/ports-mgmt/pkg-plist/Makefile
@@ -0,0 +1,28 @@
+# Created by: Martin Tournoij <martin@arp242.net>
+# $FreeBSD$
+
+PORTNAME= pkg-plist
+PORTVERSION= 1.4
+CATEGORIES= ports-mgmt python
+MASTER_SITES= http://code.arp242.net/${BB_PROJECT}/get/${BB_COMMIT}.tar.gz?dummy=/
+
+MAINTAINER= martin@arp242.net
+COMMENT= Generate a pkg-plist for a port
+
+LICENSE= MIT
+
+USES= python
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
+
+BB_ACCOUNT= Carpetsmoker
+BB_PROJECT= ${PORTNAME}
+BB_COMMIT= ff040a64c20b
+
+PLIST_FILES= bin/pkg-plist man/man1/pkg-plist.1.gz
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pkg-plist ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pkg-plist.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/pkg-plist/distinfo b/ports-mgmt/pkg-plist/distinfo
new file mode 100644
index 000000000000..7ded4bee1108
--- /dev/null
+++ b/ports-mgmt/pkg-plist/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pkg-plist-1.4.tar.gz) = f65ba9994dd78e4916f3a420170f8c25f3a481032338433375385ab7c85ea17f
+SIZE (pkg-plist-1.4.tar.gz) = 4404
diff --git a/ports-mgmt/pkg-plist/pkg-descr b/ports-mgmt/pkg-plist/pkg-descr
new file mode 100644
index 000000000000..53f66c7a970a
--- /dev/null
+++ b/ports-mgmt/pkg-plist/pkg-descr
@@ -0,0 +1,18 @@
+Make a pkg-plist for a FreeBSD port. Try to be as "automatic" as possible.
+
+That's all it does ;-)
+
+Basic usage
+===========
+1. Build your port to the staging directory: `make stage`.
+2. Run this from your port's directory (or set `-p`).
+
+Alternatively, you can install your ports to a "fake" prefix, this is the "old"
+from before staging support, but it has the added advantage that you've tested
+whether your port works when installing to a different prefix.
+
+1. Build & install your port with a different `PREFIX`: `make install
+ PREFIX=/var/tmp/ptest`.
+2. Run this from your port's directory with `-x` set to `PREFIX`.
+
+WWW: http://code.arp242.net/pkg-plist