aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2013-09-27 14:54:39 +0800
committermatthew <matthew@FreeBSD.org>2013-09-27 14:54:39 +0800
commite632d30b4a1e60fe8b4904ad12bdaf0db6202453 (patch)
tree0ed4c385cda0987c70309c3dcd15bd587b5ca33e /ports-mgmt
parentf868198e4772eff66135fc0ab5a33216de944280 (diff)
downloadfreebsd-ports-gnome-e632d30b4a1e60fe8b4904ad12bdaf0db6202453.tar.gz
freebsd-ports-gnome-e632d30b4a1e60fe8b4904ad12bdaf0db6202453.tar.zst
freebsd-ports-gnome-e632d30b4a1e60fe8b4904ad12bdaf0db6202453.zip
- Stageify
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/wanted-ports/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/ports-mgmt/wanted-ports/Makefile b/ports-mgmt/wanted-ports/Makefile
index b3d023955bd3..3be31e4554ae 100644
--- a/ports-mgmt/wanted-ports/Makefile
+++ b/ports-mgmt/wanted-ports/Makefile
@@ -19,7 +19,8 @@ SUB_FILES= ${PORTNAME} \
SUB_LIST= PORTNAME=${PORTNAME} \
PKGNAME=${PKGNAME}
PLIST_SUB= PORTNAME=${PORTNAME}
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
MAN1= ${PORTNAME}.1
@@ -29,13 +30,12 @@ CFGFILE= ${WANTEDPORTSCFG}
CFGFILE?= /var/db/${PORTNAME}.conf
.endif
-NO_STAGE= yes
.if exists(${CFGFILE})
.include "${CFGFILE}"
.endif
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
- ${INSTALL_MAN} ${WRKDIR}/${PORTNAME}.1 ${MANPREFIX}/man/man1/
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKDIR}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1/
.include <bsd.port.mk>