aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-06-11 21:01:56 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-06-11 21:01:56 +0800
commite51a5eb57d6454383587f2a3d2b420836673bdc9 (patch)
treeb4e418cf357e908c0caa9a4b3c658e4215a23929 /ports-mgmt
parent10b861307a5aa1584f2e7f8d81f3df5a359a1a27 (diff)
downloadfreebsd-ports-gnome-e51a5eb57d6454383587f2a3d2b420836673bdc9.tar.gz
freebsd-ports-gnome-e51a5eb57d6454383587f2a3d2b420836673bdc9.tar.zst
freebsd-ports-gnome-e51a5eb57d6454383587f2a3d2b420836673bdc9.zip
- Update to 1.0.13
Changes: - Add pkg -N to detect if pkgng is installed and activated. See pkg(8) for usage as this is not completely safe for 9.1's bootstrapper. - Update manpages with examples - Fix crash in shlib handling (was already in port) - Fix shlibs scanning over NFS - Update to new repository/upstream URL at http://github.com/freebsd/pkg With hat: portmgr
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg/Makefile3
-rw-r--r--ports-mgmt/pkg/distinfo4
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__pkg_elf.c26
3 files changed, 3 insertions, 30 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index c5146bc178aa..3b49b9452fa1 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= pkg
-DISTVERSION= 1.0.12
-PORTREVISION= 1
+DISTVERSION= 1.0.13
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/portmgr \
http://files.etoilebsd.net/pkg/ \
diff --git a/ports-mgmt/pkg/distinfo b/ports-mgmt/pkg/distinfo
index 1b07a435f41e..12d3ae77dbcb 100644
--- a/ports-mgmt/pkg/distinfo
+++ b/ports-mgmt/pkg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pkg-1.0.12.tar.xz) = 04b5fe89c9f106b5499056825066df284e5f1bd3bcdf3b46228164c9be3a96b2
-SIZE (pkg-1.0.12.tar.xz) = 1456292
+SHA256 (pkg-1.0.13.tar.xz) = 29d2f477f30aff8dd394ffbcdc9e75f3b88ba43d99da71b2a5ad9e171241271b
+SIZE (pkg-1.0.13.tar.xz) = 1458576
diff --git a/ports-mgmt/pkg/files/patch-libpkg__pkg_elf.c b/ports-mgmt/pkg/files/patch-libpkg__pkg_elf.c
deleted file mode 100644
index a416d9e4db13..000000000000
--- a/ports-mgmt/pkg/files/patch-libpkg__pkg_elf.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- ./libpkg/pkg_elf.c.orig 2013-05-16 23:38:38.020628709 -0500
-+++ ./libpkg/pkg_elf.c 2013-05-16 23:57:33.346627390 -0500
-@@ -258,7 +258,10 @@
- }
-
- if (note != NULL) {
-- data = elf_getdata(note, NULL);
-+ if ((data = elf_getdata(note, NULL)) == NULL) {
-+ ret = EPKG_END; /* Some error occurred, ignore this file */
-+ goto cleanup;
-+ }
- osname = (const char *) data->d_buf + sizeof(Elf_Note);
- if (strncasecmp(osname, "freebsd", sizeof("freebsd")) != 0 &&
- strncasecmp(osname, "dragonfly", sizeof("dragonfly")) != 0) {
-@@ -272,7 +275,10 @@
- }
- }
-
-- data = elf_getdata(dynamic, NULL);
-+ if ((data = elf_getdata(dynamic, NULL)) == NULL) {
-+ ret = EPKG_END; /* Some error occurred, ignore this file */
-+ goto cleanup;
-+ }
-
- /* First, scan through the data from the .dynamic section to
- find any RPATH or RUNPATH settings. These are colon