aboutsummaryrefslogtreecommitdiffstats
path: root/print/a2ps
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2015-09-28 04:39:37 +0800
committerdinoex <dinoex@FreeBSD.org>2015-09-28 04:39:37 +0800
commitb15827fcceabf58f3f475b9ae2626148d550b33f (patch)
treee6454bc2a9aa53b9d01dc514711c9114448bbb83 /print/a2ps
parent630998d055c38818aed9f0a090ed8db805e85f1f (diff)
downloadfreebsd-ports-gnome-b15827fcceabf58f3f475b9ae2626148d550b33f.tar.gz
freebsd-ports-gnome-b15827fcceabf58f3f475b9ae2626148d550b33f.tar.zst
freebsd-ports-gnome-b15827fcceabf58f3f475b9ae2626148d550b33f.zip
- fix cli option "--list=defaults"
PR: 203326 Submitted by: Tatsuki Makino
Diffstat (limited to 'print/a2ps')
-rw-r--r--print/a2ps/Makefile2
-rw-r--r--print/a2ps/files/patch-printlen.c27
-rw-r--r--print/a2ps/files/patch-title.c11
3 files changed, 39 insertions, 1 deletions
diff --git a/print/a2ps/Makefile b/print/a2ps/Makefile
index c2813f5020e6..abfa51914b65 100644
--- a/print/a2ps/Makefile
+++ b/print/a2ps/Makefile
@@ -3,7 +3,7 @@
PORTNAME= a2ps
PORTVERSION= 4.13b
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= print
MASTER_SITES= GNU LOCAL/hrs/a2ps/:i18n
diff --git a/print/a2ps/files/patch-printlen.c b/print/a2ps/files/patch-printlen.c
new file mode 100644
index 000000000000..4afb7da9f1d5
--- /dev/null
+++ b/print/a2ps/files/patch-printlen.c
@@ -0,0 +1,27 @@
+--- lib/printlen.c.orig 1999-08-31 17:42:42 UTC
++++ lib/printlen.c
+@@ -28,14 +28,11 @@ Foundation, Inc., 59 Temple Place - Suit
+ unsigned long strtoul ();
+
+ static int
+-int_printflen (const char *format, va_list *args)
++int_printflen (const char *format, va_list ap)
+ {
+ const char *cp;
+ int total_width = 0;
+ int width = 0;
+- va_list ap;
+-
+- memcpy (&ap, args, sizeof (va_list));
+
+ for (cp = format ; *cp ; cp++)
+ {
+@@ -99,7 +96,7 @@ int_printflen (const char *format, va_li
+ int
+ vprintflen (const char *format, va_list args)
+ {
+- return int_printflen (format, &args);
++ return int_printflen (format, args);
+ }
+
+ int
diff --git a/print/a2ps/files/patch-title.c b/print/a2ps/files/patch-title.c
new file mode 100644
index 000000000000..08a8b8d7f850
--- /dev/null
+++ b/print/a2ps/files/patch-title.c
@@ -0,0 +1,11 @@
+--- lib/title.c.orig 2015-09-25 08:26:23 UTC
++++ lib/title.c
+@@ -88,6 +88,8 @@ title (stream, c, center_p, format, va_a
+ if (center_p)
+ for (padding = 0 ; padding < 79 - len ; padding += 2)
+ putc (' ', stream);
++ va_end(args);
++ VA_START(args, format);
+ # if HAVE_VPRINTF || _LIBC
+ vfprintf (stream, format, args);
+ # else