aboutsummaryrefslogtreecommitdiffstats
path: root/print/c2ps-letter/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1998-02-25 08:25:52 +0800
committersteve <steve@FreeBSD.org>1998-02-25 08:25:52 +0800
commit9966a715223c283a78d00db88ac58805c4c762a8 (patch)
treec2031ad9eef24728261469f21d4dd6df2ff4ba35 /print/c2ps-letter/Makefile
parent3aec0069335c9b2947b9f222ada131db44bc8824 (diff)
downloadfreebsd-ports-gnome-9966a715223c283a78d00db88ac58805c4c762a8.tar.gz
freebsd-ports-gnome-9966a715223c283a78d00db88ac58805c4c762a8.tar.zst
freebsd-ports-gnome-9966a715223c283a78d00db88ac58805c4c762a8.zip
Upgrade to version 4.0 and allow the build of A4 and LETTER
packages. PR: 5075 Submitted by: Matthew Hunt <mph@pobox.com>
Diffstat (limited to 'print/c2ps-letter/Makefile')
-rw-r--r--print/c2ps-letter/Makefile26
1 files changed, 19 insertions, 7 deletions
diff --git a/print/c2ps-letter/Makefile b/print/c2ps-letter/Makefile
index e5a6cc8cd242..f7f35f090f43 100644
--- a/print/c2ps-letter/Makefile
+++ b/print/c2ps-letter/Makefile
@@ -1,20 +1,32 @@
# New ports collection makefile for: c2ps
-# Version required: 3.0
+# Version required: 4.0
# Date created: 19 March 1997
# Whom: Matthew Hunt <mph@pobox.com>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1997/03/24 19:36:55 obrien Exp $
#
-DISTNAME= c2ps-3.0
+DISTNAME= c2ps-4.0
+PKGNAME= c2ps-${PAPERSIZE:S/A/a/:S/LETTER/letter/}-4.0
CATEGORIES= print
-MASTER_SITES= http://www.geocities.com/SiliconValley/Park/2055/
-DISTFILES= c2ps-30.tgz
-# Also: http://www.cs.technion.ac.il/~c0928189/c2ps/c2ps-3.0.tar.Z
+MASTER_SITES= http://www.cs.technion.ac.il/users/c2ps/
MAINTAINER= mph@pobox.com
MAN1= c2ps.1
+MAKE_ENV= DEFAULT_PAPER_TYPE=${PAPERSIZE}
-.include <bsd.port.mk>
+.if !defined(PAPERSIZE)
+PAPERSIZE=A4
+.elif ${PAPERSIZE} != A4 && ${PAPERSIZE} != LETTER
+PAPERSIZE_INVALID=yes
+.endif
+
+pre-fetch:
+.if defined(PAPERSIZE_INVALID)
+ @${ECHO} "Invalid value for PAPERSIZE: \"${PAPERSIZE}\""
+ @${ECHO} "Possible values are: A4 (default), and LETTER."
+ @${FALSE}
+.endif
+.include <bsd.port.mk>