aboutsummaryrefslogtreecommitdiffstats
path: root/print/c2ps-letter
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-20 12:15:15 +0800
committerasami <asami@FreeBSD.org>1998-11-20 12:15:15 +0800
commit71102e95212bab836c7a1f7b6a46879128507258 (patch)
tree092d32b70a72fb7f03924e677d49b93599639b89 /print/c2ps-letter
parent1adcc2f9a259e053ec9c8749e6e4ca4193bd4a56 (diff)
downloadfreebsd-ports-gnome-71102e95212bab836c7a1f7b6a46879128507258.tar.gz
freebsd-ports-gnome-71102e95212bab836c7a1f7b6a46879128507258.tar.zst
freebsd-ports-gnome-71102e95212bab836c7a1f7b6a46879128507258.zip
Remove LOOP_VAR and replace it with tiny Makefiles using MASTERDIR to
share most files. Repository copy the default to explicitly named directories to avoid any confusion. Greatly simplify the shared Makefiles, since we are now in different subdirectories, we don't need "a4-install" stuff. While I'm here, consistently name the variables. Here are the guidelines (master port is in brackets) DOCFORMAT: [html] pdf ps KONFONT: 14dot [16dot] PAPERSIZE: a4 [letter] letterdj RESOLUTION: 118 240 [300] 360 400 600 "math/r" has been copied to "R-a4" and "R-letter", to follow the spirit of the original port. "japanese/kon" is renamed to "kon2-*", since that seems to be the basename.
Diffstat (limited to 'print/c2ps-letter')
-rw-r--r--print/c2ps-letter/Makefile28
1 files changed, 9 insertions, 19 deletions
diff --git a/print/c2ps-letter/Makefile b/print/c2ps-letter/Makefile
index 2a925298fd65..aae94eb01480 100644
--- a/print/c2ps-letter/Makefile
+++ b/print/c2ps-letter/Makefile
@@ -1,37 +1,27 @@
-# New ports collection makefile for: c2ps
+# New ports collection makefile for: c2ps (letter)
# Version required: 4.0
# Date created: 19 March 1997
# Whom: Matthew Hunt <mph@pobox.com>
#
-# $Id: Makefile,v 1.5 1998/04/17 23:26:29 mph Exp $
+# $Id: Makefile,v 1.6 1998/10/30 08:35:31 asami Exp $
#
DISTNAME= c2ps-4.0
-PKGNAME= c2ps-${PAPERSIZE:S/A4/a4/:S/LETTER/letter/:S/Letter/letter/}-4.0
+PKGNAME= c2ps-${PAPERSIZE}-4.0
CATEGORIES= print
MASTER_SITES= http://www.cs.technion.ac.il/users/c2ps/
MAINTAINER= mph@freebsd.org
-LOOP_VAR= PAPERSIZE
-LOOP_OPTIONS= letter a4
MAN1= c2ps.1
-MAKE_ENV= DEFAULT_PAPER_TYPE=${PAPERSIZE}
+MAKE_ENV= DEFAULT_PAPER_TYPE=${PS}
-.if !defined(PAPERSIZE)
-PAPERSIZE=A4
-.elif ${PAPERSIZE} == letter || ${PAPERSIZE} == Letter
-PAPERSIZE=LETTER
-.elif ${PAPERSIZE} == a4
-PAPERSIZE=A4
-.elif ${PAPERSIZE} != A4 && ${PAPERSIZE} != LETTER
-PAPERSIZE_INVALID=yes
-.endif
-
-pre-fetch:
-.if defined(PAPERSIZE_INVALID)
+PAPERSIZE?= letter
+PS!= echo ${PAPERSIZE} | awk '{print toupper($$1)}'
+.if ${PAPERSIZE} != a4 && ${PAPERSIZE} != letter
+.BEGIN:
@${ECHO} "Invalid value for PAPERSIZE: \"${PAPERSIZE}\""
- @${ECHO} "Possible values are: A4 (default), and Letter."
+ @${ECHO} "Possible values are: a4, and letter."
@${FALSE}
.endif