aboutsummaryrefslogtreecommitdiffstats
path: root/print/cups-base
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2014-04-23 03:32:06 +0800
committerbsam <bsam@FreeBSD.org>2014-04-23 03:32:06 +0800
commit8a0f8c64c3e2dddba88e7ef4570047cbf8d7a201 (patch)
tree6863974d12f014c21e6c3bd402edac994f46adda /print/cups-base
parentba473cd21d5c65eba74117c6f9e057c872f02750 (diff)
downloadfreebsd-ports-gnome-8a0f8c64c3e2dddba88e7ef4570047cbf8d7a201.tar.gz
freebsd-ports-gnome-8a0f8c64c3e2dddba88e7ef4570047cbf8d7a201.tar.zst
freebsd-ports-gnome-8a0f8c64c3e2dddba88e7ef4570047cbf8d7a201.zip
print/cups-base: remove BLOCKS detection from cups/cups.h
It appears to be the best option here, i.e. just remove BLOCKS detection from cups/cups.h: there are some other ports which use cups/cups.h and get broken by a BLOCKS detection. So: . patch cups/cups.h to remove the offending code; . remove traces of previous attempts to fix cups-* ports; . bump PORTREVISION; . at PORTNAME block add a note that PORTREVISION is defined later for all ports. Discussed at: freebsd-ports Suggested by: tijl MFH: 2014Q2
Diffstat (limited to 'print/cups-base')
-rw-r--r--print/cups-base/Makefile21
-rw-r--r--print/cups-base/files/patch-cups-cups.h16
2 files changed, 21 insertions, 16 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index f9b1d2352947..4b5ba203f179 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -4,7 +4,7 @@
PORTNAME= cups
PORTVERSION= 1.7.1
DISTVERSIONSUFFIX= -source
-PORTREVISION= 2
+#PORTREVISION= defined further
CATEGORIES= print
MASTER_SITES= http://www.cups.org/software/${DISTVERSION}/ \
EASYSW/${PORTNAME}/${DISTVERSION}
@@ -51,22 +51,20 @@ CUPSSYSGRP= wheel
GROUPS= cups
USERS= cups
-USES+= compiler
-
# UNIQUENAME must be set before bsd.port.pre.mk so OPTIONSFILE can be included
.if defined(CUPS_CLIENT)
-PORTREVISION= 0
+PORTREVISION= 1
LICENSE= LGPL21
CUPS_SUFFIX= -client
OPTIONS_DEFINE= GNUTLS
.elif defined(CUPS_IMAGE)
-PORTREVISION= 0
+PORTREVISION= 1
CUPS_SUFFIX= -image
LICENSE= LGPL21
OPTIONS_DEFINE= GNUTLS
.else
INSTALLS_ICONS= yes
-PORTREVISION= 0
+PORTREVISION= 1
CUPS_SUFFIX= -base
OPTIONS_DEFINE= GNUTLS LIBPAPER PHP PYTHON PAM DBUS LIBUSB XDG_OPEN AVAHI MDNSRESPONDER
OPTIONS_DEFAULT= LIBPAPER
@@ -300,13 +298,4 @@ post-install:
${INSTALL_SCRIPT} ${WRKDIR}/ulpt-cupsd.sh ${STAGEDIR}${PREFIX}/sbin/
.endif
-# This is to workaround a CUPS bug. Should be fixed by 1.7.3.
-# pfg@ filed a bug report upstream: https://www.cups.org/str.php?L4397
-#
-.include <bsd.port.pre.mk>
-.if (defined(CUPS_CLIENT) || defined(CUPS_IMAGE)) && ${OPSYS} == "FreeBSD" && \
- ${OSVERSION} > 1000000 && ${COMPILER_TYPE} == clang
-CFLAGS+= -fno-blocks
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/cups-base/files/patch-cups-cups.h b/print/cups-base/files/patch-cups-cups.h
new file mode 100644
index 000000000000..6f765480cd02
--- /dev/null
+++ b/print/cups-base/files/patch-cups-cups.h
@@ -0,0 +1,16 @@
+# This is to workaround a CUPS bug. Should be fixed by 1.7.3.
+# pfg@ filed a bug report upstream: https://www.cups.org/str.php?L4397
+#
+--- cups/cups.h.orig 2014-04-04 14:02:34.056258164 +0400
++++ cups/cups.h 2014-04-04 14:02:46.828258878 +0400
+@@ -30,10 +30,6 @@
+ typedef off_t ssize_t; /* @private@ */
+ # endif /* WIN32 && !__CUPS_SSIZE_T_DEFINED */
+
+-# ifdef __BLOCKS__
+-# include <dispatch/dispatch.h>
+-# endif /* __BLOCKS__ */
+-
+ # include "file.h"
+ # include "ipp.h"
+ # include "language.h"