aboutsummaryrefslogtreecommitdiffstats
path: root/print/cups-lpr
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2003-01-22 21:54:55 +0800
committeralane <alane@FreeBSD.org>2003-01-22 21:54:55 +0800
commitd1e8e640e9ddb3f555d4076a99143e831d3cfd59 (patch)
tree76c16563220c128925497bc1760d5efb4e30391f /print/cups-lpr
parent5c7711456283eb2c8137612ba6c394c5d8256450 (diff)
downloadfreebsd-ports-gnome-d1e8e640e9ddb3f555d4076a99143e831d3cfd59.tar.gz
freebsd-ports-gnome-d1e8e640e9ddb3f555d4076a99143e831d3cfd59.tar.zst
freebsd-ports-gnome-d1e8e640e9ddb3f555d4076a99143e831d3cfd59.zip
Long awaited update to 1.1.18.0
Diffstat (limited to 'print/cups-lpr')
-rw-r--r--print/cups-lpr/Makefile38
-rw-r--r--print/cups-lpr/distinfo2
-rw-r--r--print/cups-lpr/files/manpages.mk18
-rw-r--r--print/cups-lpr/files/patch-Makefile121
-rw-r--r--print/cups-lpr/files/patch-man-Makefile.common55
-rw-r--r--print/cups-lpr/pkg-message20
-rw-r--r--print/cups-lpr/pkg-plist3
7 files changed, 141 insertions, 116 deletions
diff --git a/print/cups-lpr/Makefile b/print/cups-lpr/Makefile
index 877270ee4fea..7440f33a4f6f 100644
--- a/print/cups-lpr/Makefile
+++ b/print/cups-lpr/Makefile
@@ -1,32 +1,28 @@
-# New ports collection makefile for: cups-lpr
-# Date created: 29 November 2001
-# Whom: James Halstead <jah4007@cs.rit.edu>
+# ex:ts=8 -*-mode: makefile-*-
+#
+# New ports collection makefile for: cups
+# Date created: 2003-01-22
+# Whom: Alan Eldridge <alane@geeksrus.net>
#
# $FreeBSD$
#
PORTNAME= cups-lpr
PORTVERSION= ${CUPS_PORTVER}
-PORTREVISION= 1
-CATEGORIES?= print
+PORTREVISION= 0
+PORTEPOCH= ${CUPS_PORTEPOCH}
+CATEGORIES= print
+MASTER_SITES= ${CUPS_MASTER_SITES}
MAINTAINER= alane@FreeBSD.org
-LIB_DEPENDS= cups.2:${.CURDIR}/../../print/cups-base
-
-MAN1= lp.1 lpoptions.1 lpq.1 lpr.1 lprm.1 lpstat.1 \
- lppasswd.1
-MAN8= accept.8 enable.8 lpadmin.8 lpc.8 lpinfo.8 \
- lpmove.8 cupsaddsmb.8
-
-USE_SUBMAKE= yes # required for MLINKS support
-
-MLINKS= accept.8 reject.8
-MLINKS+= enable.8 disable.8
-MLINKS+= lp.1 cancel.1
-
post-install:
- @${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGMESSAGE}
+ ${FIND} ${PREFIX}/man/cat* -type l -name '*.0' -delete
+ ${FIND} ${PREFIX}/man/fr/cat* -type l -name '*.0' -delete
+
+.include "${.CURDIR}/../../print/cups/Makefile.common"
+.include <bsd.port.pre.mk>
+.include "${FILESDIR}/manpages.mk"
+.include <bsd.port.post.mk>
-.include "${.CURDIR}/../../print/cups/Makefile.inc"
-.include <bsd.port.mk>
+#EOF
diff --git a/print/cups-lpr/distinfo b/print/cups-lpr/distinfo
index 0edc8c761640..7c4c9f612542 100644
--- a/print/cups-lpr/distinfo
+++ b/print/cups-lpr/distinfo
@@ -1 +1 @@
-MD5 (cups-1.1.15-1-source.tar.bz2) = 971a14d35f61ea19871616f437e199a2
+MD5 (cups-1.1.18-source.tar.bz2) = 4a8a423a8268d088bffa19f6515883a7
diff --git a/print/cups-lpr/files/manpages.mk b/print/cups-lpr/files/manpages.mk
new file mode 100644
index 000000000000..fa6f89285ff8
--- /dev/null
+++ b/print/cups-lpr/files/manpages.mk
@@ -0,0 +1,18 @@
+MAN1+= cupsaddsmb.1
+MAN1+= cupstestppd.1
+MAN1+= lp.1
+MAN1+= lpoptions.1
+MAN1+= lppasswd.1
+MAN1+= lpq.1
+MAN1+= lpr.1
+MAN1+= lprm.1
+MAN1+= lpstat.1
+MAN8+= accept.8
+MAN8+= enable.8
+MAN8+= lpadmin.8
+MAN8+= lpc.8
+MAN8+= lpinfo.8
+MAN8+= lpmove.8
+MLINKS+= lp.1 cancel.1
+MLINKS+= enable.8 disable.8
+MLINKS+= accept.8 reject.8
diff --git a/print/cups-lpr/files/patch-Makefile b/print/cups-lpr/files/patch-Makefile
index 1e8bd03e34cb..133708751f6d 100644
--- a/print/cups-lpr/files/patch-Makefile
+++ b/print/cups-lpr/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Apr 23 13:49:34 2002
-+++ Makefile Sat Jun 8 01:20:35 2002
+--- Makefile.orig Tue Dec 17 13:56:25 2002
++++ Makefile Wed Jan 22 08:02:38 2003
@@ -28,8 +28,7 @@
# Directories to make...
#
@@ -19,25 +19,7 @@
echo Making all in $$dir... ;\
(cd $$dir ; $(MAKE) $(MFLAGS)) || exit 1;\
done
-@@ -47,7 +46,7 @@
- #
-
- clean:
-- for dir in $(DIRS); do\
-+ for dir in cups $(DIRS); do\
- echo Cleaning in $$dir... ;\
- (cd $$dir; $(MAKE) $(MFLAGS) clean) || exit 1;\
- done
-@@ -57,7 +56,7 @@
- #
-
- depend:
-- for dir in $(DIRS); do\
-+ for dir in cups $(DIRS); do\
- echo Making dependencies in $$dir... ;\
- (cd $$dir; $(MAKE) $(MFLAGS) depend) || exit 1;\
- done
-@@ -67,52 +66,52 @@
+@@ -67,104 +66,11 @@
# Install object and target files...
#
@@ -88,47 +70,58 @@
- $(INSTALL_SCRIPT) cups.sh $(BUILDROOT)$(INITDDIR)/cups; \
- fi \
- fi
-+# echo Installing in conf...
-+# (cd conf; $(MAKE) $(MFLAGS) install)
-+# echo Installing in data...
-+# (cd data; $(MAKE) $(MFLAGS) install)
-+# echo Installing in doc...
-+# (cd doc; $(MAKE) $(MFLAGS) install)
-+# echo Installing in fonts...
-+# (cd fonts; $(MAKE) $(MFLAGS) install)
-+# echo Installing in locale...
-+# (cd locale; $(MAKE) $(MFLAGS) install)
-+# echo Installing in ppd...
-+# (cd ppd; $(MAKE) $(MFLAGS) install)
-+# echo Installing in templates...
-+# (cd templates; $(MAKE) $(MFLAGS) install)
-+# echo Installing cups-config script...
-+# $(INSTALL_DIR) $(BINDIR)
-+# $(INSTALL_SCRIPT) cups-config $(BINDIR)/cups-config
-+# echo Installing startup script...
-+# if test "x$(INITDIR)" != "x"; then \
-+# $(INSTALL_DIR) $(BUILDROOT)$(INITDIR)/init.d; \
-+# $(INSTALL_SCRIPT) cups.sh $(BUILDROOT)$(INITDIR)/init.d/cups; \
-+# $(INSTALL_DIR) $(BUILDROOT)$(INITDIR)/rc0.d; \
-+# $(INSTALL_SCRIPT) cups.sh $(BUILDROOT)$(INITDIR)/rc0.d/K00cups; \
-+# $(INSTALL_DIR) $(BUILDROOT)$(INITDIR)/rc2.d; \
-+# $(INSTALL_SCRIPT) cups.sh $(BUILDROOT)$(INITDIR)/rc2.d/S99cups; \
-+# $(INSTALL_DIR) $(BUILDROOT)$(INITDIR)/rc3.d; \
-+# $(INSTALL_SCRIPT) cups.sh $(BUILDROOT)$(INITDIR)/rc3.d/S99cups; \
-+# $(INSTALL_DIR) $(BUILDROOT)$(INITDIR)/rc5.d; \
-+# $(INSTALL_SCRIPT) cups.sh $(BUILDROOT)$(INITDIR)/rc5.d/S99cups; \
-+# fi
-+# if test "x$(INITDIR)" = "x" -a "x$(INITDDIR)" != "x"; then \
-+# $(INSTALL_DIR) $(BUILDROOT)$(INITDDIR); \
-+# if test "$(INITDDIR)" = "/System/Library/StartupItems/PrintingServices"; then \
-+# $(INSTALL_SCRIPT) cups.sh $(BUILDROOT)$(INITDDIR)/PrintingServices; \
-+# $(INSTALL_DATA) cups.plist $(BUILDROOT)$(INITDDIR)/StartupParameters.plist; \
-+# $(INSTALL_DIR) $(BUILDROOT)$(INITDDIR)/Resources/English.lproj; \
-+# $(INSTALL_DATA) cups.strings $(BUILDROOT)$(INITDDIR)/Resources/English.lproj/Localizable.strings; \
-+# else \
-+# $(INSTALL_SCRIPT) cups.sh $(BUILDROOT)$(INITDDIR)/cups; \
-+# fi \
-+# fi
-
+-
+-#
+-# Install source and header files...
+-#
+-
+-installsrc:
+- gnutar --dereference --exclude=CVS -cf - . | gnutar -C $(SRCROOT) -xf -
+-
+-installhdrs:
+- (cd cups ; $(MAKE) $(MFLAGS) installhdrs) || exit 1;\
+- (cd filter ; $(MAKE) $(MFLAGS) installhdrs) || exit 1;
+-
+-
+-#
+-# Run the test suite...
+-#
+-
+-check test: all
+- echo Running CUPS test suite...
+- cd test; ./run-stp-tests.sh
+-
+-
+-#
+-# Make software distributions using EPM (http://www.easysw.com/epm)...
+-#
+-
+-EPMFLAGS = -v
+-
+-aix:
+- epm $(EPMFLAGS) -f aix cups
+-
+-bsd:
+- epm $(EPMFLAGS) -f bsd cups
+-
+-epm:
+- epm $(EPMFLAGS) cups
+-
+-rpm:
+- epm $(EPMFLAGS) -f rpm cups
+-
+-deb:
+- epm $(EPMFLAGS) -f deb cups
+-
+-depot:
+- epm $(EPMFLAGS) -f depot cups
+-
+-pkg:
+- epm $(EPMFLAGS) -f pkg cups
+-
+-tardist:
+- epm $(EPMFLAGS) -f tardist cups
+-
+ #
+ # End of "$Id: Makefile,v 1.47 2002/12/17 18:56:25 swdev Exp $".
#
- # Install source and header files...
diff --git a/print/cups-lpr/files/patch-man-Makefile.common b/print/cups-lpr/files/patch-man-Makefile.common
index e3b450f5d23a..b160843f0ed0 100644
--- a/print/cups-lpr/files/patch-man-Makefile.common
+++ b/print/cups-lpr/files/patch-man-Makefile.common
@@ -1,16 +1,18 @@
---- man/Makefile.common.orig Sat Jun 8 01:05:48 2002
-+++ man/Makefile.common Sat Jun 8 01:08:44 2002
-@@ -26,26 +26,17 @@
+--- man/Makefile.common.orig Tue Dec 17 13:59:55 2002
++++ man/Makefile.common Wed Jan 22 07:38:08 2003
+@@ -26,9 +26,8 @@
# Man pages...
#
-MAN1 = backend.man \
+- cupstestppd.man \
- filter.man \
-- lp.man \
-+MAN1 = lp.man \
++MAN1 = cupsaddsmb.man\
++ cupstestppd.man\
+ lp.man \
lpoptions.man \
lppasswd.man \
- lpq.man \
+@@ -36,50 +35,17 @@
lprm.man \
lpr.man \
lpstat.man
@@ -20,13 +22,48 @@
- mime.convs.man \
- mime.types.man \
- printers.conf.man
-+MAN3 =
-+MAN5 =
MAN8 = accept.man \
- cupsaddsmb.man \
+- cupsaddsmb.man \
- cups-lpd.man \
- cups-polld.man \
- cupsd.man \
enable.man \
lpadmin.man \
lpinfo.man \
+ lpmove.man \
+ lpc.man
+
+-CAT1 = backend.$(CAT1EXT) \
+- cupstestppd.$(CAT1EXT) \
+- filter.$(CAT1EXT) \
+- lp.$(CAT1EXT) \
+- lpoptions.$(CAT1EXT) \
+- lppasswd.$(CAT1EXT) \
+- lpq.$(CAT1EXT) \
+- lprm.$(CAT1EXT) \
+- lpr.$(CAT1EXT) \
+- lpstat.$(CAT1EXT)
+-CAT3 = cups-config.$(CAT3EXT)
+-CAT5 = classes.conf.$(CAT5EXT) \
+- cupsd.conf.$(CAT5EXT) \
+- mime.convs.$(CAT5EXT) \
+- mime.types.$(CAT5EXT) \
+- printers.conf.$(CAT5EXT)
+-CAT8 = accept.$(CAT8EXT) \
+- cupsaddsmb.$(CAT8EXT) \
+- cups-lpd.$(CAT8EXT) \
+- cups-polld.$(CAT8EXT) \
+- cupsd.$(CAT8EXT) \
+- enable.$(CAT8EXT) \
+- lpadmin.$(CAT8EXT) \
+- lpinfo.$(CAT8EXT) \
+- lpmove.$(CAT8EXT) \
+- lpc.$(CAT8EXT)
+-
++CAT1 =
++CAT3 =
++CAT5 =
++CAT8 =
+
+ #
+ # End of "$Id: Makefile.common,v 1.3 2002/12/17 18:59:55 swdev Exp $".
diff --git a/print/cups-lpr/pkg-message b/print/cups-lpr/pkg-message
deleted file mode 100644
index e75d8c7b65f3..000000000000
--- a/print/cups-lpr/pkg-message
+++ /dev/null
@@ -1,20 +0,0 @@
-======================================================================
-
-CUPS BSD and system V print compatibility system is installed.
-
-This port installs binaries (lpr, lpc, etc) which have the same names as
-binaries in /usr/bin and /usr/sbin. Assuming you installed this port to use
-cups fully, the minimum you need to do is make sure all users PATH variable
-has %%PREFIX%%/bin before /usr/bin. As this is not always easy to do,
-you may consider removing the FreeBSD printing system completely. To do this,
-remove the binaries and man pages listed below, and set NO_LPR=true in your
-/etc/make.conf. This will prevent future buildworlds from re-installing the
-binaries, but will not prevent them from getting re-installed during a binary
-upgrade.
-
-The relevant files for the FreeBSD printing system are:
-(with wildcards to make it easier)
-/usr/bin/lp* /usr/sbin/lpc /usr/sbin/lpd /usr/share/man/cat*/lp*
-/usr/share/man/man1/lp.* /usr/share/man/man1/lp[a-s,u-z]*
-
-======================================================================
diff --git a/print/cups-lpr/pkg-plist b/print/cups-lpr/pkg-plist
index d11fea616efa..310bf8bd6315 100644
--- a/print/cups-lpr/pkg-plist
+++ b/print/cups-lpr/pkg-plist
@@ -9,9 +9,10 @@ bin/lpr
bin/lprm
bin/lpstat
sbin/accept
+sbin/reject
sbin/cupsaddsmb
+sbin/cupstestppd
sbin/lpadmin
sbin/lpc
sbin/lpinfo
sbin/lpmove
-sbin/reject