aboutsummaryrefslogtreecommitdiffstats
path: root/print/cups-smb-backend
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-11-18 00:49:52 +0800
committerpav <pav@FreeBSD.org>2005-11-18 00:49:52 +0800
commitbc7433b649a0f42b0c3bd5d984875333cfa8d7e9 (patch)
tree1520bb72209bbb48a6826a7e2d599581781c85e0 /print/cups-smb-backend
parent5cb37e35d5543c4f1a7372ab09b06389eb90b07a (diff)
downloadfreebsd-ports-gnome-bc7433b649a0f42b0c3bd5d984875333cfa8d7e9.tar.gz
freebsd-ports-gnome-bc7433b649a0f42b0c3bd5d984875333cfa8d7e9.tar.zst
freebsd-ports-gnome-bc7433b649a0f42b0c3bd5d984875333cfa8d7e9.zip
CUPS smb backend allows *nix users to print to Windows-attached printers via
smbspool program, which comes with Samba. PR: ports/88887 Submitted by: Andrew Pantyukhin <infofarmer@gmail.com>
Diffstat (limited to 'print/cups-smb-backend')
-rw-r--r--print/cups-smb-backend/Makefile28
-rw-r--r--print/cups-smb-backend/files/pkg-message.in17
-rw-r--r--print/cups-smb-backend/pkg-descr5
3 files changed, 50 insertions, 0 deletions
diff --git a/print/cups-smb-backend/Makefile b/print/cups-smb-backend/Makefile
new file mode 100644
index 000000000000..bdd5f580a832
--- /dev/null
+++ b/print/cups-smb-backend/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: cups-smb-backend
+# Date created: 12 November 2005
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cups-smb-backend
+PORTVERSION= 1.0
+CATEGORIES= print
+MASTER_SITES= # empty
+DISTFILES= # empty
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= A CUPS backend for printing to Windows servers
+
+RUN_DEPENDS= smbspool:${PORTSDIR}/net/samba3 \
+ ${LOCALBASE}/sbin/cupsd:${PORTSDIR}/print/cups-base
+
+NO_BUILD= yes
+PLIST_FILES= libexec/cups/backend/smb
+SUB_FILES= pkg-message
+
+do-install:
+ ${LN} -fs ${PREFIX}/bin/smbspool ${PREFIX}/libexec/cups/backend/smb
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/print/cups-smb-backend/files/pkg-message.in b/print/cups-smb-backend/files/pkg-message.in
new file mode 100644
index 000000000000..02f336ddda79
--- /dev/null
+++ b/print/cups-smb-backend/files/pkg-message.in
@@ -0,0 +1,17 @@
+CUPS smb backend is now installed.
+
+Please configure your samba environment if
+you haven't already done so. To do so edit
+
+%%PREFIX%%/etc/smb.conf
+
+You can then add a new printer to CUPS.
+smbspool(8) manpage describes device URI
+format. In most cases (latest samba 2.x
+and samba 3.x), it's something like this:
+
+smb://username:password@server/printer
+smb://username:password@workgroup/server/printer
+
+But a CUPS article describes another syntax,
+so beware.
diff --git a/print/cups-smb-backend/pkg-descr b/print/cups-smb-backend/pkg-descr
new file mode 100644
index 000000000000..e86a36c61b8a
--- /dev/null
+++ b/print/cups-smb-backend/pkg-descr
@@ -0,0 +1,5 @@
+CUPS smb backend allows *nix users to print
+to Windows-attached printers via smbspool
+program, which comes with Samba.
+
+WWW: http://www.cups.org/articles.php?L294