aboutsummaryrefslogtreecommitdiffstats
path: root/print/epsonepl/Makefile
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-07-06 20:29:21 +0800
committerpawel <pawel@FreeBSD.org>2014-07-06 20:29:21 +0800
commit343f5009af5d6cbeaa40a88d83b014f968c8084e (patch)
treeb32bb9599c074180eac5bdcde26d9929bcc1adf7 /print/epsonepl/Makefile
parent5015442325a3142e63b8ef2138d18f476b660475 (diff)
downloadfreebsd-ports-gnome-343f5009af5d6cbeaa40a88d83b014f968c8084e.tar.gz
freebsd-ports-gnome-343f5009af5d6cbeaa40a88d83b014f968c8084e.tar.zst
freebsd-ports-gnome-343f5009af5d6cbeaa40a88d83b014f968c8084e.zip
- Add staging support, allow it as regular user
- Convert to new LIB_DEPENDS format - Use SUB_FILES for path substitution - Unmute install commands
Diffstat (limited to 'print/epsonepl/Makefile')
-rw-r--r--print/epsonepl/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/print/epsonepl/Makefile b/print/epsonepl/Makefile
index 7b91fae18e9d..57c2c833a9d8 100644
--- a/print/epsonepl/Makefile
+++ b/print/epsonepl/Makefile
@@ -12,20 +12,21 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Printer filter for EPSON EPL-5700L etc
-USE_GHOSTSCRIPT_RUN= yes
+LIB_DEPENDS= libijs.so:${PORTSDIR}/print/libijs
-LIB_DEPENDS= ijs.1:${PORTSDIR}/print/libijs
+USES= uidfix
+USE_GHOSTSCRIPT_RUN= yes
MAKEFILE= ${FILESDIR}/Makefile
+SUB_FILES= pkg-message
-NO_STAGE= yes
post-extract:
@cd ${WRKSRC} && ${LS} ijs* | ${GREP} -v ${PORTNAME} | ${XARGS} ${RM}
post-install:
- @${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.conf.sample ${PREFIX}/etc
- @${MKDIR} ${DATADIR}
- @${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.apsfilter ${DATADIR}
- @${SED} -e 's#%%PREFIX%%#${PREFIX}#' ${PKGMESSAGE}
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.conf.sample \
+ ${STAGEDIR}${PREFIX}/etc
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.apsfilter ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>