aboutsummaryrefslogtreecommitdiffstats
path: root/print/flpsed/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-07-19 21:25:22 +0800
committermiwi <miwi@FreeBSD.org>2008-07-19 21:25:22 +0800
commit6623b2ba987d927f2dac9ae3a8c435084d7440a5 (patch)
tree0cf69f5eaf33aea183ffb1ddf2cb03ee47e21eee /print/flpsed/Makefile
parent5ebd6fa04fc438f8d0b13234143dc210aa639281 (diff)
downloadfreebsd-ports-gnome-6623b2ba987d927f2dac9ae3a8c435084d7440a5.tar.gz
freebsd-ports-gnome-6623b2ba987d927f2dac9ae3a8c435084d7440a5.tar.zst
freebsd-ports-gnome-6623b2ba987d927f2dac9ae3a8c435084d7440a5.zip
- Update to 0.6.1
- Fix dependencys - Fix grammer - Update WWW PR: 125144 Submitted by: bf <bf2006a@yahoo.com> Approved by: maintainer timeout
Diffstat (limited to 'print/flpsed/Makefile')
-rw-r--r--print/flpsed/Makefile25
1 files changed, 21 insertions, 4 deletions
diff --git a/print/flpsed/Makefile b/print/flpsed/Makefile
index f7be3765b3be..c633be7c5f62 100644
--- a/print/flpsed/Makefile
+++ b/print/flpsed/Makefile
@@ -6,28 +6,45 @@
#
PORTNAME= flpsed
-PORTVERSION= 0.3.9
-PORTREVISION= 1
+PORTVERSION= 0.6.1
CATEGORIES= print
MASTER_SITES= http://www.ecademix.com/JohannesHofmann/
MAINTAINER= fernan@iib.unsam.edu.ar
-COMMENT= WYSIWYG pseudo Postscript editor
+COMMENT= WYSIWYG Postscript pseudo-editor
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libfltk2.a:${PORTSDIR}/x11-toolkits/fltk2
+RUN_DEPENDS+= ${LOCALBASE}/lib/libfltk2.a:${PORTSDIR}/x11-toolkits/fltk2
GNU_CONFIGURE= yes
USE_GHOSTSCRIPT=yes
USE_GMAKE= yes
PLIST_FILES= bin/flpsed
+MAN1= flpsed.1
PORTDOCS= README
+post-configure:
+ @${FIND} -X ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
+ "s|-lpthread|${PTHREAD_LIBS}|g"
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/flpsed ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/flpsed.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
+post-install:
+.if !exists(${LOCALBASE}/bin/pdftops)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} " Consider installing graphics/xpdf, to take full advantage of "
+ @${ECHO_CMD} " flpsed's ability to edit PDF files by first converting them "
+ @${ECHO_CMD} " to PostScript via xpdf's pdftops(1) before editing, and then "
+ @${ECHO_CMD} " transforming the edited Postscript files back to PDF via "
+ @${ECHO_CMD} " Ghostscript's ps2pdf(1). "
+ @${ECHO_CMD} ""
+.endif
+
.include <bsd.port.mk>