aboutsummaryrefslogtreecommitdiffstats
path: root/print/fpdf
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-04-09 00:08:52 +0800
committerthierry <thierry@FreeBSD.org>2006-04-09 00:08:52 +0800
commit6d8c29af71546156568d580fc132b9870df2202e (patch)
tree4eb6ef4ff54855d64b6965b9eb3b8557077b04d5 /print/fpdf
parent266d1e2e1b2709d75ee06bea947fb6e67fda232a (diff)
downloadfreebsd-ports-gnome-6d8c29af71546156568d580fc132b9870df2202e.tar.gz
freebsd-ports-gnome-6d8c29af71546156568d580fc132b9870df2202e.tar.zst
freebsd-ports-gnome-6d8c29af71546156568d580fc132b9870df2202e.zip
Don"t try to convert every type of files.
PR: 95453 Submitted by: Dmitry Marakasov <amdmi3 (at) mail.ru>
Diffstat (limited to 'print/fpdf')
-rw-r--r--print/fpdf/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/print/fpdf/Makefile b/print/fpdf/Makefile
index a1220dadaa5b..61e52a58aac5 100644
--- a/print/fpdf/Makefile
+++ b/print/fpdf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fpdf
PORTVERSION= 1.53
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print www
MASTER_SITES= http://www.fpdf.org/fr/
DISTNAME= ${PORTNAME}${PORTVERSION:S|.||}
@@ -18,7 +18,6 @@ COMMENT= A free PHP class to generate PDF files with pure PHP
USE_PHP= zlib
-USE_DOS2UNIX= yes
FETCH_CMD= /usr/bin/fetch -ARr -o ${DISTDIR}/${DISTFILES}
NO_BUILD= yes
@@ -28,6 +27,7 @@ SUB_FILES= pkg-message
SUB_LIST= FPDF_DIR=${FPDF_DIR}
PLIST_SUB= FPDF_DIR=${FPDF_DIR}
+EXT2CNV= afm css htm php txt
DOCS= FAQ.htm doc/* fpdf.css histo.htm install.txt tutoriel
do-fetch:
@@ -37,6 +37,11 @@ do-fetch:
fi
pre-patch:
+ @${ECHO_MSG} "===> Converting DOS text files to UNIX text files"
+.for ext in ${EXT2CNV}
+ @${FIND} ${WRKSRC} -type f -name "*.${ext}" -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -i '' -e 's/ $$//'
+.endfor
@${FIND} ${WRKSRC} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
do-install: