aboutsummaryrefslogtreecommitdiffstats
path: root/print/ghostscript-gpl/Makefile
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>1998-12-03 16:24:21 +0800
committerandreas <andreas@FreeBSD.org>1998-12-03 16:24:21 +0800
commite1c4df0ecddf5cabe6d9b817e9d9e5c6e518ed2b (patch)
treea6135475eda016e25b4462d735a5d5057b2c826f /print/ghostscript-gpl/Makefile
parent00efc4ce62e47dc580430c05bab51e16e3f90775 (diff)
downloadfreebsd-ports-gnome-e1c4df0ecddf5cabe6d9b817e9d9e5c6e518ed2b.tar.gz
freebsd-ports-gnome-e1c4df0ecddf5cabe6d9b817e9d9e5c6e518ed2b.tar.zst
freebsd-ports-gnome-e1c4df0ecddf5cabe6d9b817e9d9e5c6e518ed2b.zip
*** empty log message ***
Diffstat (limited to 'print/ghostscript-gpl/Makefile')
-rw-r--r--print/ghostscript-gpl/Makefile50
1 files changed, 24 insertions, 26 deletions
diff --git a/print/ghostscript-gpl/Makefile b/print/ghostscript-gpl/Makefile
index bfc4cd815897..74807a6b2b89 100644
--- a/print/ghostscript-gpl/Makefile
+++ b/print/ghostscript-gpl/Makefile
@@ -3,32 +3,33 @@
# Date created: Tue Jun 10 21:58:54 CEST 1997
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.24 1998/11/28 09:07:15 asami Exp $
+# $Id: Makefile,v 1.25 1998/12/01 09:59:46 asami Exp $
#
-DISTNAME= ghostscript-5.10
+DISTNAME= ghostscript-5.50
CATEGORIES= print
-MASTER_SITES= ftp://ftp.cs.wisc.edu/ghost/aladdin/gs510/ \
- ftp://bonk.ethz.ch/gs-driver-distrib/ \
+MASTER_SITES= ftp://ftp.cs.wisc.edu/ghost/aladdin/gs550/ \
+ http://www.erdw.ethz.ch/~bonk/ftp/gs-driver-distrib/ \
http://www.ozemail.com.au/~geoffk/pdfencrypt/
DISTFILES= ${GS_SOURCES} ${GS_FONTS_STD} ${GS_FONTS_OTHER} \
${HP850_DRV} ${DECRYPT_PDF}
+
MAINTAINER= andreas@FreeBSD.ORG
BUILD_DEPENDS= /nonexistent:${PORTSDIR}/graphics/jpeg:extract \
/nonexistent:${PORTSDIR}/graphics/png:extract \
unzip:${PORTSDIR}/archivers/unzip
+LIB_DEPENDS= png.2:${PORTSDIR}/graphics/png
USE_XLIB= yes
-MAKE_ENV= PORTSDIR=${PORTSDIR}
EXTRACT_ONLY= ${GS_SOURCES}
-WRKSRC= ${WRKDIR}/gs5.10
+WRKSRC= ${WRKDIR}/gs5.50
+USE_GMAKE= yes
MAKEFILE= unix-gcc.mak
-MAKE_FLAGS= prefix=${PREFIX} zlibc_=-lz CFLAGS="${CFLAGS}" -f
-MAN1= gs.1 pdf2dsc.1 pdf2ps.1 ps2ascii.1 ps2epsi.1 ps2pdf.1
+MAN1= gs.1 pdf2dsc.1 pdf2ps.1 ps2ascii.1 ps2epsi.1 ps2pdf.1 ps2ps.1
-GS_SOURCES= ghostscript-5.10.tar.gz
-GS_SOURCES+= ghostscript-5.10gnu.tar.gz
+GS_SOURCES= ghostscript-5.50.tar.gz
+GS_SOURCES+= ghostscript-5.50gnu.tar.gz
# Note: the following two are real files that have symlinks with
# later version numbers pointing to them. To avoid unnecessarily
# downloading distfiles, do not change these when upgrading the port
@@ -36,7 +37,7 @@ GS_SOURCES+= ghostscript-5.10gnu.tar.gz
GS_FONTS_STD= ghostscript-fonts-std-5.10.tar.gz
GS_FONTS_OTHER= ghostscript-fonts-other-5.10.tar.gz
-# Additional driver HP 850, see http://bonk.ethz.ch/hp850/hp850.html
+# Additional driver HP 850, see http://www.erdw.ethz.ch/~bonk/hp850/hp850.html
HP850_DRV= hp8xxs13.zip
# replacement for pdf_sec.ps, that allows you to read encrypted PDF files
@@ -54,25 +55,22 @@ pre-fetch:
.endif
post-extract:
- ${TOUCH} ${WRKSRC}/adler32.c
- ${TOUCH} ${WRKSRC}/deflate.c
- ${TOUCH} ${WRKSRC}/trees.c
- ${TOUCH} ${WRKSRC}/adler32.o
- ${TOUCH} ${WRKSRC}/deflate.o
- ${TOUCH} ${WRKSRC}/trees.o
- ln -s ${WRKDIRPREFIX}${PORTSDIR}/graphics/jpeg/work/jpeg-6b ${WRKSRC}/jpeg-6b
- ln -s ${WRKDIRPREFIX}${PORTSDIR}/graphics/png/work/libpng-1.0.2 ${WRKSRC}/libpng
+ ${LN} -s ${WRKDIRPREFIX}${PORTSDIR}/graphics/jpeg/work/jpeg-6b ${WRKSRC}/jpeg
+ ${LN} -s ${WRKDIRPREFIX}${PORTSDIR}/graphics/png/work/libpng-1.0.2 ${WRKSRC}/libpng
+ ${MV} ${WRKSRC}/devs.mak ${WRKSRC}/devs.mak.bak
cd ${WRKSRC} && unzip -Lao ${DISTDIR}/${HP850_DRV}
+ ${MV} ${WRKSRC}/devs.mak.bak ${WRKSRC}/devs.mak
do-configure:
.if defined(BATCH)
- @${SETENV} PORTSDIR=${PORTSDIR} WRKSRC=${WRKSRC} \
- ${SH} ${SCRIPTDIR}/configure.batch
+ @${SETENV} WRKSRC=${WRKSRC} ${SH} ${SCRIPTDIR}/configure.batch
.else
- @${SETENV} PORTSDIR=${PORTSDIR} WRKSRC=${WRKSRC} \
- ${SH} ${SCRIPTDIR}/configure
+ @${SETENV} WRKSRC=${WRKSRC} ${SH} ${SCRIPTDIR}/configure
.endif
+pre-build:
+ ${MKDIR} ${WRKSRC}/obj
+
pre-install:
@${MKDIR} ${PREFIX}/share/ghostscript ${PREFIX}/bin ${PREFIX}/man/man1
(cd ${PREFIX}/share/ghostscript ; \
@@ -84,10 +82,10 @@ pre-install:
post-install:
strip ${PREFIX}/bin/gs
${INSTALL_DATA} ${DISTDIR}/${DECRYPT_PDF} \
- ${PREFIX}/share/ghostscript/5.10
+ ${PREFIX}/share/ghostscript/5.50
${INSTALL_DATA} ${WRKSRC}/license.hp8 \
- ${PREFIX}/share/ghostscript/5.10/doc
+ ${PREFIX}/share/ghostscript/5.50/doc
${INSTALL_DATA} ${WRKSRC}/readme.hp8 \
- ${PREFIX}/share/ghostscript/5.10/doc
+ ${PREFIX}/share/ghostscript/5.50/doc
.include <bsd.port.mk>