aboutsummaryrefslogtreecommitdiffstats
path: root/print/ghostscript7-commfont/Makefile
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2007-04-28 21:03:16 +0800
committerhrs <hrs@FreeBSD.org>2007-04-28 21:03:16 +0800
commited1f4c541c95c56d099b48bb52ff53d5c34806bb (patch)
tree809af14cbb9cad7d1a9b177b46be43628c281326 /print/ghostscript7-commfont/Makefile
parent670b9382a20f633d6c0cb952c05cccabeb8a118f (diff)
downloadfreebsd-ports-gnome-ed1f4c541c95c56d099b48bb52ff53d5c34806bb.tar.gz
freebsd-ports-gnome-ed1f4c541c95c56d099b48bb52ff53d5c34806bb.tar.zst
freebsd-ports-gnome-ed1f4c541c95c56d099b48bb52ff53d5c34806bb.zip
Cleanup ghostscript-gnu-commfont and related CJK font support meta ports.
Changes include: - Set WITH_GHOSTSCRIPT_GNU forcibly. - Use PostScript virtual fonts to handle CJK CID/TT-CID emulated fonts. CIDFnmap still works but when a font is both in Resource/Font or Resource/CIDFont and in CIDFnmap, the former entry will be used. For the actual font mapping, see files in Resource/CIDFont/*. So, note that you need to remove (or rename) the virtual font if you use CIDFnmap for the moment. This is still a transitional measure and more consistent font management thoughout the ports collection should be added later. This is just an internal structural change; default font mapping has not been changed. - Add Chinese font support to print/gsfonts (but no dependency added).
Diffstat (limited to 'print/ghostscript7-commfont/Makefile')
-rw-r--r--print/ghostscript7-commfont/Makefile39
1 files changed, 35 insertions, 4 deletions
diff --git a/print/ghostscript7-commfont/Makefile b/print/ghostscript7-commfont/Makefile
index 75f9300f38e0..794c645c65a3 100644
--- a/print/ghostscript7-commfont/Makefile
+++ b/print/ghostscript7-commfont/Makefile
@@ -5,9 +5,40 @@
# $FreeBSD$
#
-MASTERDIR= ${.CURDIR}
-PORTREVISION= 3
+PORTNAME= ghostscript-gnu-commfont
+PORTVERSION= 7.07
+PORTREVISION= 4
+CATEGORIES= print
+MASTER_SITES= # empty
+DISTFILES= # empty
-COMMFONT= yes
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Common files for GNU Ghostscript CJK font support
-.include "${MASTERDIR}/Makefile.common"
+RUN_DEPENDS= ${CMAPDIR}/ac15/cid2code.txt:${PORTSDIR}/print/adobe-cmaps
+
+NO_WRKSUBDIR= yes
+SUB_FILES= pkg-message \
+ Makefile template.cidfont template.ttcidfont template.font
+SUB_LIST= PORTVERSION="${PORTVERSION}" GS_RESDIR="${GS_RESDIR}"
+PLIST_SUB= GS_RESDIR="${GS_RESDIR}"
+PKGMESSAGE= ${WRKDIR}/pkg-message
+DEPENDS_ARGS+= -DA4
+# set these forcibly
+USE_GHOSTSCRIPT= yes
+WITH_GHOSTSCRIPT_GNU= yes
+
+CONFLICTS= ghostscript-afpl-[0-9]* \
+ ghostscript-afpl-nox11-[0-9]* \
+ ghostscript-gpl-[0-9]* \
+ ghostscript-gpl-nox11-[0-9]*
+
+CMAPDIR?= ${LOCALBASE}/share/fonts/adobe-cmaps
+GS_RESDIR?= share/ghostscript/Resource
+
+post-extract: apply-slist
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>