aboutsummaryrefslogtreecommitdiffstats
path: root/print/ghostscript7-commfont/Makefile
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-04-30 04:12:16 +0800
committerhrs <hrs@FreeBSD.org>2013-04-30 04:12:16 +0800
commit175f60e46f0594dff3c3315640679dcbc83775ea (patch)
treeb668622bec03cea02602798988a5ed72533143b2 /print/ghostscript7-commfont/Makefile
parent570c1e46e4147388fbc47465b6227d7a1e1dde4e (diff)
downloadfreebsd-ports-gnome-175f60e46f0594dff3c3315640679dcbc83775ea.tar.gz
freebsd-ports-gnome-175f60e46f0594dff3c3315640679dcbc83775ea.tar.zst
freebsd-ports-gnome-175f60e46f0594dff3c3315640679dcbc83775ea.zip
Resurrect print/ghostscript7*. Ghostscript 7.x is incompatible with 8.x
and 9.x in terms of CJK character support and they are still in demand. While I am here, the following changes have been added: - Add LICENSE. - Use OPTIONS_DEFINE for ghostscript drivers. - Add MAKE_JOBS_SAFE=yes. Discussed with: bapt
Diffstat (limited to 'print/ghostscript7-commfont/Makefile')
-rw-r--r--print/ghostscript7-commfont/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/print/ghostscript7-commfont/Makefile b/print/ghostscript7-commfont/Makefile
new file mode 100644
index 000000000000..4b211deb0434
--- /dev/null
+++ b/print/ghostscript7-commfont/Makefile
@@ -0,0 +1,43 @@
+# Created by: Tomokatsu SAITO <saito@a2z.co.jp>
+# $FreeBSD$
+
+PORTNAME= ghostscript
+PORTVERSION= 7.07
+PORTREVISION= 11
+CATEGORIES= print
+MASTER_SITES= # empty
+PKGNAMESUFFIX= 7-commfont
+DISTFILES= # empty
+
+MAINTAINER= doceng@FreeBSD.org
+COMMENT= Common files for Ghostscript 7.x CJK font support
+
+BUILD_DEPENDS= ${CMAPDIR}/ac15/cid2code.txt:${PORTSDIR}/print/adobe-cmaps
+RUN_DEPENDS= ${CMAPDIR}/ac15/cid2code.txt:${PORTSDIR}/print/adobe-cmaps
+
+NO_WRKSUBDIR= yes
+SUB_FILES= pkg-message \
+ Makefile template.cidfont template.ttcidfont template.font
+SUB_LIST= PORTVERSION="${PORTVERSION}" GS_RESDIR="${GS_RESDIR}"
+PLIST_SUB= GS_RESDIR="${GS_RESDIR}"
+PKGMESSAGE= ${WRKDIR}/pkg-message
+DEPENDS_ARGS+= -DA4
+# set these forcibly
+USE_GHOSTSCRIPT_RUN=7
+
+CONFLICTS= ghostscript8-[0-9]* \
+ ghostscript8-nox11-[0-9]* \
+ ghostscript9-[0-9]* \
+ ghostscript9-nox11-[0-9]* \
+ ghostscript9-agpl-[0-9]* \
+ ghostscript9-agpl-nox11-[0-9]*
+
+CMAPDIR?= ${LOCALBASE}/share/fonts/adobe-cmaps
+GS_RESDIR?= share/ghostscript/Resource
+
+post-extract: apply-slist
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>