aboutsummaryrefslogtreecommitdiffstats
path: root/print/ghostscript7-jpnfont/Makefile
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-04-30 04:12:16 +0800
committerhrs <hrs@FreeBSD.org>2013-04-30 04:12:16 +0800
commit175f60e46f0594dff3c3315640679dcbc83775ea (patch)
treeb668622bec03cea02602798988a5ed72533143b2 /print/ghostscript7-jpnfont/Makefile
parent570c1e46e4147388fbc47465b6227d7a1e1dde4e (diff)
downloadfreebsd-ports-gnome-175f60e46f0594dff3c3315640679dcbc83775ea.tar.gz
freebsd-ports-gnome-175f60e46f0594dff3c3315640679dcbc83775ea.tar.zst
freebsd-ports-gnome-175f60e46f0594dff3c3315640679dcbc83775ea.zip
Resurrect print/ghostscript7*. Ghostscript 7.x is incompatible with 8.x
and 9.x in terms of CJK character support and they are still in demand. While I am here, the following changes have been added: - Add LICENSE. - Use OPTIONS_DEFINE for ghostscript drivers. - Add MAKE_JOBS_SAFE=yes. Discussed with: bapt
Diffstat (limited to 'print/ghostscript7-jpnfont/Makefile')
-rw-r--r--print/ghostscript7-jpnfont/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/print/ghostscript7-jpnfont/Makefile b/print/ghostscript7-jpnfont/Makefile
new file mode 100644
index 000000000000..60dc326c9b86
--- /dev/null
+++ b/print/ghostscript7-jpnfont/Makefile
@@ -0,0 +1,26 @@
+# Created by: Mita Yoshio <mita@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ghostscript
+PORTVERSION= 7.07
+PORTREVISION= 9
+CATEGORIES= japanese print
+MASTER_SITES= # empty
+PKGNAMESUFFIX= 7-jpnfont
+DISTFILES= # empty
+
+MAINTAINER= doceng@FreeBSD.org
+COMMENT= Japanese font support for Ghostscript 7.x
+
+RUN_DEPENDS= ${LOCALBASE}/share/fonts/std.ja_JP/Ryumin-Light:${PORTSDIR}/japanese/font-std \
+ ${LOCALBASE}/share/ghostscript/Resource/CIDFont/Ryumin-Light:${PORTSDIR}/print/ghostscript7-commfont
+
+# set these forcibly
+USE_GHOSTSCRIPT_RUN= 7
+NO_BUILD= yes
+DEPENDS_ARGS+= -DA4
+
+do-install:
+ @${DO_NADA}
+
+.include <bsd.port.mk>