aboutsummaryrefslogtreecommitdiffstats
path: root/print/ghostscript7
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
committerdinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
commit530706893f31269bbfa303e069f2e76cbbe2fce7 (patch)
treea8077a0d6e20d70b39e6a7fe3e57a6dafe7c7f33 /print/ghostscript7
parent9d262811a145d3e715edefd1d5d64ceac41de547 (diff)
downloadfreebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.gz
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.zst
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.zip
- update png to 1.5.10
Diffstat (limited to 'print/ghostscript7')
-rw-r--r--print/ghostscript7/Makefile7
-rw-r--r--print/ghostscript7/files/patch-src-gdevpng.c11
-rw-r--r--print/ghostscript7/files/patch-src-png_.h9
3 files changed, 24 insertions, 3 deletions
diff --git a/print/ghostscript7/Makefile b/print/ghostscript7/Makefile
index 4bb40979b45f..c4579ab79739 100644
--- a/print/ghostscript7/Makefile
+++ b/print/ghostscript7/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ghostscript7
PORTVERSION= 7.07
-PORTREVISION= 24
+PORTREVISION= 25
CATEGORIES= print
MASTER_SITES= SF/ghostscript/gnu-gs/${PORTVERSION}:gs_srcs \
${MASTER_SITE_PORTS_JP:S/$/:ports_jp,ports_jp_gs/} \
@@ -23,7 +23,7 @@ MAINTAINER= doceng@FreeBSD.org
COMMENT= Ghostscript 7.x PostScript interpreter
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
RUN_DEPENDS= ${LOCALBASE}/share/ghostscript/fonts/a010013l.pfb:${PORTSDIR}/print/gsfonts
# normazile WRKSRC so things like cups-pstoraster may work
@@ -43,7 +43,8 @@ MAKE_ENV= CFLAGS_STANDARD="${CFLAGS}" \
MAKE_JOBS_UNSAFE= yes
CONFIGURE_ENV= ${MAKE_ENV}
-CPPFLAGS+= -DUPD_SIGNAL=0 -I. -I${WRKSRC}/gimp-print -I${LOCALBASE}/include/libpng -I${LOCALBASE}/include
+CPPFLAGS+= -DUPD_SIGNAL=0 -I. -I${WRKSRC}/gimp-print -I${LOCALBASE}/include/libpng \
+ -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
LDFLAGS+= ${XLDFLAGS}
CONFIGURE_ARGS= --disable-compile-inits \
--with-ijs
diff --git a/print/ghostscript7/files/patch-src-gdevpng.c b/print/ghostscript7/files/patch-src-gdevpng.c
new file mode 100644
index 000000000000..697f6c71ff7d
--- /dev/null
+++ b/print/ghostscript7/files/patch-src-gdevpng.c
@@ -0,0 +1,11 @@
+--- src/gdevpng.c.orig 2003-05-15 12:05:29.000000000 +0200
++++ src/gdevpng.c 2012-04-27 20:17:30.000000000 +0200
+@@ -258,7 +258,7 @@
+ goto done;
+ }
+ /* set error handling */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* If we get here, we had a problem reading the file */
+ code = gs_note_error(gs_error_VMerror);
+ goto done;
diff --git a/print/ghostscript7/files/patch-src-png_.h b/print/ghostscript7/files/patch-src-png_.h
new file mode 100644
index 000000000000..3ab10a5af90a
--- /dev/null
+++ b/print/ghostscript7/files/patch-src-png_.h
@@ -0,0 +1,9 @@
+--- src/png_.h.orig 2003-01-17 01:49:05.000000000 +0100
++++ src/png_.h 2012-04-27 19:22:59.000000000 +0200
+@@ -27,5 +27,6 @@
+ #else
+ #include "png.h"
+ #endif
++#include "pngpriv.h"
+
+ #endif /* png__INCLUDED */