aboutsummaryrefslogtreecommitdiffstats
path: root/print/ghostscript8/Makefile
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>2000-03-25 20:27:38 +0800
committerandreas <andreas@FreeBSD.org>2000-03-25 20:27:38 +0800
commit21ef1fe1c1dc3d9343e6434d37ad0c283d792ebb (patch)
treee1afc055e18a3da0dd0f63f2ee43dab08e61cab8 /print/ghostscript8/Makefile
parentac501d2bfe9aae0d26866b8486473e1676d5d9b3 (diff)
downloadfreebsd-ports-gnome-21ef1fe1c1dc3d9343e6434d37ad0c283d792ebb.tar.gz
freebsd-ports-gnome-21ef1fe1c1dc3d9343e6434d37ad0c283d792ebb.tar.zst
freebsd-ports-gnome-21ef1fe1c1dc3d9343e6434d37ad0c283d792ebb.zip
new ghostscript 6.01 port after repository copy
additional changes by me: - configure + configure.batch updates: reviewed all informations in makefiles and driver docu to make list of available drivers and supported printers complete - added DeskJet 880C/882C/895C Driver from Matthew J. Gelhau Driver is still in developement. There is a newer 1.4 beta version available, but this version is recommended by the author. http://www.proaxis.com/~mgelhaus/linux/software/hp880c/hp880c.html Supported are the following models: HP DeskJet 812C 815C 832C 880C 882C 895C 932C 970C - added contributed uniprint driver profiles: - configure + configure.batch updates: reviewed all informations in makefiles and driver docu to make list of available drivers and supported printers complete - added DeskJet 880C/882C/895C Driver from Matthew J. Gelhau Driver is still in developement. There is a newer 1.4 beta version available, but this version is recommended by the author. http://www.proaxis.com/~mgelhaus/linux/software/hp880c/hp880c.html Supported are the following models: HP DeskJet 812C 815C 832C 880C 882C 895C 932C 970C - added contributed uniprint driver profiles: printer: Epson Stylus Color 740 mode1: stc740ih.upp: Epson Stylus Color 740, 1440x720DpI, Inkjet Paper mode2: stc740p.upp : Epson Stylus Color 740, 720x720DpI, Plain Paper mode3: stc740pl.upp: Epson Stylus Color 740, 360x360DpI, Plain Paper contributor: Francois D. Menard <fmenard@g6-114b.residence.usherb.ca> # printer: Epson LQ-1170 mode1: lqx70ch.upp : Epson LQ-1170 ESC/P2 Dot Matrix, 360x360DpI, Plain Pap. mode2: lqx70cl.upp : Epson LQ-1170 ESC/P2 Dot Matrix, 180x180DpI, Plain Pap. mode3: lqx70cm.upp : Epson LQ-1170 ESC/P2 Dot Matrix, 360x180DpI, Plain Pap. contributor: Harold Bower <HalBower@worldnet.att.net> - updated PLIST - use GS_VERSION for DISTNAME - fix installation path for pdf_sec.ps if defined PDFENCRYPT - silence make install ("@") - change COMMENT to reflect version - update DESCR, to document driver enhancements compared to stanfard gs release - apsfilter will be updated later Submitted by: "Alec Wolman" <wolman@cs.washington.edu>
Diffstat (limited to 'print/ghostscript8/Makefile')
-rw-r--r--print/ghostscript8/Makefile99
1 files changed, 54 insertions, 45 deletions
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index 67a952d41057..ed81a9fb9a37 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -1,46 +1,64 @@
# New ports collection makefile for: ghostscript
-# Version required: 5.50
+# Version required: 6.01
# Date created: Tue Jun 10 21:58:54 CEST 1997
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
# $FreeBSD$
#
-DISTNAME= ghostscript-5.50
+DISTNAME= ghostscript-${GS_VERSION}
CATEGORIES= print
-MASTER_SITES= ftp://ftp.cs.wisc.edu/ghost/aladdin/gs550/ \
- http://www.erdw.ethz.ch/~bonk/ftp/gs-driver-distrib/ \
- http://www.ozemail.com.au/~geoffk/pdfencrypt/
+MASTER_SITES= ftp://ftp.cs.wisc.edu/ghost/aladdin/gs601/ \
+ ftp://ftp.cs.wisc.edu/ghost/aladdin/fonts/ \
+ http://www.ozemail.com.au/~geoffk/pdfencrypt/ \
+ http://www.proaxis.com/~mgelhaus/linux/software/hp880c/1.31/
DISTFILES= ${GS_SOURCES} ${GS_FONTS_STD} ${GS_FONTS_OTHER} \
- ${HP850_DRV} ${DECRYPT_PDF}
+ ${DECRYPT_PDF} ${HP880_DRV}
MAINTAINER= andreas@FreeBSD.org
-Y2K= http://www.cs.wisc.edu/~ghost/aladdin/y2k.html
+Y2K= http://www.cs.wisc.edu/~ghost/aladdin/y2k.html
-BUILD_DEPENDS= /nonexistent:${PORTSDIR}/graphics/jpeg:extract \
- /nonexistent:${PORTSDIR}/graphics/png:extract \
- unzip:${PORTSDIR}/archivers/unzip
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/graphics/jpeg:extract
LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png
+GS_VERSION= 6.01
+PLIST_SUB= GS_VERSION=${GS_VERSION}
USE_XLIB= yes
EXTRACT_ONLY= ${GS_SOURCES}
-WRKSRC= ${WRKDIR}/gs5.50
+WRKSRC= ${WRKDIR}/gs${GS_VERSION}
USE_GMAKE= yes
-MAKEFILE= unix-gcc.mak
-MAN1= gs.1 pdf2dsc.1 pdf2ps.1 ps2ascii.1 ps2epsi.1 ps2pdf.1 ps2ps.1
-
-GS_SOURCES= ghostscript-5.50.tar.gz
-GS_SOURCES+= ghostscript-5.50gnu.tar.gz
+MAKEFILE= src/unix-gcc.mak
+# Note: the order that the manpages are listed here matters because
+# some of them are symbolic links
+MAN1= gs.1 dvipdf.1 font2c.1 eps2eps.1 gsbj.1 gsdj.1 gsdj500.1 \
+ gslj.1 gslp.1 gsnd.1 pdf2dsc.1 pdf2ps.1 pf2afm.1 \
+ pfbtopfa.1 printafm.1 ps2ascii.1 ps2epsi.1 ps2pdf12.1 \
+ ps2pdf13.1 ps2pdf.1 ps2pdfwr.1 ps2ps.1 wftopfa.1
+
+GS_SOURCES= ghostscript-${GS_VERSION}.tar.gz
# Note: the following two are real files that have symlinks with
# later version numbers pointing to them. To avoid unnecessarily
# downloading distfiles, do not change these when upgrading the port
# unless the files really change.
-GS_FONTS_STD= ghostscript-fonts-std-5.50.tar.gz
-GS_FONTS_OTHER= ghostscript-fonts-other-5.50.tar.gz
+GS_FONTS_STD= ghostscript-fonts-std-6.0.tar.gz
+GS_FONTS_OTHER= ghostscript-fonts-other-6.0.tar.gz
+
+# Additional Drivers:
+
+# http://www.proaxis.com/~mgelhaus/linux/software/hp880c/hp880c.html
+HP880_DRV= gdevcd8.tar.gz
-# Additional driver HP 850, see http://www.erdw.ethz.ch/~bonk/hp850/hp850.html
-HP850_DRV= hp8xxs13.zip
+# contributed uniprint profiles
+CONTRIB_UPP= lqx70ch.upp lqx70cl.upp lqx70cm.upp \
+ stc740ih.upp stc740p.upp stc740pl.upp
+
+# encrypted PDF support. can't be packaged due to export control issues.
+.if defined(PDFENCRYPT)
+MASTER_SITES+= http://www.ozemail.com.au/~geoffk/pdfencrypt/
+DISTFILES+= pdf_sec.ps
+RESTRICTED= "Crypto; export controlled, RC4 in PostScript code included"
+.endif
.if defined(A4)
CFLAGS+= -DA4
@@ -54,11 +72,8 @@ pre-fetch:
.endif
post-extract:
- ${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/jpeg/work/jpeg-6b ${WRKSRC}/jpeg
- ${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/png/work/libpng-* ${WRKSRC}/libpng
- ${MV} ${WRKSRC}/devs.mak ${WRKSRC}/devs.mak.bak
- cd ${WRKSRC} && unzip -Lao ${DISTDIR}/${HP850_DRV}
- ${MV} ${WRKSRC}/devs.mak.bak ${WRKSRC}/devs.mak
+ @${LN} -s ${PORTSDIR}/graphics/jpeg/work/jpeg-6b ${WRKSRC}/jpeg
+ @cd ${WRKSRC}; ${TAR} -xzf ${DISTDIR}/${HP850_DRV}
do-configure:
.if defined(BATCH)
@@ -68,33 +83,27 @@ do-configure:
.endif
pre-build:
- ${MKDIR} ${WRKSRC}/obj
+ @${MKDIR} ${WRKSRC}/obj
+ @${MKDIR} ${WRKSRC}/bin
pre-install:
- @${MKDIR} ${PREFIX}/share/ghostscript ${PREFIX}/bin ${PREFIX}/man/man1
- (cd ${PREFIX}/share/ghostscript ; \
+ @${MKDIR} ${PREFIX}/share/ghostscript
+ @(cd ${PREFIX}/share/ghostscript ; \
${TAR} -xzf ${DISTDIR}/${GS_FONTS_STD})
- (cd ${PREFIX}/share/ghostscript/fonts ; \
+ @(cd ${PREFIX}/share/ghostscript ; \
${TAR} -xzf ${DISTDIR}/${GS_FONTS_OTHER})
-# install the readme and license file of the hp8xxx driver as well
post-install:
- strip ${PREFIX}/bin/gs
- ${INSTALL_SCRIPT} ${WRKSRC}/unix-lpr.sh ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/lprsetup.sh ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/license.hp8 \
- ${PREFIX}/share/ghostscript/5.50/doc
- ${INSTALL_DATA} ${WRKSRC}/readme.hp8 \
- ${PREFIX}/share/ghostscript/5.50/doc
-.if defined(PDFENCRYPT)
- ${INSTALL_DATA} ${DISTDIR}/pdf_sec.ps ${PREFIX}/share/ghostscript/5.50
-.endif
-
-# encrypted PDF support. can't be packaged due to export control issues.
+ @strip ${PREFIX}/bin/gs
+ @${INSTALL_SCRIPT} ${WRKSRC}/lib/unix-lpr.sh ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/lib/lprsetup.sh ${PREFIX}/bin
+.for i in ${CONTRIB_UPP}
+ @${INSTALL_DATA} ${FILESDIR}/$i \
+ ${PREFIX}/share/ghostscript/${GS_VERSION}/lib
+.endfor
.if defined(PDFENCRYPT)
-MASTER_SITES+= http://www.ozemail.com.au/~geoffk/pdfencrypt/
-DISTFILES+= pdf_sec.ps
-RESTRICTED= "Crypto; export controlled, RC4 in PostScript code included"
+ @${INSTALL_DATA} ${DISTDIR}/pdf_sec.ps \
+ ${PREFIX}/share/ghostscript/${GS_VERSION}/lib
.endif
.include <bsd.port.mk>