aboutsummaryrefslogtreecommitdiffstats
path: root/print/ghostscript8/Makefile
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>2001-04-01 23:55:32 +0800
committerandreas <andreas@FreeBSD.org>2001-04-01 23:55:32 +0800
commit3786bd80f6d8718fcb4e85022715928419537b86 (patch)
treeede4cf8aad4419db998597ecc87f310c4b0cf4b1 /print/ghostscript8/Makefile
parenta42bf19fd9b4aa5d92cf6f0492ec07e16d476df4 (diff)
downloadfreebsd-ports-gnome-3786bd80f6d8718fcb4e85022715928419537b86.tar.gz
freebsd-ports-gnome-3786bd80f6d8718fcb4e85022715928419537b86.tar.zst
freebsd-ports-gnome-3786bd80f6d8718fcb4e85022715928419537b86.zip
- "Gelhaus driver" (cdj850) wasn't active in gs, fix that
- therefore bump port revision - add a makefile template, so that it will be compiled in - patch configure.batch and the interactive one interactive configuration is still not enabled, because every driver entry needs to be checked thoroughly if its still present, if more printer models are supported, if there are new printers/drivers, etc ... This needs time that I currently don't have. Any taker ???
Diffstat (limited to 'print/ghostscript8/Makefile')
-rw-r--r--print/ghostscript8/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index 121796cee33e..5fd292a39687 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ghostscript
PORTVERSION= 6.50
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= print
MASTER_SITES= ftp://ftp.fh-koblenz.de/pub/Ghostscript/aladdin/gs650/ \
ftp://ftp.fh-koblenz.de/pub/Ghostscript/aladdin/fonts/ \
@@ -73,17 +73,19 @@ GS_FONTS_OTHER= ghostscript-fonts-other-6.0.tar.gz
# Ghostscript Driver for HP DeskJet 812C/815C/832C/880C/882C/895C
# http://www.gelhaus.net/hp880c/
# driver names: cdj880
+HP8XX= cdj850
HP8XX_DRV= gdevcd8.tar.gz
# HPDJ, additional driver for HP PCL3 Printers, by Martin Lottermoser
# ftp://ftp.sbs.de/pub/graphics/ghostscript/pcl3/pcl3.html
+# still present, just for the case pcl3 is missing some hpdj feature
HPDJ= hpdj
HPDJ_VERS= 2.6
HPDJ_NAME= ${HPDJ}-${HPDJ_VERS}
HPDJ_SRC= ${HPDJ_NAME}.tar.gz
HPDJ_MAN1= gs-hpdj.1
-# PCL3 (hpdj successor in BETA state)
+# PCL3 (hpdj successor now in RELEASE quality)
# additional driver for HP PCL3 Printers, by Martin Lottermoser
# http://home.t-online.de/home/Martin.Lottermoser/pcl3.html
PCL3= pcl3
@@ -166,6 +168,10 @@ post-patch:
# advantage: you see unmodified makefiles after a pure make extract
pre-configure:
@${ECHO} ">>> in pre-configure ..."
+# for HP8XX driver
+ @${ECHO} ">>> adding ${HP8XX} driver to contrib.mak ..."
+ @${CAT} ${FILESDIR}/cdj850.contrib.mak \
+ >> ${WRKSRC}/src/contrib.mak
# for HPDJ driver
@${ECHO} ">>> adding ${HPDJ} driver to contrib.mak ..."
@${CAT} ${WRKSRC}/src/contrib.mak-5.94.add \