aboutsummaryrefslogtreecommitdiffstats
path: root/print/ghostscript8/Makefile
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>2000-11-26 22:13:02 +0800
committerandreas <andreas@FreeBSD.org>2000-11-26 22:13:02 +0800
commit7dc236a4839c7d0566bbecf567464dfb6dfa71ec (patch)
tree4c0631145e014bebbda2b531f1d31b31e2c25062 /print/ghostscript8/Makefile
parent8bfe1f7572f10203da442b0b8610759d90ccb84b (diff)
downloadfreebsd-ports-gnome-7dc236a4839c7d0566bbecf567464dfb6dfa71ec.tar.gz
freebsd-ports-gnome-7dc236a4839c7d0566bbecf567464dfb6dfa71ec.tar.zst
freebsd-ports-gnome-7dc236a4839c7d0566bbecf567464dfb6dfa71ec.zip
- Add 3rd party gs driver for HP DeskJet 970
- http://www.harsch.net/Ghostscript/ghostscript.html - driver is based on Uli Wortmann's HO DJ850 driver - supports duplex printing Note from the author: in duplex mode black is not so intensive as in normal mode. Maybe HP wants to prevent, that you don't see the black of the other side of the page too much. If somebody knows HP's algorithm, how to reduce the black, then author would try to compensate it with some code...
Diffstat (limited to 'print/ghostscript8/Makefile')
-rw-r--r--print/ghostscript8/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index f22bf77920f8..d2368edf4de2 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -12,9 +12,10 @@ MASTER_SITES= ftp://ftp.cs.wisc.edu/ghost/aladdin/gs601/ \
ftp://ftp.cs.wisc.edu/ghost/aladdin/fonts/ \
http://www.ozemail.com.au/~geoffk/pdfencrypt/ \
http://www.proaxis.com/~mgelhaus/linux/software/hp880c/1.31/ \
- ftp://ftp.sbs.de/pub/graphics/ghostscript/pcl3/
+ ftp://ftp.sbs.de/pub/graphics/ghostscript/pcl3/ \
+ http://www.harsch.net/Download/
DISTFILES= ${GS_SOURCES} ${GS_FONTS_STD} ${GS_FONTS_OTHER} \
- ${DECRYPT_PDF} ${HP8XX_DRV} ${HPDJ_DRV}
+ ${DECRYPT_PDF} ${HP8XX_DRV} ${HPDJ_DRV} ${HP970_DRV}
EXTRACT_ONLY= ${GS_SOURCES} ${HPDJ_DRV}
MAINTAINER= andreas@FreeBSD.org
@@ -54,6 +55,9 @@ HP8XX_DRV= gdevcd8.tar.gz
# ftp://ftp.sbs.de/pub/graphics/ghostscript/pcl3/pcl3.html
HPDJ_DRV= hpdj-2.6.tar.gz
+# additional driver for HP DeskJet 970, supports duplex printing
+HP970_DRV= gdevdj9.c.gz
+
# contributed uniprint profiles
CONTRIB_UPP= lqx70ch.upp lqx70cl.upp lqx70cm.upp \
stc740ih.upp stc740p.upp stc740pl.upp
@@ -82,6 +86,9 @@ post-extract:
@${CAT} ${WRKSRC}/src/contrib.mak-5.94.add >> ${WRKSRC}/src/contrib.mak
@${PATCH} -d ${WRKSRC}/src --forward --quiet -E \
< ${WRKSRC}/src/zmedia2.c-5.50.diff
+ @${CP} ${DISTDIR}/${HP970_DRV} ${WRKSRC}/src
+ @${GUNZIP_CMD} ${WRKSRC}/src/${HP970_DRV}
+ @${CAT} ${FILESDIR}/dj970.contrib.mak >> ${WRKSRC}/src/contrib.mak
do-configure:
.if defined(BATCH)