aboutsummaryrefslogtreecommitdiffstats
path: root/print/ghostscript8/files
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2010-04-03 15:02:54 +0800
committerhrs <hrs@FreeBSD.org>2010-04-03 15:02:54 +0800
commitec8eb3361a8301eeea9eee7049db9045fb6cd648 (patch)
treef9a400ea9c6a48031ca8014cd7cef18ef46cfdab /print/ghostscript8/files
parentc66533a79591854d562c9fc7016826abd041c632 (diff)
downloadfreebsd-ports-gnome-ec8eb3361a8301eeea9eee7049db9045fb6cd648.tar.gz
freebsd-ports-gnome-ec8eb3361a8301eeea9eee7049db9045fb6cd648.tar.zst
freebsd-ports-gnome-ec8eb3361a8301eeea9eee7049db9045fb6cd648.zip
* Update to 8.71.[1] Changes include:
- Support for tiff file output is now provided using the libtiff implementation rather than our more limited native code as in previous releases. There is also a new 'tiffsep1' output device which produces halftoned separations at 1 bit-per-pixel, in contrast to the 'tiffsep' device which produces 8 bit-per-pixel plates. - The graphics library has been updated to provide more accurate scan conversion of vector art including fixes to dash behavior, transparent stroked paths, thick stroked paths, radial shadings, xps cap handling, "pie" joins, degenerate beziers, improved handling of dropouts in thin strokes and better thin axis-aligned strokes. * Fix cairo support. GS_cairo is added to the drivers list (this is disabled by default). When WITH_CAIRO is defined, GS_cairo will be set by default.[2] PR: ports/144111[1] PR: ports/137634[2] PR: ports/145248[2]
Diffstat (limited to 'print/ghostscript8/files')
-rw-r--r--print/ghostscript8/files/patch-base-Makefile.in25
-rw-r--r--print/ghostscript8/files/patch-base-unix-dll.mak17
2 files changed, 33 insertions, 9 deletions
diff --git a/print/ghostscript8/files/patch-base-Makefile.in b/print/ghostscript8/files/patch-base-Makefile.in
index 9fa3da2332f3..aa8d8876e596 100644
--- a/print/ghostscript8/files/patch-base-Makefile.in
+++ b/print/ghostscript8/files/patch-base-Makefile.in
@@ -1,6 +1,6 @@
---- base/Makefile.in.orig 2008-06-22 15:43:28.000000000 +0900
-+++ base/Makefile.in 2008-11-03 00:09:12.000000000 +0900
-@@ -46,9 +46,8 @@
+--- base/Makefile.in.orig 2009-12-18 16:04:10.000000000 +0900
++++ base/Makefile.in 2010-03-02 06:21:50.000000000 +0900
+@@ -47,9 +47,8 @@
# the directories also define the default search path for the
# initialization files (gs_*.ps) and the fonts.
@@ -12,7 +12,7 @@
INSTALL_SHARED = @INSTALL_SHARED@
prefix = @prefix@
-@@ -164,7 +163,7 @@
+@@ -156,7 +155,7 @@
# some older JPEG streams that violate the standard. If the JPEG
# library built from local sources, the patch will be applied.
@@ -21,7 +21,7 @@
JPEG_NAME=jpeg
# Define the directory where the PNG library sources are stored,
-@@ -172,14 +171,14 @@
+@@ -164,12 +163,12 @@
# You may need to change this if the libpng version changes.
# See libpng.mak for more information.
@@ -30,6 +30,13 @@
PNGSRCDIR=@LIBPNGDIR@
LIBPNG_NAME=png
+ # libtiff
+-SHARE_LIBTIFF=@SHARE_LIBTIFF@
++SHARE_LIBTIFF=1
+ TIFFSRCDIR=@LIBTIFFDIR@
+ TIFFPLATFORM=unix
+ TIFFCONFIG_SUFFIX=
+@@ -178,7 +177,7 @@
# Define the directory where the zlib sources are stored.
# See zlib.mak for more information.
@@ -38,7 +45,7 @@
ZSRCDIR=@ZLIBDIR@
#ZLIB_NAME=gz
ZLIB_NAME=z
-@@ -250,7 +249,7 @@
+@@ -254,7 +253,7 @@
# Define the added flags for standard, debugging, profiling
# and shared object builds.
@@ -47,7 +54,7 @@
CFLAGS_DEBUG=-g -O0
CFLAGS_PROFILE=-pg @OPT_CFLAGS@
CFLAGS_SO=@DYNAMIC_CFLAGS@
-@@ -295,7 +294,7 @@
+@@ -299,7 +298,7 @@
# Solaris may need -lnsl -lsocket -lposix4.
# (Libraries required by individual drivers are handled automatically.)
@@ -56,7 +63,7 @@
# Define the standard libraries to search at the end of linking.
# Most platforms require -lpthread for the POSIX threads library;
-@@ -339,7 +338,7 @@
+@@ -343,7 +342,7 @@
# the pthread library. Otherwise use SYNC=nosync
#SYNC=posync
#SYNC=nosync
@@ -65,7 +72,7 @@
# programs we use
RM=rm -f
-@@ -498,6 +497,7 @@
+@@ -490,6 +489,7 @@
# ---------------- End of platform-specific section ---------------- #
INSTALL_CONTRIB=@INSTALL_CONTRIB@
diff --git a/print/ghostscript8/files/patch-base-unix-dll.mak b/print/ghostscript8/files/patch-base-unix-dll.mak
new file mode 100644
index 000000000000..96876e3bfb15
--- /dev/null
+++ b/print/ghostscript8/files/patch-base-unix-dll.mak
@@ -0,0 +1,17 @@
+--- base/unix-dll.mak.orig 2009-10-20 05:24:53.000000000 +0900
++++ base/unix-dll.mak 2010-04-03 12:22:35.000000000 +0900
+@@ -79,12 +79,11 @@
+ # Build the small Ghostscript loaders, with Gtk+ and without
+
+ $(GSSOC_XE): $(GS_SO) $(PSSRC)$(SOC_LOADER)
+- $(GLCC) -g -o $(GSSOC_XE) $(PSSRC)dxmainc.c \
+- $(LDFLAGS) -L$(BINDIR) -l$(GS)
++ $(GLCC) -g -o $(GSSOC_XE) $(PSSRC)dxmainc.c -L$(BINDIR) -l$(GS)
+
+ $(GSSOX_XE): $(GS_SO) $(PSSRC)$(SOC_LOADER)
+ $(GLCC) -g $(SOC_CFLAGS) -o $(GSSOX_XE) $(PSSRC)$(SOC_LOADER) \
+- $(LDFLAGS) -L$(BINDIR) -l$(GS) $(SOC_LIBS)
++ -L$(BINDIR) -l$(GS) $(SOC_LIBS)
+
+ # ------------------------- Recursive make targets ------------------------- #
+