aboutsummaryrefslogtreecommitdiffstats
path: root/print/ghostscript8
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-05-03 05:14:26 +0800
committerhrs <hrs@FreeBSD.org>2013-05-03 05:14:26 +0800
commit5bb0d78297ba421785d9bb55c4380eaebe523a42 (patch)
treece130a4952071c0fb910cc998c76ea53a04bef17 /print/ghostscript8
parentdf8a23f05451495499c1019fff954b899542d873 (diff)
downloadfreebsd-ports-gnome-5bb0d78297ba421785d9bb55c4380eaebe523a42.tar.gz
freebsd-ports-gnome-5bb0d78297ba421785d9bb55c4380eaebe523a42.tar.zst
freebsd-ports-gnome-5bb0d78297ba421785d9bb55c4380eaebe523a42.zip
- Use OPTIONS_MULTI and OPTIONS_GROUP.
- Add dependency on libpaper unconditionally to 8.x and 9.x. - Fix CONFLICTS_INSTALL. - Remove ABI version numbers from LIB_DEPENDS.
Diffstat (limited to 'print/ghostscript8')
-rw-r--r--print/ghostscript8/Makefile52
-rw-r--r--print/ghostscript8/Makefile.drivers9
-rw-r--r--print/ghostscript8/files/Makefile.drivers_post2
3 files changed, 26 insertions, 37 deletions
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index 6430b370802b..15cac3f51258 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ghostscript
PORTVERSION= 8.71
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= print
MASTER_SITES= http://downloads.ghostscript.com/public/:gs_srcs \
SF/ghostscript/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
@@ -26,11 +26,16 @@ LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
jbig2dec:${PORTSDIR}/graphics/jbig2dec \
jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
+ paper:${PORTSDIR}/print/libpaper \
tiff:${PORTSDIR}/graphics/tiff
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/fonts/a010013l.pfb:${PORTSDIR}/print/gsfonts
-CONFLICTS_INSTALL= gambc-[0-9]* ghostscript[79]-[0-9]* \
- ghostscript[79]-*-[0-9]*
+CONFLICTS_INSTALL= \
+ gambc-[0-9]* \
+ ghostscript[79]-[0-9]* \
+ ghostscript[79]-nox11-[0-9]* \
+ ghostscript9-agpl-[0-9]* \
+ ghostscript9-agpl-nox11-[0-9]*
USE_XZ= yes
USE_GMAKE= yes
@@ -45,18 +50,20 @@ MAKE_ENV= CFLAGS_STANDARD="${CFLAGS}" \
EXTRALIBS="${EXTRALIBS}" \
SOC_LOADER="dxmainc.c"
CONFIGURE_ENV= ${MAKE_ENV}
-LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-compile-inits \
--enable-contrib \
--enable-dynamic \
--with-ijs \
--with-jasper \
+ --with-libpaper \
--with-drivers=""
CPPFLAGS+= -DUPD_SIGNAL=0 -I. \
-I${WRKSRC}/jasper/src/libjasper/include \
-I${LOCALBASE}/include/libpng15 \
-I${LOCALBASE}/include
-XCFLAGS= ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib
+XCFLAGS= ${PTHREAD_CFLAGS} \
+ -DA4
XLDFLAGS= ${PTHREAD_LIBS}
PLIST_SUB= GS_VERSION="${PORTVERSION}" \
@@ -65,9 +72,8 @@ SUB_FILES= pkg-message
SUB_LIST= DATADIR=${DATADIR} PORTVERSION=${PORTVERSION}
PKGMESSAGE= ${WRKDIR}/pkg-message
-OPTIONS_DEFINE= A4SIZE CAIRO CUPS FONTCONFIG FT_BRIDGE LIBPAPER GTK2 X11
-OPTIONS_DEFAULT= CAIRO CUPS FONTCONFIG LIBPAPER X11
-A4SIZE_DESC= Set A4 (not Letter) as the default paper size
+OPTIONS_DEFINE= X11 DOCS CAIRO CUPS FONTCONFIG FT_BRIDGE GTK2 ICONV
+OPTIONS_DEFAULT=X11 DOCS CAIRO CUPS FONTCONFIG ICONV
FONTCONFIG_DESC=Enable fontconfig support
FT_BRIDGE_DESC= Enable FreeType Bridge support
NO_OPTIONS_SORT=yes
@@ -98,32 +104,15 @@ PLIST_SUB+= GS_${D}="@comment "
.endif
.endfor
-.if ${PORT_OPTIONS:MA4SIZE}
-DEFAULTPAPERSIZE?= a4
-XCFLAGS+= -DA4
-MSG_PAPERSIZE= "NOTE: Default paper size will be A4."
-.endif
-DEFAULTPAPERSIZE?= letter
-
-.if ${PORT_OPTIONS:MLIBPAPER}
-LIB_DEPENDS+= paper:${PORTSDIR}/print/libpaper
-CONFIGURE_ARGS+= --with-libpaper
-.if ${DEFAULTPAPERSIZE:L} == a4
-RUN_DEPENDS+= ${LOCALBASE}/etc/papersize:${PORTSDIR}/print/papersize-default-a4
-.endif
-.else
-CONFIGURE_ARGS+= --without-libpaper
-.endif
-
.if ${PORT_OPTIONS:MFONTCONFIG}
-LIB_DEPENDS+= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS+= fontconfig:${PORTSDIR}/x11-fonts/fontconfig
CONFIGURE_ARGS+= --enable-fontconfig
.else
CONFIGURE_ARGS+= --disable-fontconfig
.endif
.if ${PORT_OPTIONS:MFT_BRIDGE}
-LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS+= freetype:${PORTSDIR}/print/freetype2
MAKE_ENV+= FT_BRIDGE=1 FT_ROOT="${WRKSRC}/freetype" FT_LIB_EXT=".so"
CPPFLAGS+= -I${LOCALBASE}/include/freetype2
PLIST_SUB+= FAPI=""
@@ -151,9 +140,6 @@ PORTDOC_FILES= japanese/Gdevlips.htm japanese/README.gs550j \
lxm3200-tweaked/RELEASE_NOTES \
lxm3200-tweaked/Z12-Z31-QuickSetup md2k_md5k/README.jis
-pre-everything::
- @${ECHO_MSG} ${MSG_PAPERSIZE}
-
post-patch:
${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g ; \
s|%%GS_VERSION%%|${PORTVERSION}|g' \
@@ -179,7 +165,7 @@ pre-build-drivers.mak:
pre-build: pre-build-drivers.mak
${MKDIR} ${WRKSRC}/obj
${MKDIR} ${WRKSRC}/bin
-.if defined(WITH_FT_BRIDGE)
+.if ${PORT_OPTIONS:MFT_BRIDGE}
${MKDIR} ${WRKSRC}/freetype/include
${LN} -s -f ${LOCALBASE}/include/ft2build.h \
${WRKSRC}/freetype/include/ft2build.h
@@ -201,7 +187,7 @@ post-install-docs:
${TAR} -cf - ${PORTDOC_FILES} | \
( cd ${DOCSDIR} && ${TAR} -xof - )
-.if defined(WITH_FT_BRIDGE)
+.if ${PORT_OPTIONS:MFT_BRIDGE}
post-install-fapi:
${INSTALL_DATA} ${WRKSRC}/lib/FAPIcidfmap \
${WRKSRC}/lib/FAPIconfig ${WRKSRC}/lib/FAPIfontmap \
@@ -219,7 +205,7 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install: post-install-docs
.endif
diff --git a/print/ghostscript8/Makefile.drivers b/print/ghostscript8/Makefile.drivers
index 175e4975a4ab..9b2b26b36554 100644
--- a/print/ghostscript8/Makefile.drivers
+++ b/print/ghostscript8/Makefile.drivers
@@ -12,14 +12,20 @@ OPTIONS_X11= \
GS_x11mono \
GS_x11rg16x \
GS_x11rg32x
+OPTIONS_MULTI= X11
+OPTIONS_MULTI_X11= ${OPTIONS_X11}
OPTIONS_SVGALIB= \
GS_lvga256 \
GS_vgalib
+OPTIONS_GROUP= SVGALIB
+OPTIONS_GROUP_SVGALIB= ${OPTIONS_SVGALIB}
OPTIONS_ICONV= \
GS_oprp \
GS_opvp
+OPTIONS_GROUP+= ICONV
+OPTIONS_GROUP_ICONV= ${OPTIONS_ICONV}
OPTIONS_CAIRO= \
GS_cairo
@@ -28,9 +34,6 @@ OPTIONS_CUPS= \
GS_cups
OPTIONS_DEFINE+= \
- ${OPTIONS_X11} \
- ${OPTIONS_SVGALIB} \
- ${OPTIONS_ICONV} \
${OPTIONS_CAIRO} \
${OPTIONS_CUPS} \
GS_display \
diff --git a/print/ghostscript8/files/Makefile.drivers_post b/print/ghostscript8/files/Makefile.drivers_post
index 0f3a0271232d..463cfa997f17 100644
--- a/print/ghostscript8/files/Makefile.drivers_post
+++ b/print/ghostscript8/files/Makefile.drivers_post
@@ -125,7 +125,7 @@ PORT_OPTIONS:= ${PORT_OPTIONS:NGS_${D}}
.endfor
.if defined(_CAIRO_DEVS)
-LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
+LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo
CONFIGURE_ARGS+= --enable-cairo
.else
CONFIGURE_ARGS+= --disable-cairo