aboutsummaryrefslogtreecommitdiffstats
path: root/print/ghostscript8
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2010-05-26 05:30:43 +0800
committerhrs <hrs@FreeBSD.org>2010-05-26 05:30:43 +0800
commit0cb66d5784fcaf005378ded3297f4afc7cb51888 (patch)
tree0ff02888d1d941c94ff2c1b93a24d17044fddc7b /print/ghostscript8
parent0cc3ccac1ec0eebfe1987f8021ff26d4e04c3c58 (diff)
downloadfreebsd-ports-gnome-0cb66d5784fcaf005378ded3297f4afc7cb51888.tar.gz
freebsd-ports-gnome-0cb66d5784fcaf005378ded3297f4afc7cb51888.tar.zst
freebsd-ports-gnome-0cb66d5784fcaf005378ded3297f4afc7cb51888.zip
Disable the cups driver when either WITHOUT_CUPS=true or
WITHOUT_GS_cups=true. Spotted by: Scott Allendorf
Diffstat (limited to 'print/ghostscript8')
-rw-r--r--print/ghostscript8/Makefile7
-rw-r--r--print/ghostscript8/files/Makefile.drivers_post19
2 files changed, 19 insertions, 7 deletions
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index a17b1de68b62..58424a2538fd 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -106,13 +106,6 @@ CONFIGURE_ARGS+= --enable-fontconfig
CONFIGURE_ARGS+= --disable-fontconfig
.endif
-.if !defined(WITHOUT_CUPS)
-LIB_DEPENDS+= cupsimage.2:${PORTSDIR}/print/cups-image
-CONFIGURE_ARGS+= --enable-cups
-.else
-CONFIGURE_ARGS+= --disable-cups
-.endif
-
.if !defined(WITHOUT_FT_BRIDGE)
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
MAKE_ENV+= FT_BRIDGE=1 FT_ROOT="${WRKSRC}/freetype" FT_LIB_EXT=".so"
diff --git a/print/ghostscript8/files/Makefile.drivers_post b/print/ghostscript8/files/Makefile.drivers_post
index b6f45172e122..20634c5c43d5 100644
--- a/print/ghostscript8/files/Makefile.drivers_post
+++ b/print/ghostscript8/files/Makefile.drivers_post
@@ -54,6 +54,25 @@ post-extract: post-extract-epag
.include "${FILESDIR}/Makefile.pcl3"
.endif
+# cups specific
+CUPS_DEVS= cups
+.undef _CUPS_DEVS
+
+.for D in ${CUPS_DEVS}
+.if defined(WITHOUT_CUPS)
+.undef WITH_GS_${D}
+.elif defined(WITH_GS_${D})
+_CUPS_DEVS+= ${D}
+.endif
+.endfor
+
+.if defined(_CUPS_DEVS)
+LIB_DEPENDS+= cupsimage.2:${PORTSDIR}/print/cups-image
+CONFIGURE_ARGS+= --enable-cups
+.else
+CONFIGURE_ARGS+= --disable-cups
+.endif
+
# vgalib specific
VGA_DEVS= lvga256 vgalib
.undef _VGA_DEVS