aboutsummaryrefslogtreecommitdiffstats
path: root/print/gnome-cups-manager/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-07-16 12:44:15 +0800
committermarcus <marcus@FreeBSD.org>2003-07-16 12:44:15 +0800
commit42643b4a60d3f385bff25c3128d516e4d6f5debe (patch)
tree8c88a2c700315e832af02905d0cf614b8f8fc030 /print/gnome-cups-manager/Makefile
parent9975ebaace77ba143e292b3904e4a8aaf08618da (diff)
downloadfreebsd-ports-gnome-42643b4a60d3f385bff25c3128d516e4d6f5debe.tar.gz
freebsd-ports-gnome-42643b4a60d3f385bff25c3128d516e4d6f5debe.tar.zst
freebsd-ports-gnome-42643b4a60d3f385bff25c3128d516e4d6f5debe.zip
Add gnome-cups-manager, a GNOME administration GUI for the CUPS print system.
PR: 54516 Submitted by: Glenn Johnson <gjohnson@srrc.ars.usda.gov>
Diffstat (limited to 'print/gnome-cups-manager/Makefile')
-rw-r--r--print/gnome-cups-manager/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/print/gnome-cups-manager/Makefile b/print/gnome-cups-manager/Makefile
new file mode 100644
index 000000000000..bed6b0ba2a90
--- /dev/null
+++ b/print/gnome-cups-manager/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: gnome-cups-manager
+# Date created: 14 Jul 2003
+# Whom: Glenn Johnson <glennpj@charter.net>
+#
+# $FreeBSD$
+
+PORTNAME= gnome-cups-manager
+PORTVERSION= 0.17
+CATEGORIES= print gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.17
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Admistration tool for cups
+
+LIB_DEPENDS= gnomecups-1.0.1:${PORTSDIR}/print/libgnomecups
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack libgnomeprintui libgnomeui
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|' \
+ < ${FILESDIR}/gnome-cups-manager.desktop \
+ > ${WRKSRC}/gnome-cups-manager.desktop
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/gnome-cups-manager.desktop \
+ ${PREFIX}/share/gnome/applications
+
+.include <bsd.port.mk>