aboutsummaryrefslogtreecommitdiffstats
path: root/print/guitartex/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-07-25 00:34:30 +0800
committerijliao <ijliao@FreeBSD.org>2001-07-25 00:34:30 +0800
commitc56df404ae128a2932035dabdebd623f64c936f4 (patch)
tree0d02c1b8f9d44ddb968885d7f91ccbfaf3fe3e8f /print/guitartex/Makefile
parentd7aa2b45a2e1efe82c3db04f5d67d22f303bf45b (diff)
downloadfreebsd-ports-gnome-c56df404ae128a2932035dabdebd623f64c936f4.tar.gz
freebsd-ports-gnome-c56df404ae128a2932035dabdebd623f64c936f4.tar.zst
freebsd-ports-gnome-c56df404ae128a2932035dabdebd623f64c936f4.zip
add guitartex
GuitarTeX converts the Chord format into "normal" LaTeX format
Diffstat (limited to 'print/guitartex/Makefile')
-rw-r--r--print/guitartex/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/print/guitartex/Makefile b/print/guitartex/Makefile
new file mode 100644
index 000000000000..ab6157d18cd3
--- /dev/null
+++ b/print/guitartex/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# New ports collection makefile for: GuitarTeX
+# Date created: Jul 23, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= guitartex
+PORTVERSION= 2.4.1
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_BUILD= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk \
+ latex:${PORTSDIR}/print/latex
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s,\"(.*\.gif)\",\"${DATADIR}/\1\",g" ${WRKSRC}/guitartex
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/guitartex ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.gif ${WRKSRC}/*.ps ${DATADIR}
+
+.include <bsd.port.mk>