aboutsummaryrefslogtreecommitdiffstats
path: root/print/gv
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-02-12 09:11:28 +0800
committernaddy <naddy@FreeBSD.org>2003-02-12 09:11:28 +0800
commit8ba99a93b528dd3f99973354e8b848b6cafe46af (patch)
treef9cffc171863af56931a922acd41d244900f24b8 /print/gv
parent4c603117b11685f14dd4dacbe489c9740f67ff0c (diff)
downloadfreebsd-ports-gnome-8ba99a93b528dd3f99973354e8b848b6cafe46af.tar.gz
freebsd-ports-gnome-8ba99a93b528dd3f99973354e8b848b6cafe46af.tar.zst
freebsd-ports-gnome-8ba99a93b528dd3f99973354e8b848b6cafe46af.zip
Fix breakage introduced with recent security update.
PR: 47776 Submitted by: tmm
Diffstat (limited to 'print/gv')
-rw-r--r--print/gv/Makefile2
-rw-r--r--print/gv/files/patch-source::ps.c26
2 files changed, 27 insertions, 1 deletions
diff --git a/print/gv/Makefile b/print/gv/Makefile
index 0bd72391b7c2..c45ae71e9d43 100644
--- a/print/gv/Makefile
+++ b/print/gv/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gv
PORTVERSION= 3.5.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= ftp://ftpthep.physik.uni-mainz.de/pub/gv/unix/ \
${MASTER_SITE_TEX_CTAN}
diff --git a/print/gv/files/patch-source::ps.c b/print/gv/files/patch-source::ps.c
new file mode 100644
index 000000000000..88bd6361c2bc
--- /dev/null
+++ b/print/gv/files/patch-source::ps.c
@@ -0,0 +1,26 @@
+--- source/ps.c.orig Sat Feb 1 00:56:20 2003
++++ source/ps.c Sat Feb 1 01:17:43 2003
+@@ -1770,8 +1770,6 @@
+ (DSCcomment(line) && iscomment(line+2,(comment)))
+ #define IS_BEGIN(comment) \
+ (iscomment(line+7,(comment)))
+-#define IS_END(comment) \
+- (iscomment(line+5,(comment)))
+ #define SKIP_WHILE(cond) \
+ while (readline(fd, &line, NULL, &nbytes) && (cond)) *line_lenP += nbytes;\
+ skipped=1;
+@@ -1808,10 +1806,10 @@
+ #endif
+ if (!IS_COMMENT("Begin")) {} /* Do nothing */
+ else if IS_BEGIN("Document:") { /* Skip the EPS without handling its content */
+- while (line && !IS_END("Document")) {
+- line = ps_io_fgetchars(fd,-1);
+- if (line) *line_lenP += FD_LINE_LEN;
+- }
++ while ((line = ps_io_fgetchars(fd,-1)) && !IS_COMMENT("EndDocument"))
++ *line_lenP += FD_LINE_LEN;
++ nbytes = line ? FD_LINE_LEN : 0;
++ skipped = 1;
+ }
+ else if IS_BEGIN("Feature:") SKIP_UNTIL_1("EndFeature")
+ #ifdef USE_ACROREAD_WORKAROUND
1a436b25ac117fae658c55de3ebc7e517098afa'>activate imgvtopgmsumikawa1999-08-311-0/+1 * Palm Pilot Image Viewer to PGM Converter, which for converting Pilotsumikawa1999-08-315-0/+38 * $Id$ -> $FreeBSD$peter1999-08-309-9/+9 * 0.9.2 -> 0.9.3dima1999-08-216-70/+38 * Mark BROKEN: Ports are not allowed to touch anything outside ofmph1999-08-041-1/+3 * Commit #3/4 to enforce caps, no period.hoek1999-06-273-3/+3 * Add the syncal port.steve1999-06-091-1/+2 * Initial impoirt of syncal version 0.5.steve1999-06-096-0/+120 * Forget about ${PREFIX}/include/giflib.tg1999-05-271-3/+1 * Use KDE version 1.1 instead of version 1.0.steve1999-05-241-7/+7 * add WWW:mharo1999-05-033-6/+8 * * Location of binutils distfile moved-- add MASTER_SITE_SUBDIRnectar1999-04-241-1/+2 * Upgrade from 0.9.1 to 0.9.2mharo1999-04-234-8/+8 * Make DESCR more descriptive.chuckr1999-04-071-1/+16 * 0.9.0 -> 0.9.1dima1999-02-226-12/+18 * Remove BROKEN_ELF:dirk1999-02-031-3/+2 * Upgrade to 0.6.6.vanilla1999-01-244-40/+37 * Move Palm*-related programs to new "palm" category.asami1999-01-097-14/+14 * The new "palm" category for software to support 3Com Palm series of products.asami1999-01-092-0/+11 * Previous commit for ELF broke a.out.nectar1998-11-074-14/+46 * Add "pilot" to list of categories.asami1998-11-061-2/+2 * * Oops, I introduced a dependency on pilot-link in my last commit.nectar1998-11-042-9/+2 * * corrected CATEGORIES (from 'x11 kde' to 'comms kde')nectar1998-11-044-68/+55 * BROKEN for ELF:jseger1998-10-131-1/+3 * Unbreak for ELF.jseger1998-10-122-6/+2 * Mark for ELF:jseger1998-10-122-2/+6 * Mark BROKEN for ELF. This hasn't been updated with new library names.jseger1998-10-121-1/+3 * Elfifybrian1998-10-031-14/+7 * Unbreak it and also upgrade to v0.9.0dima1998-09-306-14/+22 * Mark all KDE ports BROKEN for ELF.jseger1998-09-301-1/+3 * Mark BROKEN:jseger1998-09-292-2/+6 * tk80 has been ELFized.asami1998-09-252-4/+4 * giflib is now converted to ELF so remove regexp support.steve1998-09-191-2/+2 * Roll back libXpm major to 4. Sorry, it wasn't a good idea to bump itasami1998-09-171-2/+2 * jpeg is now converted to ELF so change LIB_DEPENDS lines accordingly.asami1998-09-151-2/+2 * libXpm major is now 5. Also remove regexp support in preparation forasami1998-09-151-2/+2 * Drats. libjscript is still at 0.90.asami1998-08-251-2/+2 * kde shared libs are now at version 1. Gosh, no wonder they kept beingasami1998-08-251-7/+7 * Wow. Deleting manpages is a lot faster on bento.hoek1998-08-172-14/+0 * Mark BROKEN for current.jseger1998-08-161-1/+6 * Replace qt dependencies with USE_QT.asami1998-08-121-4/+3 * Remove manpages define in MAN? fom PLIST for all the devel ports.asami1998-08-121-20/+0 * Fix up dependencies for ports that moved into the x11-toolkits category.asami1998-08-083-7/+7 * Rename all USE_X11 to USE_X_PREFIX. Requires 1.279 (3.0-current) orasami1998-08-051-2/+2 * Remove non-existent file so this port packages. I'm not exactly sureasami1998-06-061-1/+0 * Fix shlib version number so this one packages.asami1998-06-052-2/+2 * Added check for "-m486" in CFLAGS &/or /etc/make.conf.dburr1998-05-271-1/+15 * 3.0 -> 3.0.2dima1998-05-212-4/+4 * Fix checksum.chuckr1998-05-141-1/+1 * 2.0 -> 3.0dima1998-05-125-23/+42 * 0.8.12 -> 0.8.13dima1998-05-124-8/+8 * 0.8.11 -> 0.8.12dima1998-05-114-10/+10 * 0.8.9 -> 0.8.11dima1998-05-074-8/+8 * Change JPEG shared library number to 9. This is to make sure that everyonejseger1998-05-051-2/+2 * Switch remaining ports to use jpeg lib version 8.0.jseger1998-04-161-2/+2 * Mark this port broken, it doesn't install. While I'm here,asami1998-03-171-4/+5 * Port of KPilot, the KDE style frontend to your 3Com PalmPilot.se1998-03-077-0/+118 * Use mtree/mkdir ${PREFIX} fix in rev 1.271 of bsd.port.mk. (I.e.,asami1998-02-193-15/+3 * Make sure ${PREFIX} exists (from prc-tools port).jkh1998-01-312-2/+8 * Take this port over from pst at his request. Move everything underjkh1998-01-164-10/+30 * Add four ports to "pilot" virtual category.asami1998-01-025-10/+10 * Package fixpst1997-12-172-2/+2 * Upgrade to 0.8.9pst1997-12-174-8/+8 * Force use of perl5 even if someone's got their path backwards.pst1997-12-012-4/+4 * It's not broken, also unspam CONFIGURE_ARGS change (+=, not =)pst1997-12-012-16/+4 * Change broken to trigger when an incompatible port has been installed.pst1997-12-012-6/+14 * Try to work around turds left by octave package.pst1997-12-012-2/+12 * Mark this BROKEN for 3.0 as well. Same libreadline problem.jseger1997-11-302-8/+2 * Fix strip problem.pst1997-11-251-7/+8 * Don't specify .gz in MAN1pst1997-11-252-8/+8 * Oops, that was not the problem -- fix PREFIX. Either way, I have noasami1997-11-251-5/+4 * Create ${PREFIX} (= ${LOCALBASE}/palm) before installing. mtree won'tasami1997-11-251-1/+4 * Portlint.asami1997-11-251-4/+6 * Mark it broken for 2.2 (libreadline version).asami1997-11-252-2/+12 * No need to use += for CONFIGURE_ARGS.asami1997-11-252-4/+4 * Strip binariespst1997-11-241-1/+23 * Forgot to add MAN1= stuff.pst1997-11-242-2/+10 * pilot-link is a set of utilities for linking with the PalmPilot PDA.pst1997-11-2414-0/+424 * prc-tools is a complete software development environment for creatingpst1997-11-245-0/+451