aboutsummaryrefslogtreecommitdiffstats
path: root/print/harfbuzz
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-05-18 02:44:50 +0800
committerkwm <kwm@FreeBSD.org>2013-05-18 02:44:50 +0800
commitbb1000ee977752ca5a3ffdb9d562e177446630f4 (patch)
tree6087d114667ec2a8792617b7e8e4d527c4425524 /print/harfbuzz
parent51ef5c0827fe4de7f257fae988e2e266e41efbd1 (diff)
downloadfreebsd-ports-gnome-bb1000ee977752ca5a3ffdb9d562e177446630f4.tar.gz
freebsd-ports-gnome-bb1000ee977752ca5a3ffdb9d562e177446630f4.tar.zst
freebsd-ports-gnome-bb1000ee977752ca5a3ffdb9d562e177446630f4.zip
Update to 0.9.16.
Diffstat (limited to 'print/harfbuzz')
-rw-r--r--print/harfbuzz/Makefile11
-rw-r--r--print/harfbuzz/distinfo4
-rw-r--r--print/harfbuzz/files/patch-configure214
-rw-r--r--print/harfbuzz/pkg-plist2
4 files changed, 168 insertions, 63 deletions
diff --git a/print/harfbuzz/Makefile b/print/harfbuzz/Makefile
index 4f3ffbde1d64..21cbdb32ce31 100644
--- a/print/harfbuzz/Makefile
+++ b/print/harfbuzz/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= harfbuzz
-PORTVERSION= 0.9.14
+PORTVERSION= 0.9.16
CATEGORIES= print
MASTER_SITES= http://www.freedesktop.org/software/harfbuzz/release/
@@ -15,9 +15,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
USES= pathfix pkgconfig
-USE_GNOME= glib20
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules
+USE_GNOME= glib20 ltverhack
+USE_AUTOTOOLS= libtool
.include <bsd.port.pre.mk>
@@ -25,4 +24,8 @@ CONFIGURE_ARGS= --disable-silent-rules
EXTRA_PATCHES= ${PATCHDIR}/extra-src_hb-open-type-private.hh
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|^build_old_libs=yes|build_old_libs=no|g' \
+ ${WRKDIR}/gnome-libtool
+
.include <bsd.port.post.mk>
diff --git a/print/harfbuzz/distinfo b/print/harfbuzz/distinfo
index 81d7f2685bea..cc0d1ea6d22a 100644
--- a/print/harfbuzz/distinfo
+++ b/print/harfbuzz/distinfo
@@ -1,2 +1,2 @@
-SHA256 (harfbuzz-0.9.14.tar.bz2) = d07c0ffdbbbfdfbb6c65e73fe9c76466e87dbf04b094cbd0abf5fd7d571a4004
-SIZE (harfbuzz-0.9.14.tar.bz2) = 900959
+SHA256 (harfbuzz-0.9.16.tar.bz2) = 6da7e032f705d8a5c91487cd296628d64975672a5b0c1704829cf2285072c92b
+SIZE (harfbuzz-0.9.16.tar.bz2) = 902208
diff --git a/print/harfbuzz/files/patch-configure b/print/harfbuzz/files/patch-configure
index a35d10d1face..608490a965c0 100644
--- a/print/harfbuzz/files/patch-configure
+++ b/print/harfbuzz/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2013-03-28 14:35:03.000000000 +0000
-+++ configure 2013-03-28 14:35:49.000000000 +0000
-@@ -17114,553 +17114,20 @@
+--- configure.orig 2013-04-21 11:02:00.000000000 +0000
++++ configure 2013-04-21 11:07:06.000000000 +0000
+@@ -17019,655 +17019,31 @@
@@ -87,12 +87,12 @@
HAVE_CAIRO_FALSE=
-fi
-
--
--
+
+
-pkg_failed=no
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for CAIRO_FT" >&5
-$as_echo_n "checking for CAIRO_FT... " >&6; }
--
+
-if test -n "$PKG_CONFIG"; then
- if test -n "$CAIRO_FT_CFLAGS"; then
- pkg_cv_CAIRO_FT_CFLAGS="$CAIRO_FT_CFLAGS"
@@ -160,7 +160,7 @@
- have_cairo_ft=true
-fi
-if $have_cairo_ft; then
-
+-
-$as_echo "#define HAVE_CAIRO_FT 1" >>confdefs.h
-
-fi
@@ -232,7 +232,7 @@
- fi
- # Put the nasty error message in config.log where it belongs
- echo "$ICU_PKG_ERRORS" >&5
-
+-
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
- have_icu=false
@@ -246,26 +246,65 @@
- have_icu=true
-fi
-if test "$have_icu" != "true"; then
-- # Extract the first word of "icu-config", so it can be a program name with args.
+- if test -n "$ac_tool_prefix"; then
+- # Extract the first word of "${ac_tool_prefix}icu-config", so it can be a program name with args.
+-set dummy ${ac_tool_prefix}icu-config; ac_word=$2
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+-$as_echo_n "checking for $ac_word... " >&6; }
+-if ${ac_cv_prog_ICU_CONFIG+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- if test -n "$ICU_CONFIG"; then
+- ac_cv_prog_ICU_CONFIG="$ICU_CONFIG" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
+- ac_cv_prog_ICU_CONFIG="${ac_tool_prefix}icu-config"
+- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+- done
+-IFS=$as_save_IFS
+-
+-fi
+-fi
+-ICU_CONFIG=$ac_cv_prog_ICU_CONFIG
+-if test -n "$ICU_CONFIG"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ICU_CONFIG" >&5
+-$as_echo "$ICU_CONFIG" >&6; }
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-fi
+-
+-
+-fi
+-if test -z "$ac_cv_prog_ICU_CONFIG"; then
+- ac_ct_ICU_CONFIG=$ICU_CONFIG
+- # Extract the first word of "icu-config", so it can be a program name with args.
-set dummy icu-config; ac_word=$2
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-$as_echo_n "checking for $ac_word... " >&6; }
--if ${ac_cv_path_icu_config+:} false; then :
+-if ${ac_cv_prog_ac_ct_ICU_CONFIG+:} false; then :
- $as_echo_n "(cached) " >&6
-else
-- case $icu_config in
-- [\\/]* | ?:[\\/]*)
-- ac_cv_path_icu_config="$icu_config" # Let the user override the test with a path.
-- ;;
-- *)
-- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+- if test -n "$ac_ct_ICU_CONFIG"; then
+- ac_cv_prog_ac_ct_ICU_CONFIG="$ac_ct_ICU_CONFIG" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
-- ac_cv_path_icu_config="$as_dir/$ac_word$ac_exec_ext"
+- ac_cv_prog_ac_ct_ICU_CONFIG="icu-config"
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
@@ -273,31 +312,43 @@
- done
-IFS=$as_save_IFS
-
-- test -z "$ac_cv_path_icu_config" && ac_cv_path_icu_config="no"
-- ;;
--esac
-fi
--icu_config=$ac_cv_path_icu_config
--if test -n "$icu_config"; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $icu_config" >&5
--$as_echo "$icu_config" >&6; }
+-fi
+-ac_ct_ICU_CONFIG=$ac_cv_prog_ac_ct_ICU_CONFIG
+-if test -n "$ac_ct_ICU_CONFIG"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_ct_ICU_CONFIG" >&5
+-$as_echo "$ac_ct_ICU_CONFIG" >&6; }
-else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
-fi
-
+- if test "x$ac_ct_ICU_CONFIG" = x; then
+- ICU_CONFIG="no"
+- else
+- case $cross_compiling:$ac_tool_warned in
+-yes:)
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
+-$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
+-ac_tool_warned=yes ;;
+-esac
+- ICU_CONFIG=$ac_ct_ICU_CONFIG
+- fi
+-else
+- ICU_CONFIG="$ac_cv_prog_ICU_CONFIG"
+-fi
-
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for ICU by using icu-config fallback" >&5
-$as_echo_n "checking for ICU by using icu-config fallback... " >&6; }
-- if test "$icu_config" != "no" && "$icu_config" --version >/dev/null; then
+- if test "$ICU_CONFIG" != "no" && "$ICU_CONFIG" --version >/dev/null; then
- have_icu=true
- # We don't use --cflags as this gives us a lot of things that we don't
- # necessarily want, like debugging and optimization flags
- # See man (1) icu-config for more info.
-- ICU_CFLAGS=`$icu_config --cppflags`
-- ICU_LIBS=`$icu_config --ldflags-libsonly`
--
--
+- ICU_CFLAGS=`$ICU_CONFIG --cppflags`
+- ICU_LIBS=`$ICU_CONFIG --ldflags-libsonly`
+
+
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; }
- else
@@ -305,10 +356,10 @@
-$as_echo "no" >&6; }
- fi
-fi
--
+
-if $have_icu; then
- CXXFLAGS="$CXXFLAGS `$PKG_CONFIG --variable=CXXFLAGS icu-uc`"
--
+
-$as_echo "#define HAVE_ICU 1" >>confdefs.h
-
-fi
@@ -364,8 +415,8 @@
- pkg_failed=untried
-fi
-
--
--
+
+
-if test $pkg_failed = yes; then
-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
@@ -380,7 +431,7 @@
- fi
- # Put the nasty error message in config.log where it belongs
- echo "$ICU_LE_PKG_ERRORS" >&5
--
+
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
- have_icu_le=false
@@ -394,26 +445,65 @@
- have_icu_le=true
-fi
-if test "$have_icu_le" != "true"; then
-- # Extract the first word of "icu-config", so it can be a program name with args.
+- if test -n "$ac_tool_prefix"; then
+- # Extract the first word of "${ac_tool_prefix}icu-config", so it can be a program name with args.
+-set dummy ${ac_tool_prefix}icu-config; ac_word=$2
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+-$as_echo_n "checking for $ac_word... " >&6; }
+-if ${ac_cv_prog_ICU_CONFIG+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- if test -n "$ICU_CONFIG"; then
+- ac_cv_prog_ICU_CONFIG="$ICU_CONFIG" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
+- ac_cv_prog_ICU_CONFIG="${ac_tool_prefix}icu-config"
+- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+- done
+-IFS=$as_save_IFS
+-
+-fi
+-fi
+-ICU_CONFIG=$ac_cv_prog_ICU_CONFIG
+-if test -n "$ICU_CONFIG"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ICU_CONFIG" >&5
+-$as_echo "$ICU_CONFIG" >&6; }
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-fi
+-
+-
+-fi
+-if test -z "$ac_cv_prog_ICU_CONFIG"; then
+- ac_ct_ICU_CONFIG=$ICU_CONFIG
+- # Extract the first word of "icu-config", so it can be a program name with args.
-set dummy icu-config; ac_word=$2
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-$as_echo_n "checking for $ac_word... " >&6; }
--if ${ac_cv_path_icu_config+:} false; then :
+-if ${ac_cv_prog_ac_ct_ICU_CONFIG+:} false; then :
- $as_echo_n "(cached) " >&6
-else
-- case $icu_config in
-- [\\/]* | ?:[\\/]*)
-- ac_cv_path_icu_config="$icu_config" # Let the user override the test with a path.
-- ;;
-- *)
-- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+- if test -n "$ac_ct_ICU_CONFIG"; then
+- ac_cv_prog_ac_ct_ICU_CONFIG="$ac_ct_ICU_CONFIG" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
-- ac_cv_path_icu_config="$as_dir/$ac_word$ac_exec_ext"
+- ac_cv_prog_ac_ct_ICU_CONFIG="icu-config"
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
@@ -421,29 +511,41 @@
- done
-IFS=$as_save_IFS
-
-- test -z "$ac_cv_path_icu_config" && ac_cv_path_icu_config="no"
-- ;;
--esac
-fi
--icu_config=$ac_cv_path_icu_config
--if test -n "$icu_config"; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $icu_config" >&5
--$as_echo "$icu_config" >&6; }
+-fi
+-ac_ct_ICU_CONFIG=$ac_cv_prog_ac_ct_ICU_CONFIG
+-if test -n "$ac_ct_ICU_CONFIG"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_ct_ICU_CONFIG" >&5
+-$as_echo "$ac_ct_ICU_CONFIG" >&6; }
-else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
-fi
-
+- if test "x$ac_ct_ICU_CONFIG" = x; then
+- ICU_CONFIG="no"
+- else
+- case $cross_compiling:$ac_tool_warned in
+-yes:)
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
+-$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
+-ac_tool_warned=yes ;;
+-esac
+- ICU_CONFIG=$ac_ct_ICU_CONFIG
+- fi
+-else
+- ICU_CONFIG="$ac_cv_prog_ICU_CONFIG"
+-fi
-
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for ICU_LE by using icu-config fallback" >&5
-$as_echo_n "checking for ICU_LE by using icu-config fallback... " >&6; }
-- if test "$icu_config" != "no" && "$icu_config" --version >/dev/null; then
+- if test "$ICU_CONFIG" != "no" && "$ICU_CONFIG" --version >/dev/null; then
- have_icu_le=true
- # We don't use --cflags as this gives us a lot of things that we don't
- # necessarily want, like debugging and optimization flags
- # See man (1) icu-config for more info.
-- ICU_LE_CFLAGS=`$icu_config --cppflags`
-- ICU_LE_LIBS=`$icu_config --ldflags-libsonly --ldflags-layout`
+- ICU_LE_CFLAGS=`$ICU_CONFIG --cppflags`
+- ICU_LE_LIBS=`$ICU_CONFIG --ldflags-libsonly --ldflags-layout`
-
-
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
@@ -466,13 +568,13 @@
HAVE_ICU_LE_FALSE=
-fi
-
--
--
+
+
-pkg_failed=no
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for GRAPHITE2" >&5
-$as_echo_n "checking for GRAPHITE2... " >&6; }
--
+
-if test -n "$PKG_CONFIG"; then
- if test -n "$GRAPHITE2_CFLAGS"; then
- pkg_cv_GRAPHITE2_CFLAGS="$GRAPHITE2_CFLAGS"
diff --git a/print/harfbuzz/pkg-plist b/print/harfbuzz/pkg-plist
index ff4ff150abe7..8f3d80f69da1 100644
--- a/print/harfbuzz/pkg-plist
+++ b/print/harfbuzz/pkg-plist
@@ -18,6 +18,6 @@ include/harfbuzz/hb-version.h
include/harfbuzz/hb.h
lib/libharfbuzz.la
lib/libharfbuzz.so
-lib/libharfbuzz.so.914
+lib/libharfbuzz.so.0
libdata/pkgconfig/harfbuzz.pc
@dirrm include/harfbuzz