aboutsummaryrefslogtreecommitdiffstats
path: root/print/html2ps-a4
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>1998-05-18 04:14:41 +0800
committerandreas <andreas@FreeBSD.org>1998-05-18 04:14:41 +0800
commitb2dc42752760d45e0671f3ab6f742bbe8bd2f385 (patch)
tree809a86807597851dea6bfcdab758e1f13dcb59d3 /print/html2ps-a4
parent3a7acef45a5041f02cae4912b74b9e58d00a8a94 (diff)
downloadfreebsd-ports-gnome-b2dc42752760d45e0671f3ab6f742bbe8bd2f385.tar.gz
freebsd-ports-gnome-b2dc42752760d45e0671f3ab6f742bbe8bd2f385.tar.zst
freebsd-ports-gnome-b2dc42752760d45e0671f3ab6f742bbe8bd2f385.zip
Import of html2ps 0.1 a HTML to PostScript converter with lot's of features.
Diffstat (limited to 'print/html2ps-a4')
-rw-r--r--print/html2ps-a4/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/print/html2ps-a4/Makefile b/print/html2ps-a4/Makefile
new file mode 100644
index 000000000000..6d178920337b
--- /dev/null
+++ b/print/html2ps-a4/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: html2ps
+# Version required: 1.0b1
+# Date created: Sat Nov 22 12:54:50 CET 1997
+# Whom: andreas
+#
+# $Id: Makefile,v 1.8 1997/11/17 16:18:35 rse Exp $
+#
+
+DISTNAME= html2ps-1.0b1
+PKGNAME= html2ps-1.0
+CATEGORIES= lang www perl5
+MASTER_SITES= http://www.tdb.uu.se/~jan/
+
+MAINTAINER= andreas@FreeBSD.ORG
+
+BUILD_DEPENDS= mogrify:${PORTSDIR}/graphics/ImageMagick \
+ djpeg:${PORTSDIR}/graphics/jpeg \
+ giftopnm:${PORTSDIR}/graphics/netpbm \
+ ${site_perl}/Image/Magick.pm:${PORTSDIR}/graphics/p5-PerlMagick \
+ gs:${PORTSDIR}/print/ghostscript5 \
+ tex:${PORTSDIR}/print/teTeX \
+ ${site_perl}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ weblint:${PORTSDIR}/www/weblint
+
+site_perl= ${PREFIX}/lib/perl5/site_perl
+USE_PERL5= YES
+NO_BUILD= YES
+IS_INTERACTIVE= YES
+
+MAN1= html2ps.1
+MAN5= html2psrc.5
+
+do-install:
+ @cd ${WRKSRC}; ${PREFIX}/bin/perl5 install
+
+.include <bsd.port.mk>